New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Mar 8, 2016 #9501 of 12951
    wireman121

    wireman121 Member

    141
    1
    Nov 8, 2008

    Advertisements

    When it happens again I will take some screenshots and save the log file


    Sent from my iPhone using Tapatalk
     
  2. Mar 9, 2016 #9502 of 12951
    moyekj

    moyekj Well-Known Member

    12,324
    958
    Jan 23, 2006
    Mission...
    For next release I've fixed a long standing issue where when a task fails subsequent dependent tasks are not killed. So, for example, if a download fails then all other associated tasks related to download are removed from job queue.
     
  3. Mar 9, 2016 #9503 of 12951
    snedecor

    snedecor Member

    88
    1
    Jun 27, 2001
    Angleton, TX
    I saw some discussion earlier about accessing TiVo's skip data, but I didn't quite get if autoskip can access the data to automatically skip through the video files that have Tivo-generated skip data,(not comskip or VrDo generated).

    Is this possible?

    Thanks,

    Snedecor
     
  4. Mar 9, 2016 #9504 of 12951
    moyekj

    moyekj Well-Known Member

    12,324
    958
    Jan 23, 2006
    Mission...
    No. Currently you have to generate the skip data yourself with help of comskip or VRD.

    I can actually write a program that emulates button D/channel Up presses to find the show start points, but the problem is for auto skip you also need the show end points. If there was a way to jump to start of a commercial by pressing a button on remote then that would be all the information needed for auto skip.
     
  5. Mar 9, 2016 #9505 of 12951
    snedecor

    snedecor Member

    88
    1
    Jun 27, 2001
    Angleton, TX

    Advertisements

    When you get to the end of the show and the commercial starts, the UI sends out a "tinkle" sound and puts up an onscreen reminder. Any way you can snoop in and see those remotely? Are the skip point embedded in the TiVo file (doubtful) or somewhere else in the file system, if so, I guess they are inaccessible, right?
     
  6. Mar 9, 2016 #9506 of 12951
    moyekj

    moyekj Well-Known Member

    12,324
    958
    Jan 23, 2006
    Mission...
    There's nothing indicated via RPC monitoring when the UI does that AFAICT. There is skip data available from the original author's DVR, but that data without the accompanying CC sync data is useless because the time points don't match up to your DVR. And making the assumption that the length of the commercial segements is the same on that author's DVR and your local DVR I don't think holds true, so a combination of knowing your show start points + original SKIP author points is still not sufficient to get accurate end points.

    Also, at least for me, what's more interesting is finding a way to share skip data for shows that don't have TiVo SKIP - I'm fine with pressing a button to skip commercials for those with TiVo SKIP. It's the shows that don't have TiVo SKIP that I want a way to skip commercials for using AutoSkip.
     
  7. Mar 9, 2016 #9507 of 12951
    snedecor

    snedecor Member

    88
    1
    Jun 27, 2001
    Angleton, TX
    Yep, quite true. Skipmode is a real game changer and had made me a true believer again. I had strayed into the Windows Media Center world until MS abandoned it, but with the Roamio, with skipmode, and now with KmTTg's AutoSkip, I'm in hog heaven!
     
  8. Mar 10, 2016 #9508 of 12951
    snedecor

    snedecor Member

    88
    1
    Jun 27, 2001
    Angleton, TX
    I have Autoskip service enabled on a Roamio Pro. It works as expected watching shows on that Roamio. However, I was under the impression it Autoskipped while streaming as well. I have a Roamio OTA that I started viewing the video (did not transfer, just played) and the Autoskip does not seem to work on the Roamio OTA playing content from the Roamio Pro which is being monitored by Autoskip service.

    Is this expected behavior?
     
  9. Mar 10, 2016 #9509 of 12951
    moyekj

    moyekj Well-Known Member

    12,324
    958
    Jan 23, 2006
    Mission...
    Yes it should work, but you have to be running AutoSkip service on the series 4 or later machine you are viewing at, so in this case the Roamio OTA. I suspect you are probably running service on the Pro.
     
  10. Mar 10, 2016 #9510 of 12951
    snedecor

    snedecor Member

    88
    1
    Jun 27, 2001
    Angleton, TX
    You are correct, sir, thanks!

    So, Do I need an instance of kmttg running for each TiVo that I want AutoSkip service?

    Can two instances play nicely on a single machine?
     
  11. Mar 10, 2016 #9511 of 12951
    moyekj

    moyekj Well-Known Member

    12,324
    958
    Jan 23, 2006
    Mission...
    If you want to run more than 1 AutoSkip at a time you should use individual kmttg instances and it's best to have them installed in different directories if you are doing anything else with them at same time. If it's just for AutoSkip and nothing else (with no changes being made and no downloads being run, etc) then it should be OK to run multiple instances from same directory. Just be careful with multiple instances not to do downloads or anything else because TiVos only like/accept one download at a time.
     
  12. Mar 11, 2016 #9512 of 12951
    davidblackledge

    davidblackledge Registered lÜser

    565
    36
    Sep 9, 2008
    NM
    Just a thought: if you can detect that somebody is playing back a recording that has SkipMode (or maybe even just any play back), just continuously send a "Page Up" every second or so. Shouldn't effect anything (or does it bonk?) and would accomplish the task within 1 second of the desired time.
     
  13. Mar 11, 2016 #9513 of 12951
    moyekj

    moyekj Well-Known Member

    12,324
    958
    Jan 23, 2006
    Mission...
    Sending a "Channel Up" or "D" press will skip to next segment regardless if you are in commercials or not, so that won't work.
     
  14. Mar 11, 2016 #9514 of 12951
    davidblackledge

    davidblackledge Registered lÜser

    565
    36
    Sep 9, 2008
    NM
    d'oh that's right. That seemed like an odd element of SkipMode...and now it's annoying ;]
     
  15. Mar 12, 2016 #9515 of 12951
    moyekj

    moyekj Well-Known Member

    12,324
    958
    Jan 23, 2006
    Mission...
    v2.1m version is now released with various bug fixes. Consult release_notes Wiki for details.
     
  16. Mar 12, 2016 #9516 of 12951
    reneg

    reneg Well-Known Member

    1,156
    236
    Jun 19, 2002
    Thanks for adding "Update to captions task to try again with special command line options if first attempt without special options fails." I tested this today and it works great.

    One thing I omitted from the 708 captions command string was the output file name which causes ccextractor to default it's output file name. That doesn't bother me because I see both the zero length .srt file from the 608 captions, and the second .srt file from the 708 captions. Others might wonder why the second .srt file name is there and named differently.

    To specify an output filename, the command string would also need to include -o <outputfile>
     
  17. Mar 12, 2016 #9517 of 12951
    moyekj

    moyekj Well-Known Member

    12,324
    958
    Jan 23, 2006
    Mission...
    OK thanks, I've made that update for next release.
     
  18. Mar 12, 2016 #9518 of 12951
    TIVO_GUY_HERE

    TIVO_GUY_HERE I miss the ocean

    7,219
    319
    Jul 10, 2000
    Dallas Texas
    I am installing this on a friends win 10 laptop. And the same thing happened to me, that happening to him.

    1 I went to 1st post and went to link for the 2.1m version,
    downloaded, unzipped it to a folder in his user download directory
    Clicked the Jar file it says tools isn't installed, download and install?
    click yes, it then pops up for a second with a confirm window ( I believe its the MAK window, but the MAK isn't there, just confirm window, like I said, it pops up for 1 sec then goes away, then it just sits and does nothing.

    2 I have unzipped to other locations on his pc, ( he probably has 4-5 by now) and all do the same thing?

    his son has a windows 7 PC and it downloaded and worked, with just 1 click of the jar file after unzipping.
     
  19. Mar 12, 2016 #9519 of 12951
    moyekj

    moyekj Well-Known Member

    12,324
    958
    Jan 23, 2006
    Mission...
    Just tried a fresh download and install of 2.1m on a Win 10 laptop and everything worked normally for me. Try the following.
    Double click kmttg.jar.
    Choose Cancel for tool download and for entering MAK if prompted.
    Then choose Help->Update tools and OK
    If that works then go to File-Configure-Program Options and enter the 10 digit MAK there.
     
  20. Mar 12, 2016 #9520 of 12951
    TIVO_GUY_HERE

    TIVO_GUY_HERE I miss the ocean

    7,219
    319
    Jul 10, 2000
    Dallas Texas
    I tried that, clicking cancel and clicking the X, thinking I could download the tools manually ( I have) and it still does the quick pop up, and the kttmg screen closes also.

    Also tried stopping his virus, firewall, thinking that would help, but no.
     

Share This Page

spam firewall

Advertisements