New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Sep 14, 2014 #7181 of 12951
    Soapm

    Soapm Active Member

    1,671
    10
    May 9, 2007
    Aurora, CO

    Advertisements


    Just checking, you say using the "flow" I use, how can I do them differently?

    Is the behavior with VideoRedo Plus? As in would switching to TVSuite change what I'm experiencing?

    What about my suggestion of exempting "qs fix" and "ad scan" from the "multiple job rule"? Is that possible? That should allow those task to open their own VideoRedo GUI, do it's thing and close without impacting the one pending a "vrdreview" task.
     
  2. Sep 16, 2014 #7182 of 12951
    rgr

    rgr Member

    676
    58
    Feb 21, 2003
    Running 1.1c under ubuntu and just got the 20.4.4au update on my Roamio Plus.

    Somehow Spotify is showing twice in the Music & Photos menu and I was instructed by TiVo support to do two service connections to clear that up. In my experience a reboot is also needed, so I used kmttg to do so. Used the reboot button - and no reboot and the TiVo was unresponsive to the remote. I could see the light flash on the unit when a remote key was pressed, so that part worked. But the unit wouldn't do anything the remote told it to. Ended up having to unplug the unit and plug it back in.

    This happened twice and I don't want to test the reboot button just to see it not work again - twice is enough for me.

    Can you look into this and see if the new software is causing reboot button not to work as designed?

    Thanks.
     
  3. Sep 16, 2014 #7183 of 12951
    moyekj

    moyekj Well-Known Member

    12,324
    958
    Jan 23, 2006
    Mission...
    I don't have the new software yet, so can't check.
     
  4. Sep 16, 2014 #7184 of 12951
    BigT4187

    BigT4187 WDW Nut

    151
    0
    Jul 24, 2006
    GSP Exit 17
    Can someone please confirm that kmttg will work with a Roamio? I love the software with my Premiere, but want to make sure kmttg will work if I get a Roamio. Thanks.
     
  5. Sep 16, 2014 #7185 of 12951
    jcthorne

    jcthorne Well-Known Member

    3,116
    196
    Jan 28, 2002
    Houston

    Advertisements

    Yes, works great.
     
  6. Sep 16, 2014 #7186 of 12951
    lpwcomp

    lpwcomp Well-Known Member

    9,461
    298
    May 6, 2002
    John's...
    Same here, using 1.1d_beta. Roamio Basic w/20.4.4a
     
  7. Sep 16, 2014 #7187 of 12951
    murgatroyd

    murgatroyd Don't stop believin'

    26,095
    256
    Jan 5, 2002
    Berkeley CA
    "middlemindError"

    :(
     
  8. Sep 20, 2014 #7188 of 12951
    innocentfreak

    innocentfreak Well-Known Member

    9,234
    54
    Aug 25, 2001
    Florida
    Just a few notes on the new season passes.

    -They show up when refreshing the season pass list.

    -If you try to schedule a season pass you already set for all channels, the show won't prompt to modify. KMTTG or the TiVo treats it like a different SP.

    -The IOS app only gives the option to create a season pass when searching so it will probably need an update to address this so it might be a different command.

    -Searches for me seem a little funky post update via KMTTG. I am not finding some of the new shows, but they are there when I use KMTTG to view the guide data for the day, time, channel. Examples: selfie, stalker, and I forget the other ones now.
     
  9. Sep 20, 2014 #7189 of 12951
    lpwcomp

    lpwcomp Well-Known Member

    9,461
    298
    May 6, 2002
    John's...
    You might try "Selfie" again. "Stalker" shows up in the last day of the guide but shows no upcoming episodes. TiVos have had problems with data from the last day for a long time.
     
  10. Sep 20, 2014 #7190 of 12951
    innocentfreak

    innocentfreak Well-Known Member

    9,234
    54
    Aug 25, 2001
    Florida
    Selfie for me still only finds the episode from Faking It.

    EDIT: Weird it only works on one of my three boxes. The other two show only faking it.
     
  11. Sep 26, 2014 #7191 of 12951
    tsool

    tsool New Member

    3
    0
    Nov 26, 2013
    Hey all,

    ever since switching to Transport Stream Tivo files and decryption with VideoRecode all was a bliss. Now all over sudden I get the crazy download interruptions again - even with Transport Stream. The download stops approximately at 50% and I have no idea how to fix it other than to watch the episode on my iPad using Tivo Stream...

    I tried to read up on this very thread, but I think nobody has reported yet these issues with TS files.

    Is this known or is there even a walkaround?
     
  12. Sep 26, 2014 #7192 of 12951
    species8472jj

    species8472jj Member

    61
    0
    Dec 23, 2009
    I posted a couple weeks ago an issue where the scenemarkers were not appearing in Comskips output of a VideoRedo file (when opening the file in VideoRedo.

    Post-processing is possible as I wrote a Word macro / batch file to make the proper edits to the file.

    I added it to the custom option to KMTTG, so the macro runs last and fixes the VRD file.

    I've only tested it on a couple files, but so far so good. Maybe a couple tweaks left, but I think it is ready.

    I can certainly share it (or at least the logic) to repair the file if anyone is interested.
     
  13. Oct 1, 2014 #7193 of 12951
    wireman121

    wireman121 Member

    141
    1
    Nov 8, 2008

    I also just recently noticed the scene markers not showing up in VRD for review. In addition to that, I noticed, with the new VRD Review script, if there is an error that pops up when kmttg attempts to run VRD for review, instead of staying open after pressing OK on the error, VRD closes and causes kmttg to think it is done processing a file. Here is an example:

    I run kmttg on a separate PC which I remote desktop into to review edits. Before the VRDReview script was implemented, VRD would pop up and give an error that it couldn't open video output (because once you remote desktop in and close the connection, while everything is running in the background, it isn't outputting anywhere.) Normally this wasn't a problem because I could just click OK and then reopen the project without VRD closing, so once I saved and closed the edits, kmttg would see it and make the cuts.... With the recent changes, once I clicked OK on the video error, VRD would immediately close and kmttg would start making cuts, without the ability to review. I was able to edit the new script and get it working properly again, but it was a pain. (Generally I am editing all of the scripts every time theres an update to repair the problem with kmttg not properly seeing which version is running and getting VRD to hide in the taskbar...but that's a entirely different topic...

    Anyway - I would be interested in the changes you made to bring the scene markers back to the VRD Review.
     
  14. Oct 1, 2014 #7194 of 12951
    wireman121

    wireman121 Member

    141
    1
    Nov 8, 2008
    species8472jj, looks like I replied too soon. A quick google search found that the comskip.ini file changed in the most recent version. Seems an option (output_videoredo3) was added to write VRD files for the new v5 beta of VRD that's out. Seems its not working quite right yet (and is only for those using the v5 beta.) Looks like its been enabled by default. The easy solution is the following:

    Open your comskip.ini file and make the following changes:

    output_videoredo=1
    output_videoredo3=0

    Save and close and VRD should start working correctly again and showing scene markers. - assuming youre still using an older version of VRD. Looks like comskip isn't writing the files properly for VRD v5, even with the options enabled properly.
     
  15. Oct 1, 2014 #7195 of 12951
    wireman121

    wireman121 Member

    141
    1
    Nov 8, 2008
    moyekj, noticed with the new VRDreview.vbs, highlighting the VRDReview task and clicking cancel no longer terminates the open VRD window - assuming this is because the script is now running VRD instead of kmttg running it directly?

    Also - I'd be interested in sharing my modified VRD VB script files with you to get things working properly with VRD V3 without requiring me to make edits every time a new version downloads, while not breaking compatibility with v4 and v5, if you're interested...
     
  16. Oct 1, 2014 #7196 of 12951
    moyekj

    moyekj Well-Known Member

    12,324
    958
    Jan 23, 2006
    Mission...
    wireman121, I have a fix in place checked in already that I mentioned a while back (fixing incorrect comskip output), I just haven't got around to releasing a new version of kmttg yet. Since I haven't made any changes since then and no plans for any kmttg changes anytime soon I'll probably just go ahead and release kmttg in next few days that will have the fix you need.
     
  17. Oct 1, 2014 #7197 of 12951
    nooneuknow

    nooneuknow Well-Known Dismembered Member (Lurk Mode On)

    3,560
    6
    Feb 5, 2011
    Whitewater, WI
    Any chance you could slip-in the ability to change an all-channel SP to the appropriate single channel, once within the 12-day window, and the TiVo allows the change, but KMTTG requires deleting the SP and making a new one, if you want to use KMTTG?

    Or, are you still not updated to the 20.4.4a software?

    I try to use KMTTG for everything to do with SPs, and have three base-Roamios to wrangle and get all the programs.

    The new up to 6-months out w/series ID allowing for an all-channels SP is great, until the TiVo knows the channels, and tries to record on all of them, creating excessive false conflicts to weed through.

    Is there any way to filter down what are "real conflicts", as opposed to conflicts that are superficial?

    I hate to even ask for more, given how great KMTTG is, and free of charge.
     
  18. Oct 2, 2014 #7198 of 12951
    Prestond

    Prestond Member

    53
    0
    Feb 4, 2008
    Well moyekj I was first poster to respond to your announcement of the kmttg and here we are 6 years later and this program and my tivo still going strong!

    Thanks for such a great product! Still works like a charm!
     
  19. Oct 2, 2014 #7199 of 12951
    chuck95

    chuck95 Member

    32
    0
    Sep 12, 2008
    Maybe this is obvious, but I can't figure out how to set the path (destination folder) for auto transfers. All the shows I download manually go to the folder specified in the "file settings" tab. But all my auto transfers go to the folder where the kmttg program files live. Am I missing something, or can this destination not be changed?
    Thanks.
     
  20. Oct 2, 2014 #7200 of 12951
    moyekj

    moyekj Well-Known Member

    12,324
    958
    Jan 23, 2006
    Mission...
    Windows has some stupid service mode limitations, so paths normally available to you may not be in service mode. To rectify:
    1. Make sure service is running using your account, not default Windows service account.
    2. If it's a network path mounted as a volume that doesn't work in service mode, so use UNC path instead:
    \\host\share
     

Share This Page

spam firewall

Advertisements