Netflix not working on Elite

Discussion in 'TiVo Help Center' started by jshore, Oct 15, 2011.

  1. jshore

    jshore Member

    147
    0
    Aug 17, 2003
    Anybody with an Elite actually able to watch shows/movies on Netflix? My Netflix (along with Hulu Plus, Blockbuster, etc) showed up from the very beginning and i was able to activate it no problem, so i just assumed it was working. But i tried playing a variety of shows in my queue this morning and got the same error on all of them. Something like "There was an error communicating with Netflix. Please try again."

    Anyone with an Elite actually able to watch Netflix? If so, wondering how you did it.

    Thanks!

    ps hopefully TiVo will fix the Phoenix DST bug when they fix this!
     
  2. jay_man2

    jay_man2 jay_man-also TCF Club

    7,134
    2,035
    Sep 14, 2003
    Northern VA
    Nobody who has the issue has reported success yet. Much discussion about this in the 4 or 5 other Elite threads.
     
  3. Balzer

    Balzer Active Member

    273
    43
    Nov 12, 2006
    Sioux Falls, SD
    I actually had this exact issue a couple days ago with my Premiere (not Elite), but a reboot fixed it. So not related the ongoing issues with the new Elites, I guess.
     
  4. djwilso

    djwilso Member

    598
    2
    Dec 23, 2006
    Phoenix, AZ
    Currently, I have a support ticket with TiVo about the Phoenix DST issue and today its Status says "Escalated to L3".

    jshore - do you also have a support case open? If not, please go to http://support.tivo.com/ and report the issue.
     
  5. djwilso

    djwilso Member

    598
    2
    Dec 23, 2006
    Phoenix, AZ
  6. jfh3

    jfh3 Active Member

    4,471
    2
    Apr 15, 2004
    Denver area
    Note that the first part of your post Tivo is just asking you to force restart the HDUI.

    As you point out, the second part is just fixing the VPL problem. As of today, the "Can't play Netflix" problem is still unsolved and escalated to engineering, according to the rep I spoke with. I've been checking on this one with Tivo every day. More details in the Elite thread.
     

Share This Page