Netflix, Hulu, Amazon, etc. not showing up anymore

Discussion in 'TiVo Help Center' started by dcardani, Dec 27, 2011.

  1. dcardani

    dcardani New Member

    9
    0
    Dec 26, 2010
    Last night, I attempted to watch something on Netflix on my Premiere, and it wasn't available. YouTube is the only service listed under "Find TV, movies, & video". The network connection is working fine. In fact, I can use Pandora, and I see the other "Music & photos" apps listed. I've rebooted the device, but it still doesn't show Netflix, Amazon, Hulu or Blockbuster anymore. What am I missing? Is there something I need to do to bring them back? I can log in to the Netflix web site and use it on my iPhone just fine, so it's not an account issue. What's going on?
     
  2. dcardani

    dcardani New Member

    9
    0
    Dec 26, 2010
    In case anyone else runs into this, for some reason rebooting alone didn't solve it, but switching the menus from HD to SD, then back to HD, then rebooting did fix it. I have no idea why, but it seems to have worked for me, and one other person who ran into this.
     
  3. dlfl

    dlfl Cranky old novice

    8,887
    702
    Jul 6, 2006
    Dayton OH
    Forcing a connection to the TiVo mothership has also been known to correct this problem.
     
  4. CartmnDBom

    CartmnDBom New Member

    5
    0
    Dec 31, 2003
    The best way to fix this problem without having to reboot is:

    Go to TiVo Central > Settings & messages > Settings > Channel > Video Provider List.*

    Once there uncheck everything and then without leaving the page recheck everything. Once you return to the TiVo central home Page everything should be back.
     
  5. timatkn

    timatkn New Member

    73
    0
    Oct 1, 2010
    This has happened to me twice. Both after downloads. One time I just had to go in and uncheck or check (can't remember which) which video providers I wanted to view. The other time I needed to reboot, then check the providers (Amazon, Netflix, Youtube, Blockbuster) I wanted to see.

    T
     
  6. dlfl

    dlfl Cranky old novice

    8,887
    702
    Jul 6, 2006
    Dayton OH
    But did either of you try just forcing a connection to the TiVo server, as I suggested in post #3?
     

Share This Page