Netflix Error

Discussion in 'TiVo Edge' started by denhearn, Jan 9, 2021.

  1. Jan 9, 2021 #1 of 10
    denhearn

    denhearn Fishing fanatic

    38
    2
    Mar 6, 2010
    Oregon

    Advertisements

    I am seeing an issue on my new Edge's. While opening a new Netflix (streaming) movie I often get this response:
    We're having trouble playing this title right now.
    Please try again later or select a different title.

    I get this almost every night. Trying a different title and waiting do NOT resolve the issue.

    I have tried:
    Exit Netflix, enter Netflix: no help
    Sign out of Netflix, sign into Netflix: no help
    The only resolution I've found is to reboot the TiVo. Then I stop getting the error immediately. But it's a pain to need to reboot the TiVo if I want to watch Netflix!

    I've never seen this before on my Premiere's or Bolt's. It is happening on both of my new TiVo Edge's. Is anyone else getting this? Is there a better way to resolve this than a reboot? Is TiVo working on a resolution? Thanks!
     

    Attached Files:

  2. Jan 9, 2021 #2 of 10
    tommiet

    tommiet Active Member

    493
    249
    Oct 28, 2005
    I've seen the same message using my Bolt AND my Amazon Fire TV. A restart seems to be the only fix for the error on any device.
     
    denhearn likes this.
  3. Steve

    Steve TiVowner since 1999

    1,287
    281
    Apr 23, 2003
    White...
    Me three, on a Bolt and an Edge.
     
    denhearn likes this.
  4. cwerdna

    cwerdna Proud Tivolutionary

    15,326
    932
    Feb 22, 2001
    SF Bay Area, CA
    Have you guys reported this to Netflix customer service? One person here might've already. You should be able to start a live chat via help center from your browser.

    Also, just for kicks, before resorting to rebooting your device, have you tried Reload Netflix? There might be an item on the left side under Get Help > Reload Netflix.
     
  5. Steve

    Steve TiVowner since 1999

    1,287
    281
    Apr 23, 2003
    White...

    Advertisements

    I have, several times. And while this is going on, Netflix is reporting well over 100mbps.

    I could be wrong, but I think this may be related to HDMI handshake issues.
     
    cwerdna likes this.
  6. tommiet

    tommiet Active Member

    493
    249
    Oct 28, 2005
    IMO.... TiVo's hardware is junk. But.. In this case, I think this is a network/internet issue and not a TiVo problem. Can't believe I'm saying that...... :rolleyes:

    You probably could reboot your router and/or cable modem and the problem would go away.
     
  7. KevTech

    KevTech Active Member

    472
    240
    Apr 15, 2014
    Seattle
  8. Steve

    Steve TiVowner since 1999

    1,287
    281
    Apr 23, 2003
    White...
    Tried that. No dice.

    Like I said above, while this is going on, Netflix network diags are showing no connectivity issues and over 100mbps throughput. Very weird.
     
    cwerdna likes this.
  9. mattyro7878

    mattyro7878 Well-Known Member

    2,012
    497
    Nov 27, 2014
    Southern CT
    Drop $40 and solve all your streaming problems. Get a Stream4k or a fire stick.
     
    cwerdna likes this.
  10. Steve

    Steve TiVowner since 1999

    1,287
    281
    Apr 23, 2003
    White...
    Got the "we're having trouble" error again, despite several attempts to play the show. Instead of rebooting, I tried toggling HDR to "Auto" in settings. It had previously been "off". Lo and behold, it allowed me to watch the show I wanted. Not saying that's the workaround, but it did work this evening.

    Further evidence this may be a Netflix<>HDMI handshake issue.
     
    cwerdna likes this.

Share This Page

spam firewall

Advertisements