Netflix App and 4k

Discussion in 'TiVo Edge' started by RGrizzzz, Mar 1, 2021.

  1. Mar 1, 2021 #1 of 11
    RGrizzzz

    RGrizzzz New Member

    14
    2
    Dec 4, 2019

    Advertisements

    I'm having issues getting the Netflix app to run in 4k on my Edge. It's connected to a Vizio P652ui-b2. (2014 model/No HDR, HDMI port 5, which is 4k/60hz) When I'm watching cable TV/recordings, it's transmitting in 4k mode, per the TV's info menu. The Amazon app also works fine in 4k mode. Whenever I load the Netflix app, the TV kicks back to 1080p, and I don't see any shows listed as being available in 4k and HDR. (I upgraded the plan to the top tier shortly after getting the Edge) I've checked the info settings for HDCP, and it says HDCP enabled, although it doesn't say 2.2 is enabled, per the Tivo support article. Does anyone have any troubleshooting suggestions.
     
  2. Mar 1, 2021 #2 of 11
    Steve

    Steve TiVowner since 1999

    1,303
    285
    Apr 23, 2003
    White...
    Not sure if any of these will help, but here's what I'd check:

    Is your Edge auto-sensing the Vizio is 4k? Even if so, try just checking the two 4k resolutions.

    Also, since the Vizio is not an HDR display, try changing HDR to "off", if it isn't already.

    Finally, are you using a "high speed" HDMI cable? Like the one that came with the Edge?
     
  3. Mar 1, 2021 #3 of 11
    RGrizzzz

    RGrizzzz New Member

    14
    2
    Dec 4, 2019
    It is auto sensing the 4k, and detects that it supports 4k 60 hz. I tried manually setting the resolution, and have also tried HDR on and auto. It makes no difference for the Netflix app.

    I doubt it's a cable issue. Amazon works fine in 4k, and TiVo settings tell me HDCP is enabled.
     
  4. Mar 1, 2021 #4 of 11
    RGrizzzz

    RGrizzzz New Member

    14
    2
    Dec 4, 2019
    Yes, I have the premium plan. 4k/hdr work on my phone and Roku devices.
     
  5. Mar 2, 2021 #5 of 11
    Steve

    Steve TiVowner since 1999

    1,303
    285
    Apr 23, 2003
    White...

    Advertisements

    I recently had a less serious issue. My Sony was reporting 4k Netflix, but Netflix wasn't advertising "Ultra HD" on shows I knew had it. I rebooted the Edge and that seemed to fix it.

    Sounds like your problem is more involved. I'd definitely open a case with TiVo tech support.
     
  6. Mar 2, 2021 #6 of 11
    RGrizzzz

    RGrizzzz New Member

    14
    2
    Dec 4, 2019
    I have a feeling the issue is due to HDCP. My mini vox shows HDCP 2.2. The support articles tell me that it should list a version. Mine doesn't. Just says "HDCP enabled"
     
  7. Mar 2, 2021 #7 of 11
    Steve

    Steve TiVowner since 1999

    1,303
    285
    Apr 23, 2003
    White...
    Directly connected to my 2018 Sony 930e, my Edge only reports "HDCP enabled", and I can see Netflix Ultra HD, as I mentioned before. Also Prime HDR. I don't like using HDR for other reasons, tho.
     
  8. Mar 2, 2021 #8 of 11
    RGrizzzz

    RGrizzzz New Member

    14
    2
    Dec 4, 2019
    Thanks for the sanity check Steve! I called Tivo. They're going to escalate the issue to a higher tier of support, which may take 5-7 days. My suspicion is that something with the TV capabilities makes the Netflix app think it won't do 4k. I'm curious how it would work with a different TV in the house, but I don't feel like putting the unit somewhere else.
     
    Steve likes this.
  9. Mar 2, 2021 #9 of 11
    doerrhb

    doerrhb New Member

    7
    1
    May 24, 2013
    Try selecting ONLY 4K 60p in the Tivo Audio / Video settings. That helped me with a similar issue.
     
  10. RGrizzzz

    RGrizzzz New Member

    14
    2
    Dec 4, 2019
    The Netflix app still kicks back to 1080, even with only 4k 60fps set.
     
  11. Steve

    Steve TiVowner since 1999

    1,303
    285
    Apr 23, 2003
    White...
    I have to amend my earlier post. If I set my Sony to "enhanced HDMI", the Edge reports HDMI 2.2. Didn't know that until now. When I'm using "standard HDMI", it just reports HDCP enabled.

    I've had other issues with "enhanced HDMI" enabled. Since I don't see any differences in picture quality, I keep it off.
     

Share This Page

spam firewall

Advertisements