Need help with aspect ratio on PC

Discussion in 'TiVo Home Media Features & TiVoToGo' started by meschen, Jan 21, 2006.

  1. meschen

    meschen New Member

    9
    0
    Jan 21, 2006

    Advertisements

    This evening I installed my Tivo to a wireless network, downloaded TiVo Desktop and Windows Media Player 10 and then installed the free CODEC Stinky_MPEG2_ CODEC recommened elsewhere here.

    To test my set-up, I downloaded about the first five minutes of a show from my Tivo to my PC and then cancelled the transfer. When I play the show, instead being shown in a normal 4:3 aspect ratio on Windows Media Player 10, the video plays in a square image, so that everyone look stall and skinny. Rather annoying to say the least.

    Does anyone have a clue where I went wrong?
     
  2. greg_burns

    greg_burns Now in HD

    6,392
    2
    May 21, 2004
    Slower...
  3. meschen

    meschen New Member

    9
    0
    Jan 21, 2006
    You're correct, it was the CODEC. That solved the problem.

    Thanks Greg!
     
  4. ottomatic

    ottomatic New Member

    26
    0
    Dec 28, 2005
    I am having the same problem... My aspect ratio was goofy in the MP10.

    I downloaded the cole2k codec but when I launch MP10 the image is still squished and when I check the properties it still says it is using the following codec....

    Roxio MPEG2 Video Decoder
     
  5. greg_burns

    greg_burns Now in HD

    6,392
    2
    May 21, 2004
    Slower...
  6. ottomatic

    ottomatic New Member

    26
    0
    Dec 28, 2005
    I have tried that utility...

    My preferred decoder is InterVideo Decoder, IVIVIDEO.AX.
    I have no idea if that is the Cole2k one or not?
     
  7. greg_burns

    greg_burns Now in HD

    6,392
    2
    May 21, 2004
    Slower...
  8. ottomatic

    ottomatic New Member

    26
    0
    Dec 28, 2005
    I finally got rid of Roxio by unregistering the dll...

    now the video plays in WMP with the following video codec:

    ffdshow MPEG-4 Video Decoder

    The only problem is the video is still squished (the video i'm trying to watch is lost which I believe is aired in 4x3 standard TV ratio) I've got black bars on the left and right though...?

    please send help.
     
  9. MichaelBatt

    MichaelBatt New Member

    4
    0
    Feb 2, 2004
    Greetings from Afghanistan and Operation Enduring Freedom! My wife has been mailing me .tivo files on DVDs as they are one of two sources of R&R until I go home next year.

    I've been following this thread, hoping that it solves my problem....

    Unfortunately, my video in WMP 10 is too tall. I've tried the Cole2K package, as well as the stinky codec and the Elecard codec.

    I can't get anything to work, and I'm not sure I know exactly what I'm doing. I'm almost positive that it is, in fact, a codec problem.

    The digital cable runs from the receiver, through the TiVo, to the TV. It is a widescreen TV and currently set to 16:9, so I would imagine that would not affect the aspect ratio.

    Am I not setting something right? I read a lot about settings and such, but don't know where to go in WMP 10 to see them. I also have Roxio 8 installed and cannot get rid of it as I use it on a regular basis here.

    I'm not the greatest with the computer, but I love my TiVo, and the video files are fast stacking up, waiting for me to watch them.

    Any help would be appreciated...Thanks!
     
  10. greg_burns

    greg_burns Now in HD

    6,392
    2
    May 21, 2004
    Slower...
    Most certainly a codec issue. If you can't fix the codec problem on your PC, perhaps you could try having her record shows at a different quality level. I've only seen the tall and skinny problem on Medium (352x480), but not on High (480x480) or Best (480x480 or 540x480 if satellite). YMMV.

    What recording quality are you currently using? You can tell by playing back a .tivo file from within WMP10 and doing a File->Properties. (Note: regardless of the numbers, it should still playback in a normal 4:3 ratio)
     
  11. ottomatic

    ottomatic New Member

    26
    0
    Dec 28, 2005
    Simple Solution: Download Media Player Clasic

    Other Option: Open the ffdshow video decoder configuration that came with Cole2K. Under Codecs/default/see if you can play around with the MPEG2 settings
     
  12. MichaelBatt

    MichaelBatt New Member

    4
    0
    Feb 2, 2004
    The properties for the file show size as 352x480 with an aspect ratio of 11:15 (which computes to it being too tall? - unless that is because of the codec output), and the video codec as "ffdshow MPEG-4 Video Decoder".

    I have emailed the wife to check the settings on the TiVo and she replied back that the shows are recorded at best quality. A one hour show is about 1.5 to 2Gb, so I would imagine that is accurate.

    I installed the trial of Elecard MPEG-4 decoder and checked the ffdshow settings in the Cole2K Media pack and didn't see an MPEG-4 setting. After a reboot, there has been no change.

    Any other thoughts?

    Thanks!
     
  13. greg_burns

    greg_burns Now in HD

    6,392
    2
    May 21, 2004
    Slower...
    IIRC, 352x480 is actually Medium unless you have Video Smoothing enabled on the Tivo. (Settings->Video->Video Smoothing).

    That is odd about the 11:15 ratio. That must be the codec doing that.

    Windows Media Player Classic is a good suggestion though. It seems to have its own built-in codec.
     
  14. MichaelBatt

    MichaelBatt New Member

    4
    0
    Feb 2, 2004
    WMP Classic works great. The video is nice and big from the best quality setting; however, i would like to edit the video using Sonic or Roxio and still bump into the codec issue.
     
  15. dognose

    dognose New Member

    2
    0
    Aug 28, 2006
    Uhg, I'm having the same problem. With all recordings High, medium and medium with smoothing.

    I have a new HP XP machine with not that much added.

    I've tried the cole2k, the classic media player and the microsoft utitlity.

    I really seems like Tivo dropped the ball on this one. Shouldn't they be setting the proper aspect ratio, or at least provide a proper codec for the viewing of their videos.
     
  16. greg_burns

    greg_burns Now in HD

    6,392
    2
    May 21, 2004
    Slower...
    Tivo eventually did address this. If you buy Tivo Desktop Plus for $25 it includes a gauranteed-to-work-with-tivo-files MPEG-2 Codec.

    If you don't want to pay up and prefer to use one of those other codecs, you'll need to get your hands dirty. You DS Filter Manager to adjust the merit values of your codecs.

    http://www.free-codecs.com/download/DirectShow_Filter_Manager.htm
     
  17. dognose

    dognose New Member

    2
    0
    Aug 28, 2006
    Tivo should really fix their player. As a long time Tivo user, I find this pretty upsetting. I certainly can't recommend this product to any normal user.

    The DS Filter Manager is about as confusing as can be. I've tried getting it not to use the video codec that it's using, but that doesn't seem to work. Is there more specific instructions somewhere?
     
  18. greg_burns

    greg_burns Now in HD

    6,392
    2
    May 21, 2004
    Slower...
    Uh, Tivo doesn't make a player. Last time I checked it just starts up Windows Media Player. ;) Even that doesn't have any say over what codec gets used. Blame Microsoft.

    Don't really know any instruction for Filter Manager. It is definately confusing. I think Cole2K install InterVideo codec. Find that codec in the list ("InterVideo Video decoder", I think) and change its merit value to "Preferred" 00800000. May have to reboot for it to take effect.

    Edit: Did a little bit of experimenting, rebooting is definately required to see the changes take effect. YMMV.
     
  19. classicsat

    classicsat Astute User

    17,877
    0
    Feb 18, 2004
    Ontario Canada.
    TiVo plays fine with a legal paid for codec.
     
  20. greg_burns

    greg_burns Now in HD

    6,392
    2
    May 21, 2004
    Slower...
    Tivo plays fine with the Tivo Desktop Plus's codec. Everything else (including legal paid for codecs) is a crap shoot, IMO.
     

Share This Page

spam firewall

Advertisements