Need Galleon Linux Help

Discussion in 'TiVo Home Media Features & TiVoToGo' started by Stormspace, Oct 14, 2007.

  1. Stormspace

    Stormspace Electrocuted by TiVo

    5,198
    6
    Apr 13, 2004
    Hartsville, SC
    Sorry for the dup thread, but the linux thread seemed to be too sprawling and possibly not related to my environment.

    I'm trying to get Galleon installed at present and am having trouble. What I think I have done so far is:

    Installed Java
    changed Java_Home
    DLed Galleon and did a make install.
    I cannot get into the galleon bin directory, even using sudo to change the permissions on the sh files, so perhaps I need to start over. Any help would be appreciated! TIA!
     
  2. tgmii

    tgmii Member

    193
    14
    Feb 21, 2002
    New Jersey
    can't tell a lot from your post, but the one thing that you should check is JAVA_HOME. Linux is case sensitive... you have mixed case in your post.

    The other linux thread had a startup script (which I haven't tried, but from glancing at it, looked correct)... compare that to your setup, and differences might jump out at you.

    Otherwise, please post the script you are using to start it. You may be starting it by hand, but its best to use a script.

    Tom
     
  3. Stormspace

    Stormspace Electrocuted by TiVo

    5,198
    6
    Apr 13, 2004
    Hartsville, SC
    Currently I'm just looking to start it manually and yes I have the case correct on the JAVA_HOME. :)
     
  4. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    You're trying this on Ubuntu, right? It's strange that you can't even get into the folder the 'make install' is creating.

    I know I had issues with the initial make script when trying to install on Mandrake. I wonder if it needs to be tweaked for Ubuntu as well.

    I still haven't gotten around to trying the install on Ubuntu. I might be able to give that a shot tomorrow and see what happens.
     
  5. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    Ok, I've run into some issues installing 2.5.1 on Ubuntu as well.

    - I used 'sudo make install' to run the Makefile
    - there's no chkconfig on Ubuntu (also discussed here) so I used 'update-rc.d galleon defaults' to get all the symbolic links for startup in the right places
    - next, I didn't have java, so I used 'sudo apt-get install sun-java-6-jre' to install the latest JRE, updated JAVA_HOME
    - the galleon startup script references /etc/rc.d/init.d/functions which also doesn't exist on Ubuntu, so I commented that line out

    Now, when I try to start Galleon, I get this error in the wrapper.log:

    Exception in thread "main" java.lang.NoClassDefFoundError: org/lnicholls/galleon/server/ServiceWrapper

    So I'm not sure if this is a java problem or a wrapper problem or what. Still need to play around with it some more ...

    edit: nevermind, I got it. I changed the install directory in the Makefile to '/usr/local/galleon' but the wrapper.conf file was still pointing to '/usr/share/galleon' so it couldn't find the classfiles.
     
  6. Stormspace

    Stormspace Electrocuted by TiVo

    5,198
    6
    Apr 13, 2004
    Hartsville, SC
    You get your working with Ubuntu? If so would you mind posting a detailed How-to? I'm concerned that although I have done some of those tasks, such as JAVA_HOME, that it might not be set up exactly the same as yours.

    TIA!
     
  7. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    I ran into one other strange problem after I fixed my wrapper issue: when I started Galleon, java went crazy and started putting this line into the log (several thousand per second!):

    12:46:22,406 ERROR [JmDNS.ServiceResolver] Configurator - java.util.ConcurrentModificationException: Could not save tivo: Family Room

    I did some Google searching and found someone with the exact same problem, albeit a long time ago, on the galleon.tv forums:

    http://galleon.tv/component/option,com_joomlaboard/Itemid,26/func,view/id,12/catid,5/

    The resolution was to put the wrapper log into DEBUG mode. So I tried that and it worked. It does appear Galleon is running on Ubuntu now, according to the log, and I was able to get into the GUI as well. I'm not at home, so I can't confirm my TiVos can see the Galleon server, but I can check that out tonight.
     
  8. Stormspace

    Stormspace Electrocuted by TiVo

    5,198
    6
    Apr 13, 2004
    Hartsville, SC
    When you do I'd be cool if you could walk me through it via a quick tutorial?
     
  9. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    Yeah. I might uninstall Galleon and then start over (without changing the install path this time) to make sure I've got it all accounted for.

    I think the only difference between us is that maybe you didn't install/run Galleon with sudo, but as your local account? That and having to comment out the /etc/init.d/functions line in the galleon startup script in the bin directory.
     
  10. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    Ok, I totally forgot to try and test Galleon on Ubuntu from my TiVos yesterday night, thanks to the ALCS game (go Indians!! :)). So I haven't confirmed the TiVo-side works yet, but Galleon is running on my Ubuntu box and here's how I did it.

    • install the java runtime (JRE), if it's not already installed (http://packages.ubuntu.com/feisty/libs/sun-java6-jre). it should install to /usr/lib/jvm:
      Code:
      sudo apt-get install java-sun6-jre
      Note: I didn't have to set JAVA_HOME anywhere after installing the java-sun6-jre package. if you have problems later on though, you might need to manually set that variable (if you used the package it should be /usr/lib/jvm/java-6-sun/jre). YMMV.
    • unzip the galleon archive to a temp directory
    • edit the Makefile. comment out the chkconfig line in the install: section and add the update-rc.d line instead
      Code:
      #chkconfig --add galleon
      update-rc.d galleon defaults
    • if you plan on uninstalling Galleon at some point, replace the chkconfig line in the uninstall: section as well:
      Code:
      #chkconfig --remove galleon
      update-rc.d -f galleon remove
    • do a 'sudo make install' to install the application. you should see the following output:
      Code:
      install -d /usr/share/galleon
      install -d /var/cache/galleon
      install -d /etc/galleon
      install -d /usr/lib/galleon
      install -d /var/log/galleon
      install -d /var/lib/galleon/hme
      install -d /var/lib/galleon/data
      cp -rf bin media /usr/share/galleon
      cp -f Makefile COPYING *.txt /usr/share/galleon
      cp -f conf/*.* /etc/galleon
      cp -rf lib/* /usr/lib/galleon
      cp -rf apps skins /var/lib/galleon
      cp -rf conf/templates /var/lib/galleon
      chmod a+rwx /usr/share/galleon/bin/run.sh
      chmod a+rwx /usr/share/galleon/bin/gui.sh
      chmod a+rwx /usr/share/galleon/bin/galleon
      chmod a+rwx /usr/share/galleon/bin/wrapper*
      chmod +rw /etc/galleon/configure.xml
      ln -sf /var/lib/galleon/apps /usr/share/galleon/apps
      ln -sf /etc/galleon /usr/share/galleon/conf
      ln -sf /var/lib/galleon/data /usr/share/galleon/data
      ln -sf /var/lib/galleon/hme /usr/share/galleon/hme
      ln -sf /usr/lib/galleon /usr/share/galleon/lib
      ln -sf /var/log/galleon /usr/share/galleon/logs
      ln -sf /var/lib/galleon/skins /usr/share/galleon/skins
      ln -sf /var/lib/galleon/templates /etc/galleon/templates
      ln -sf /usr/share/galleon/bin/galleon /etc/init.d/galleon
      update-rc.d galleon defaults
       Adding system startup for /etc/init.d/galleon ...
         /etc/rc0.d/K20galleon -> ../init.d/galleon
         /etc/rc1.d/K20galleon -> ../init.d/galleon
         /etc/rc6.d/K20galleon -> ../init.d/galleon
         /etc/rc2.d/S20galleon -> ../init.d/galleon
         /etc/rc3.d/S20galleon -> ../init.d/galleon
         /etc/rc4.d/S20galleon -> ../init.d/galleon
         /etc/rc5.d/S20galleon -> ../init.d/galleon
    • cd to /usr/share/galleon/bin and edit the galleon script, commenting out the following line:
      Code:
      #. /etc/rc.d/init.d/functions
    • now at this point you can try and start galleon:
      Code:
      sudo ./galleon start
      Note: on my box, however, at this point after galleon initialized, the log (under /usr/share/galleon/logs/log.txt) would start filling up with thousands of lines of:
      Code:
      10:14:59,098 ERROR [JmDNS.ServiceResolver] Configurator - java.util.ConcurrentModificationException: Could not save tivo: Family Room
      If this happens to you, cd to /etc/galleon, edit wrapper.conf and change the logfile log level to DEBUG (instead of INFO, http://galleon.sourceforge.net/index.php?option=com_joomlaboard&Itemid=&func=view&catid=5&id=12#12/):
      Code:
      # Log Level for log file output.  (See docs for log levels)
      wrapper.logfile.loglevel=DEBUG
      Then try starting Galleon again. Update: after upgrading to Hardy Heron, I was able to go back to the INFO loglevel without getting the jmDNS errors anymore.

    • as soon as you start Galleon, quickly cd to /usr/share/galleon/logs and then:
      Code:
      tail -f log.txt
      so you can watch everything starting up
    • now that the server is running, it's time to try the GUI. cd to /usr/share/galleon/bin and then:
      Code:
      sudo ./gui.sh
      (obviously you need to be in windowed environment for this to work ... for headless systems you can do what I do and use VNC over an SSH tunnel through PuTTY). the GUI should appear:

      [​IMG]

      Note: if you had to set JAVA_HOME earlier, you might also need to edit gui.sh and uncomment and set the JAVA_HOME line in there too.
    • one more note ... when running Galleon on Mandrake Linux, I had to disable IPv6 in order to get Galleon to bind correctly to the network adapter. I don't know if this is still necessary, but I did it on my Ubuntu box too. edit /etc/modprobe.d/alias and change the following line as shown:
      Code:
      alias net-pf-10 off # ipv6
      reboot to have the change take effect.

    Good luck, I hope this helps!

    edit: added link to using VNC over SSH through PuTTY
    edit #2: updated jmDNS link to Galleon forums
     
  11. Stormspace

    Stormspace Electrocuted by TiVo

    5,198
    6
    Apr 13, 2004
    Hartsville, SC
    First, Thanks for the help! I can get the galleon service running however the gui keeps throwing up the connecting to server message. On the TiVo the server shows up in now playing, but not in music, photos, etc.

    Ideas?
     
  12. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    Check the log.txt and gui.txt files under /usr/share/galleon/logs. Anything of note in there?

    Might want to check 'netstat -a' and see if you can "see" the Galleon service listening.

    Glad the instructions helped, though! :cool:
     
  13. Stormspace

    Stormspace Electrocuted by TiVo

    5,198
    6
    Apr 13, 2004
    Hartsville, SC
    Checked Netstat and saw that galleon was listening on ipv6. Put a bad_list file with the off line in it and rebooted. Whoo hooo! I'm set.
     
  14. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    Excellent! :up:
     
  15. ebeckhusen

    ebeckhusen New Member

    20
    0
    Feb 15, 2007
    I'm a bit of a Linux newbie, especially to Ubuntu, and I'm having a hard time getting this to work. I tried to change the "aliases" file to alias net-pf-10 off # ipv6, but it wouldn't let me save because I don't own the file (it's a root file, and I don't know how to log in as root). So, is there some way to edit it from the terminal, using sudo, or some way to login as root so I can edit it?
     
  16. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    The whole point of Ubuntu is you never login as root ... you can't. It's taking me some time to get used to this as well.

    So, to edit the aliases file, you need to do 'sudo vi /etc/modprobe.d/aliases'.
     
  17. ebeckhusen

    ebeckhusen New Member

    20
    0
    Feb 15, 2007
    Thanks for the help, it's running fine now.

    Yeah, there's quite a bit I'm getting used to with Ubuntu, not logging in as Root is one of them. But, I love it and I've already scrapped Windows :)
     
  18. TiVoter123

    TiVoter123 New Member

    146
    0
    Jan 1, 2001
    Orange, CA
    I am having the exact same problem (trying to get Galleon working on my THD).

    I'm getting the following error:

    Code:
    22:04:49,677 ERROR [WrapperListener_start_runner] TiVoListener - java.io.IOExcep
    tion: Operation not permitted
    22:04:49,677 DEBUG [WrapperListener_start_runner] TiVoListener - java.io.IOExcep
    tion: Operation not permitted
            at java.net.PlainDatagramSocketImpl.send(Native Method)
            at java.net.DatagramSocket.send(Unknown Source)
            at javax.jmdns.JmDNS.send(Unknown Source)
            at javax.jmdns.JmDNS.init(Unknown Source)
            at javax.jmdns.JmDNS.<init>(Unknown Source)
            at org.lnicholls.galleon.server.TiVoListener.<init>(TiVoListener.java:57
    )
            at org.lnicholls.galleon.server.Server.start(Server.java:327)
            at org.lnicholls.galleon.server.ServiceWrapper.start(ServiceWrapper.java
    :47)
            at org.tanukisoftware.wrapper.WrapperManager$12.run(WrapperManager.java:
    2788)
    
    ipv6 is in fact disabled (though I had to do it via a blacklist file, but lsmod | grep ipv6 confirms it's not loaded). I have my JAVA_HOME environmental pointed at /usr/java/jre1.6.0_03 -- I installed this manually from java's website). I am running as root.

    This seems like the exact problem that Malibyte was having here --- any specific fix / obvious thing I'm doing wrong?
     
  19. Stu_Bee

    Stu_Bee New Member

    887
    0
    Jan 14, 2002
    Silicon...
    Thanks for the guide Windracer. Mucho useful.
     
  20. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    Glad you found it helpful!
     

Share This Page