Need advice... Installing firmware?

Discussion in 'TiVo Bolt DVR/Streamer' started by Telnetdoogie, Dec 1, 2018.

  1. Telnetdoogie

    Telnetdoogie New Member

    4
    5
    Mar 22, 2015
    My Tivo has been rebooting randomly over the past few days and I suspected some hard drive issue, so I used kickstart code 54 in the hope of doing a file system check - which appeared to do nothing. (I couldn't see the hard drive test screen at all, it just rebooted) - So then I tried 57. It booted to a screen that said "installing firmware, do not unplug the box" and I waited maybe an hour or more... I figured it was stuck so I rebooted (yeah I know) and then the box was stuck in a reboot loop with the black "serious issue" screen, followed by a reboot after maybe 10 seconds (obviously something was wrong there, since the screen says it'll take 3 hours)... back to the black "serious issue" screen ad infinitum... I couldn't get it to do anything else.

    I removed the drive and scanned it with the WD utility tool and it checked out ok. While it was out I booted the box with no drive in and saw what I expected to see - 4 LED flashes. So, after adding the drive back in again, I was able to re-start the firmware install with kickstart code 57 again (it was still doing the boot loop but at least I was able this time to restart the kickstart 57 (Media File System (MFS) check) process, which apparently on this box reinstalls firmware)

    So, it's back on the "installing firmware" screen, it's plugged in via ethernet, but with there being no visual indicator of progress... what should I expect? Does firmware download and update take... 20 minutes? 3 hours? overnight? It's only been on the screen for 15 minutes so far this time, and I'm tempted to just leave it now for 12 hours and see what happens but I figured I'd get people's take on how long they think that should take. I have a feeling that the previous reboot loop was caused by me interrupting the previous firmware update, so I'm at least happy that I was able to get it back to trying to do that again.

    Anyone have any advice?
     
    Last edited: Dec 1, 2018
  2. Telnetdoogie

    Telnetdoogie New Member

    4
    5
    Mar 22, 2015
    I'll respond to my own post here to close the loop and potentially help others that might experience this same issue later down the road.

    Below is what I have 'arrived at' based on my experience today. Some details may be invalid assumptions but it's based on observation and although the technical 'reasons' may be a reach, it's the root cause that to me makes the most sense.

    I believe my 2015 Tivo Bolt is one of the units that has an issue with the kickstart firmware. When you try to do a [KS54 - Hard Drive Test] on the device, it does nothing. There's no SMART menu or drive test options. It effectively skips the tests, and reboots as normal. This should be an indicator that something isn't right.

    If you have the same issue; DO NOT ISSUE OTHER KICKSTART COMMANDS!

    ...When KS54 did nothing for me, I took the next step, and ran [KS57 - Media File System (MFS) check]. Like linux (and windows) - this effectively flags the drive as having an 'inconsistent' state, so that file systems checks will be run on the unit next time it boots.

    Unfortunately, for me this caused a boot loop, where it continued to enter the GSOD (or black, in my case) "A serious issue has occured... 3 hours yada yada" filesystem repair process that didn't work and would crash within 15 seconds of starting.... thus, the cycle repeated over and over. The File system could not effectively become unflagged or marked as clean by a successful file system check / repair.

    Took me a while of experimenting and tooling around, but what worked was to use MFSTools to mark the filesystem as CLEAN. Once that was done, and I put the drive back in, the Tivo booted normally as if nothing had ever happened.

    The command to mark the filesystem as clean is:
    mfsck -m1 /dev/sdb

    And the corresponding output was something like:

    WARNING: mfs filesystem marked as inconsistent
    Setting volume to MFS_MAGIC_OK

    I hope this helps someone who's found themselves stuck in a GSOD or "Serious Issue" boot loop.
     
    Last edited: Dec 1, 2018
    aaronwt, jrtroo, UCLABB and 2 others like this.
  3. ggieseke

    ggieseke Well-Known Member

    5,616
    674
    May 30, 2008
    From other posts that I've seen lately, I'm convinced that KS57 doesn't work anymore (at least on Premiere and later models). Even worse, it causes a boot loop as you've seen.

    KS58 still works fine, and it's another way to get out of the loop. Using mfsck was smart.
     
    jrtroo likes this.
  4. jrtroo

    jrtroo Chill- its just TV

    5,084
    310
    Feb 4, 2008
    Chicagoland
    Great post and follow up. I initially thought it was going to be FUD, I'm happily surprised to see how helpful this will be for others. Thanks for contributing!
     

Share This Page