My Premiere XL4 can't complete 'Connect to TiVo service now'

Discussion in 'TiVo Premiere DVRs' started by SianG, Jan 13, 2021.

  1. SianG

    SianG New Member

    10
    3
    Jan 13, 2021

    Advertisements

    I connect via Ethernet. All the diagnostics indicate that everything works (in particular, test results for TCP ports indicate ports are available). I can stream Netflix to my TiVo Premiere, so I know I'm connecting to the router.
    However, when I connect to Tivo Service to download schedules, when it reaches the step "Getting Info", it starts to do so, then stops with a message of "Connection interrupted". This has been happening since Sunday (1/10/21). Are other Premiere users experiencing this? Any suggestions?
     
    Winkabc likes this.
  2. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,621
    1,147
    Apr 6, 2000
    SF Bay Area
    Try a power cycle it.
     
  3. SianG

    SianG New Member

    10
    3
    Jan 13, 2021
    I've done that several times. It's the first thing I tried. I've also unplugged and replugged all cables, and spoken to TiVo Customer Support twice.
     
  4. kpeters59

    kpeters59 Well-Known Member

    3,175
    652
    Jun 19, 2007
    Houston, Texas
    Rebooted the Router and/or Modem?

    Try changing IP Address' on the TiVo, too.

    -KP
     
  5. KimberlyA

    KimberlyA New Member

    4
    2
    Jul 28, 2016

    Advertisements

    I have the same issue. My last successful download from Tivo Central was on Sunday 1/10. All the diagnostics check out fine. I can connect to TiVo to test the connection and that checks out fine.

    When I force a connection to Tivo I can connect but "Getting Info - Downloading" comes back with the message that the connection is unstable and it fails.

    I have no other internet issues going on with any other devices in the house. I can even stream Netflix through the TiVo fine.

    I am hardwired via ethernet directly into my Modem/Router (one unit) and all the TiVo ports are open and set to TCP as TiVo had me check today.
     
    SianG and Winkabc like this.
  6. Lucas Buck

    Lucas Buck New Member

    5
    5
    Jan 24, 2005
    Trinity
    Exact same issue down to the day my premiere quit loading data. TiVo has done something but won’t admit it. I’ve spent hours on the phone with their tech support. They just want us to buy new boxes. Really makes me angry. What should we do?
     
    SianG and Winkabc like this.
  7. Winkabc

    Winkabc New Member

    5
    1
    Nov 5, 2016
    Exact same issue - also last connected 1/10. Have done all the troubleshooting as suggested with no issues, but still get N11 - connection interrupted when trying to connect to Tivo service.
    Any other ideas?
     
    SianG likes this.
  8. Lucas Buck

    Lucas Buck New Member

    5
    5
    Jan 24, 2005
    Trinity
    We need to all call in and demand they fix this issue. (877) 367-8486
    I will call again tomorrow. There must be thousands of us so let’s put the pressure on. My guess is they purposely shut us down to try and force us to buy new TiVo boxes. Please join me in letting then know we will not stand for this!
     
    Winkabc and SianG like this.
  9. Winkabc

    Winkabc New Member

    5
    1
    Nov 5, 2016
    So I really have a mess now....stupidly tried to do Guided Setup. Guess I hoped something would break free. But now the box is stuck in a setup loop because it can't get to TiVo service to load info. So can't even use it to watch live TV. Yes, I'll be calling tomorrow too. :mad:
     
  10. SianG

    SianG New Member

    10
    3
    Jan 13, 2021
    Thanks KimberlyA, Lucas Buck, and Winkabc. It's good to get confirmation that it's not just me! My networking professional housemate has suggested that there's been a software or firmware update, possibly on our machines, or on the TiVo end, that is not quite compatible with our aging units.

    I'm wondering if there are Premiere users who are NOT having this issue? That would be useful information, so it would be great to hear from people who can successfully connect. Potential variable...is this affecting only people using specific ISPs, or is it all of us? Any of the rest of you getting internet from RCN?
     
    Winkabc likes this.
  11. SianG

    SianG New Member

    10
    3
    Jan 13, 2021
    I actually asked the service rep I talked to on Tuesday if this meant my Premiere was at end-of-life, and he was quite adamant that it was not. He made a suggestion of a particular newer model if I wanted to upgrade, but did not hard-sell me on it, and I gave him every chance to do so.

     
  12. Winkabc

    Winkabc New Member

    5
    1
    Nov 5, 2016
    SianG, I saw a recommendation somewhere to check for firmware updates for the router. But other network devices using the same router are working flawlessly so ???. I would think TiVo boxes would display a message of some kind if there was an update needed, or it would just update automatically when connecting (if it can!!). I'm thinking like Lucas - something changed on TiVo's end. I'll be curious to see what support says when I call!
     
  13. Winkabc

    Winkabc New Member

    5
    1
    Nov 5, 2016
    FYI - no, I have a different ISP.
     
  14. SianG

    SianG New Member

    10
    3
    Jan 13, 2021
    Winkabc, My techie roomie meant a firmware/software update may have happened either on our TiVos (automatically), or at the TiVo end, and whoever wrote the update forgot to account for some Premiere-specific detail. It would be worth asking, the next time someone talks with a TiVo rep, if indeed some update happened late Saturday/early Sunday.

    And thanks for letting me know you're at a different ISP than me. One of my worries was of having the same issue if I got a newer TiVo model, and it turned out that the problem really was that my ISP had updated their firewall (what the TiVo rep suggested was causing the issue).
     
  15. Lucas Buck

    Lucas Buck New Member

    5
    5
    Jan 24, 2005
    Trinity
    SianG - this makes a lot of sense. I will ask this very thing when next I contact TiVo. Thanks!
     
  16. Sparky1234

    Sparky1234 Well-Known Member

    2,327
    348
    May 8, 2006
    Just checked and its updating fine here.
     
  17. fatcat

    fatcat New Member

    8
    0
    Feb 22, 2005
    I'm having the exact same issue on my Premiere: last successful update was around Jan 10 (maybe 11), and now updating fails with the Connection Interrupted (N11) error, even though my general network access works fine (both accessing the TiVo over my home network and accessing the outside world from the TiVo) and the network diagnostics succeed.

    Things I've tried:
    • Restarting (several times).
    • Clearing the guide data. This ran overnight without finishing (stuck on the "Clearing Guide data & the To Do List; This may take up to an hour" screen), so today I ...
    • Restarted and did the KS57 trick.
    • Rebooted the switch it's plugged into, my Wi-Fi access point, and my cable modem.
    After all that, it's still having the same problem.
     
  18. fatcat

    fatcat New Member

    8
    0
    Feb 22, 2005
    Me, too: Spectrum, not RCN.
     
  19. SianG

    SianG New Member

    10
    3
    Jan 13, 2021
    So at least one Premiere XL4 user can get schedule updates?
     
  20. Lucas Buck

    Lucas Buck New Member

    5
    5
    Jan 24, 2005
    Trinity
    Just to clarify - your TiVo is a Premiere model? I believe they were made about 2010-2013.
     

Share This Page

spam firewall

Advertisements