1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MoCA help

Discussion in 'TiVo Help Center' started by rswc90, Sep 16, 2018.

  1. rswc90

    rswc90 Member

    43
    8
    Oct 8, 2017
    I have a new TiVo bolt, 2 new smart TVs and a TiVo mini. They are not talking now.

    I had 2 "not smart" TVs, TiVo, Mini and a bridge set up. it worked great for a year. Then I had to replace everything (fried by lightening) so upgraded the TVs, the Modem (Spectrum), and replaced the TiVo. Now on the Modem it shows that MoCA is lit up (was not on the previous modem) and TiVo is insisting that I set up my Bolt on wireless when I am CERTAIN it was set up on MoCA before. I tried changing both to MoCA but that did not work. Neither the Bolt or the Mini is plugged into the router. I spent 6 hours bouncing back and forth from Spectrum to TiVo yesterday - each pointing to the other for the fix.

    Can there be too many MoCAs running?
    Does fact that these are smart TVs change the equation?
    Thanks!
     
  2. krkaufman

    krkaufman TDL shepherd

    12,068
    1,624
    Nov 25, 2003
    I’m surprised that MoCA appears enabled on your Spectrum-supplied cable gateway (combo modem/router); even for models that support MoCA, from my TCF reading (i.e. not personal experience) it’s been pretty universal that Spectrum wouldn’t enable the MoCA bridging feature.

    Regardless, yes, you *can* have “too many MoCAs running,” since there’s a limit of 16 nodes — a limit you’re nowhere near. The more pressing limit is that you cannot have two MoCA nodes both bridging between the router’s Ethernet LAN and the MoCA coax segment, since this creates a network loop that is likely to bring your LAN to its knees.

    I’m guessing that you previously were using the TiVo Bridge (or some other MoCA adapter) connected at your modem/router location to act as the MoCA bridge (aka MoCA access point). Are you still? If yes, and the gateway’s built-in MoCA bridge is also enabled, then you’d have a dual MoCA bridge situation, requiring one bridge or the other to be disabled.

    Once you’ve confirmed that you have only a single MoCA bridge active, you should be able to configure the BOLT and Mini as MoCA clients.

    p.s. No, the SmartTVs needn’t dramatically affect the setup, aside from increasing demand for wired Ethernet connections (always preferred, where possible, over wireless for fixed-location devices). If you require the SmartTVs to be wired via Ethernet, then you’d need a MoCA adapter at the Mini’s TV location; a MoCA-client BOLT’s built-in MoCA bridge could be used to network its TV via Ethernet. (more info here)
     
  3. krkaufman

    krkaufman TDL shepherd

    12,068
    1,624
    Nov 25, 2003
    An odd insistence given that TiVo only officially supports wired Ethernet or MoCA connections for all TiVo boxes part of a Mini whole home setup.
     
  4. rswc90

    rswc90 Member

    43
    8
    Oct 8, 2017
    Update. Despite SIX hours of phone conversations yesterday with Spectrum and Tivo, today, I received a good guy on the Spectrum end. He said that Spectrum did, in fact, turn on the MoCA (AH HA!!) and he got into the modem and turned it off. The TiVo Bolt worked (for a minute) - the Mini never connected.

    (As a reminder, I have the MoCA, POE and Bridge still set up from before the lightening took out all my electronics.)

    Then I tried changing the settings on the router to reflect my old router settings of port mapping. now, not even the Bolt is working. TiVo and Spectrum were both on the call today and told me I needed to contact Apple for port-forwarding instructions to reset this Airport Extreme. Thoughts?
     
  5. rswc90

    rswc90 Member

    43
    8
    Oct 8, 2017
    I am adding "insult to injury" as they say. My TiVo now sets up as MoCA AND has an IP address YET I get a message that it cannot connect to the router. I don't get it -- It has an auto-set IP address that shows on the screen. AND it says it cannot communicate with the internet.
     
  6. mdavej

    mdavej Well-Known Member

    2,379
    476
    Aug 13, 2015
    Since the Moca change in the router, I would power down everything, including all your Tivos, then bring back up in this order - Modem, router, main Tivo (Moca bridge), then Minis.
     
  7. krkaufman

    krkaufman TDL shepherd

    12,068
    1,624
    Nov 25, 2003
    ^This^, except insert “TiVo Bridge” in front of “main TiVo.”
     
  8. rswc90

    rswc90 Member

    43
    8
    Oct 8, 2017
    OK -- I powered down everything and then waited. I started things in order and now I don't even get an IP address, which I had earlier when I had loaded the old settings I thought I had from the previous - (despite it saying that it was not connected to the internet.) AND, it tapes a show I set up just to test it.

    Now, Just added the MAC ID of the TiVo to the router and set the router's network port setting to Apple Remote Setting which it filled in the same numbers I had on the previous TiVo and Airport Extreme. I restarted the TiVo but it says there's still no connection. Now I can't get the IP address even.
     
  9. fcfc2

    fcfc2 Well-Known Member

    2,107
    320
    Feb 19, 2015
    A bit confused...do you have the Spectrum Gateway setup in bridge mode? Are you running the Spectrum gateway and your own Apple router? What is the port forwarding supposed to be doing for you?
     
  10. rswc90

    rswc90 Member

    43
    8
    Oct 8, 2017
    The Spectrum gateway is NOT set up in bridge mode. I have an external bridge that I bought from TiVo originally when I set this up. That is plugged into the router. The port forwarding, according to both TiVo and Spectrum is supposed to be needed in order for the TiVo Bolt to find the router so it can then also feed the Mini (if I understand all this correctly) because neither the Bolt or the Mini is hard-wired into the modem or router.
     
  11. mdavej

    mdavej Well-Known Member

    2,379
    476
    Aug 13, 2015
    FWIW, mine has always worked fine plug and play - one Roamio, four Minis, two Moca adapters. No port forwarding, no reservations. I would remove all that stuff and try again.

    Do you have a more complex setup than you've described up to now? Do you have multiple routers or VLANs?

    Please post the make/model of your Spectrum Modem. If it's also a router, that is probably the source of your problem. If it IS a router, it needs to be in bridge mode (not the Moca part but the LAN part).
     
    Last edited: Sep 17, 2018
  12. fcfc2

    fcfc2 Well-Known Member

    2,107
    320
    Feb 19, 2015
    And what is the Apple Airport Extreme setup as a router or as an Access Point only? And which unit is the port forwarding done on?
    BTW, I have never ever needed to use port forwarding for a Tivo to find a router.
     
  13. rswc90

    rswc90 Member

    43
    8
    Oct 8, 2017
    The Airport Extreme is my router - not just an access point. The Spectrum and TiVo folks said the port forwarding is because I have an Apple router. UGH! Now, My Bolt has a red light on it that goes away occasionally!
     
  14. krkaufman

    krkaufman TDL shepherd

    12,068
    1,624
    Nov 25, 2003
    Is it anywhere near the status LED that indicates “Recording in Progress”?
     
  15. rswc90

    rswc90 Member

    43
    8
    Oct 8, 2017
    yes -- but there's nothing set up to record!
     
  16. krkaufman

    krkaufman TDL shepherd

    12,068
    1,624
    Nov 25, 2003
    Not even Suggestions? (I disable Suggestions, so I don’t know if the record status LED lights-up for those.)

    p.s. “Nothing set up to record” is different than “nothing is recording.”
     
  17. JoeKustra

    JoeKustra in the other Alabama TCF Club

    14,550
    2,123
    Dec 7, 2012
    Ashland, PA...
    Suggestions, which default to ON, will cause the red LED to come on. Also a Bolt has only one red LED.
     
    krkaufman likes this.
  18. fcfc2

    fcfc2 Well-Known Member

    2,107
    320
    Feb 19, 2015
    I wonder if you actually have 2 routers, a double nat situation, and your Tivos are linked to the wrong router/network. When you have a gateway from Spectrum and your own router, the gateway should be put in "bridge mode", which means that it is then only acting as a cable modem and the router function has been disabled. If a wireless signal is being broadcast from the gateway, you have 2 routers functioning and this is likely causing you networking issues. Port forwarding is not used in that kind of situation and incorrectly applied may also cause networking problems.
    The fix is to call and get the gateway put into "bridge mode" and then power off everything on your network and then starting with the gateway power each device on and wait till it completely boots up then go to the next and so on.
    EDIT: Also, remove any port forwarding settings, period.
     
    krkaufman likes this.
  19. krkaufman

    krkaufman TDL shepherd

    12,068
    1,624
    Nov 25, 2003
    This status LED being lit-up indicates several things:
    • The modem’s built-in MoCA bridge must be enabled, and at least one MoCA node is successfully connected.
    • This "modem" is actually a combo cable modem/router (i.e. a cable gateway), which must be the case for the built-in MoCA bridge to have anything to bridge between.
    • This cable gateway is configured to function as such, that is, as both a modem and router. And if you’re also using another, separate router that is still configured to function as a router, then the root of your issue is likely a cascaded NAT firewall/router setup, and possibly how the various devices are connected to each.

      Typically (and ideally), when a user has supplied their own router, it would be paired with a simple modem*, letting the modem establish the Internet connection, with the modem passing the connection over to the router via the Ethernet WAN link.

      * When a cable gateway is present in such a setup, it should be reconfigured to function as a simple modem, stripping it of all its router, firewall, wireless, MoCA, etc. functionality, leaving it with the sole task of establishing the cable Internet connection and making that available to an Ethernet-connected device — typically a router. Reconfiguring a gateway in this fashion, to function strictly as a modem, is often referred to as operating the gateway in "bridge mode" -- distinct from anything related to MoCA.

      If you intend to keep using the Apple Airport Extreme as your main router, then you'll want to contact Spectrum and have them configure your gateway in bridge mode, to have it function strictly as a cable modem. The ~cable modem~ would then only have a coax connection and a single Ethernet connection to the WAN port of your Airport Extreme. (I'm not sure if it will matter which port you use on the gateway to make the WAN connection to the Airport Extreme, but I'd recommend using Ethernet port #1 absent any specific instructions.)
    edit: p.s. What @fcfc2 (and @mdavej) said, including and especially that it may be necessary to do a full power reset of all the equipment to quickly flush any confusion that might linger related to the double-NAT situation. And if it doesn't work, I'd recommend providing a full description of the devices in play and how they connect to each other via Ethernet, coax, whatever; through what components; and back to the signal source. A text description can suffice; a diagram, however rough, can be more helpful.

    p.p.s. And don't let Spectrum tell you they can't configure the gateway in bridge mode (or as a simple modem); I had to coach my brother through a call with Spectrum over a year ago in order to educate the Spectrum support desk jockey on what was needed.

    Finally, from Spectrum: Can I connect my own wireless router if I have Home WiFi?
     
    Last edited: Sep 18, 2018
  20. rswc90

    rswc90 Member

    43
    8
    Oct 8, 2017
    I will call today -- I assumed that it was set this way since Spectrum charges extra to use their modem and I am not being charged. Also, the tech who replaced this also plugged in the router so she knew I had a home router. I will post back after I get through to them. Thanks.
     
    krkaufman likes this.

Share This Page