1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MFStools Boot CD - LBA48 Boot Disk for ALL TiVo Models

Discussion in 'TiVo Upgrade Center' started by tivoupgrade, Oct 4, 2004.

  1. djtravis

    djtravis New Member

    Jan 23, 2003
    Lockport, IL
    I sort of answered my own question, I think. I tried to restore my original image to the Black 1T drive twice more and both times the restore fails at the same point. So, I tried again, but this time I did not issue the hdparm (dma) commands. The restore is now taking place, ever so slow, but it is working. I'm guessing about 20 times slower than with the hdparm commands issued. I don't know why the copy with hdparm command worked on one drive and not the other, but if the restore will work w/o that command, I don't care. Thank you for all of the information in the forum and a shoulder to cry on.
  2. unitron

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC
    I've used hdparm for monkeying with the reported LBA number (especially when having to undo the mischief of a GigaByte motherboard's nasty tendency to create unasked for HPA's), but I didn't even know there was a way or a reason to use it when restoring TiVo images or copying TiVo drives.
  3. lmbebo

    lmbebo New Member

    Mar 31, 2005

    Its been a long time since I've played around with my Tivo HD. It was originally a 160gb version. I think I had upgraded it to 500 gb back in 2007.

    Just started getting HD problems. So I'm looking to replace my HD again.

    I've read a few things and just not sure if its all correct.

    1. mfslive is still the software to restore my backup images from 2007? Or I guess I can save my current image (with mcard info, etc)

    2. Anyway to expand the size to 2tb (looking at that WDEURS? drive I've seen mentioned on here).

    3. Can all this be done from an external esata or usb enclosure?

    4. jmfs is for the series 4 tivos only?

  4. unitron

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC
    Although it's a good idea to have a copy of the MFS Live cd v1.4 on hand, I'm assuming you can run WinMFS with admin privileges, and I'd recommend that.

    You can use MFS Live to do backup of the drive in there now, which will produce a .bak file, and you can use MFS Live to restore .bak files, and assuming it'll work with a 2TB drive at all, I guess it'll create a really big Apple Free partition on the end of the target drive.

    But I'm pretty sure you'll have to use WinMFS to actually expand into the unused space on the 2TB.

    WinMFS, although written by the same guy (spike) as the one who turned MFS Tools into the MFS Live cd, does not work with .bak truncated TiVo backup files. It doesn't write them or restore from them.

    It has its own truncated TiVo backup file format, that produces .tbk files, which are not usable by MFS Live or MFS Tools.

    As long as that S3 HD has been upgraded to version 11.0k or 11.0m of the TiVo operating system software (look on the system information page), you can use WinMFS for upgrading to drives up to and including 2TB and not worry about messing with jmfs.

    The WD20EURS is a "green" drive, but it's not a Caviar Green, so it doesn't have Intellipark enabled (and maybe it's not even in the firmware to enable in the first place), so you don't need to run wdidle3.exe to disable it, which would have required hooking it directly to the motherboard.

    So you can do the upgrade hooking it up via USB.

    As far as I know you can hook up via USB and run the WD diagnostic software long test before putting that EURS into service just to be sure there's nothing wrong with it (ship happens :rolleyes: )

    Use WinMFS to make a current backup (.tbk file) of the current hard drive, but go ahead and see if you can't copy it to the EURS as well--it'll take time, but all your settings and shows will be saved.

    After it finishes the copy (or if you make a back up and then restore to the 2TB from that truncated backup), when it finishes it'll say you've got extra space, do you want to expand.

    Tell it no.

    Close out that box and check the 2TB with mfsinfo (if you did a copy from the other drive, you'll have to change which drive is selected first), just to make sure everything looks kosher (it'll show a big Apple Free partition on the end of the drive).

    At that point you should probably put the 2TB in the TiVo and run it awhile to make sure it's working okay.

    Then you can hook it back up to the PC and run WinMFS again and select it can click on mfsadd to expand. You'll need to tell it yes, you want a partition bigger than 1.2TB.

    Earlier, when you do the copy or restore, it'll probably pop up a box asking if you want the opimized partition layout (you do), and offering the chance at a custom swap partition size.

    If it were me, I'd choose to make the swap 1000 or 1024 MB just as cheap insurance against any risk of a problem that can't be fixed by the TiVo itself with the original swap size. It's only like 15 minutes of standard def video worth of space. WinMFS's supersize option will give you more than that.

    For some reason trying to expand when it offers to at the end of a restore or copy doesn't work, although it might say that it did.

    I don't know why, but you have to do it as a separate step, even if during the same overall WinMFS session.

    As WinMFS does a backup, and especially as it does a drive to drive copy, it will probably appear to have frozen, but it very likely hasn't, and you just have to wait until it has finished.
  5. Oct 1, 2013 #565 of 572

    lmbebo New Member

    Mar 31, 2005
    Thanks for the extensive reply. I should get my new HD tomorrow.
  6. Oct 2, 2013 #566 of 572

    Darr247 New Member

    Mar 21, 2010
    Not shilling for newegg (or Western Digital), but they have the WD20EURS on sale again.
    Not as cheap as last time, but still $70 less than the cheapest S3-imaged 2TB drive I see on ebay.
  7. Oct 2, 2013 #567 of 572

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC
    One thing, that's the OEM version.

    Exactly the same physically and all that, but designed to be sold to OEMs who are building systems or something into which the drive will go, and who will be responsible for the warranty, if I'm not mistaken, and you might wind up with newegg and WD referring you back to each other over and over again and no one actually standing behind the warranty.

    If you think about it, in the case of buying one of these and putting it in your TiVo, you are the OEM.
  8. dfouts74

    dfouts74 New Member

    Dec 17, 2013
    Hi All -

    First time poster, but have used this thread and others on the board to troubleshoot in the past so I wanted to first say thanks for all the help.

    I have previously used the images provided in the image thread to restore a series 3 tivo harddrive (thermometer style) using mfslive cd and everything worked out OK. A friend has a series 3 hd (652160) that has a failing harddrive and I attempted to do the same but had no luck. Hoping someone who has seen these problems in the past can point me in the right direction.

    Attempting to restore Series 3 HD with MFSLive:
    After I execute the command to restore the drive with expanded size, part way through the copying I receive the error "restore: /dev/sdb113: no such file or directory."

    I have tried reformatting the drive, starting over, using a different computer, nothing seems to work. Tried to restore to original size, same problem.

    Attempting to restore Series 3 HD with WinMFS:
    I was able to borrow a friends windows 7 computer and figured I'd use winmfs to restore using the .tbk file found in /tivo-vb/showthread.php?t=388695

    When using winmfs as admin, I can navigate and select the drivethe drive and once I hit restore the program sits and the partition being copy notice says "processing".

    Am I out of options?
  9. unitron

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC
    With either program, restore without expanding.

    In MFS Live, this means do not use the -x option.

    You can skip z as well, just use -pi

    Then use


    either on the command line or clicking it in WinMFS to make sure everything looks okay, and if using the command line also run

    pdisk -l

    Then do the expansion as a separate step.

    In both cases the command is


    These should be version 11.0k, which is new enough to let you use a 2TB drive in a 652

    For use with the MFS Live cd v1.4:


    For use with WinMFS:


    When you restore with WinMFS it sits there and looks like it's not doing anything for a while.

    Just let it run.

    Eventually it will finish, at which point it says you have extra space, do you want to expand, and you tell it no.

    Then after looking at it with


    you expand as a separate step, although it wouldn't hurt to test it in the TiVo first and then bring it back to the PC to expand.

    Since the image is from a 652 with a different TiVo Service Number, you may or may not have to do a Clear & Delete Everything and force a few connections to the TiVo, Inc. servers, and reboot the TiVo a time or 3 before it gets itself straightened out.
  10. dfouts74

    dfouts74 New Member

    Dec 17, 2013
    Thanks for the quick reply Unitron!

    I downloaded the image from your dropbox and threw it on a flash drive. With the hard drive attached in an external enclosure, I ran the following in msflive:

    1. fdisk -l
    /dev/sdb1 = flash drive with .bak file
    /dev/sdc1 = 1 TB Harddrive for TiVo

    2. mount -t vfat /dev/sdb1 /dos
    3. restore -s 128 -pi /dos/652_gset.bak /dev/sdc1

    At this point it starts restore and begins. Unfortunately it returned an error again with only 36% remaining:
    Restore: Input/output error restoring MFS data.
    Restore: /dev/sdc113: No such file or directory.

    As for WinMFS, I left the computer on all night and all day while I was at work and it still said "processing", so I cancelled it last night and tried again - same thing. Should I be waiting more than 24 hours?
  11. unitron

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC

    No, 24 hours is way more than enough time.

    You need to run the drive maker's own diagnostic software long test on your target drive(s).

    Even if it's brand new.

    Always do that before putting a drive into service--"stuff" can happen during shipping.

    Also, has this drive ever been attached to a GigaByte brand motherboard, or used in something other than a TiVo?

    Amazon currently has the 2TB WD20EURS for $95, and any of the 3 Series 3 models can use it if they've already been updated to version 11.0k of the TiVo OS.

    However, /dev/sd"x"1 is a partition on /dev/sd"x", which is proper form when mounting it to access a file on that partition, but when restoring to a drive, you don't restore to a partition on the drive, you restore to the drive itself and the restoration process creates the needed partitions, so it would be more like

    restore -s 128 -pi /dos/652_gset.bak /dev/sdc
  12. dfouts74

    dfouts74 New Member

    Dec 17, 2013
    Finally had a moment to attempt using this method -- worked great.



Share This Page