mfsadd - Can you undo this?

Discussion in 'TiVo Upgrade Center' started by kooma, Feb 26, 2004.

  1. kooma

    kooma New Member

    1
    0
    Feb 26, 2004

    Advertisements

    Hello all..

    Can you un-do a mfsadd -x /dev/hdc /dev/hdd? I want to remove the second drive that I added. Since the second drive I have not been able to boot up Tivo. Just loops at "powering up".

    What's the opposite of mfsadd -x ?

    I checked all the switch but nothing. I also tried to add a different drive but I think it knows that there should be a partition on a second drive and will not allow me to add the replacement.

    Or if you can't undo the mfsadd -x , then how do you replace a second drive? I would be willing to try that...

    If anyone knows how you do this can you let me know? I have no Tivo ;-(
     
  2. Robert S

    Robert S New Member

    9,725
    0
    Jul 8, 2002
    Cambridgeshi...
    Sticking at 'powering up' suggests that the B drive is interfering with the A drive. This could be due to a jumper problem.

    There's no way to undo mfsadd. All you can do is restore a backup to the drive. Your recordings are not likely to survive this under most circumstances.
     
  3. Randyman...

    Randyman... New Member

    43
    0
    Feb 17, 2004
    Houston, TX
    I had the EXACT same problem a few weeks ago with my first upgrade.

    I made a back-up of the stock 40 gig drive, performed "mfsadd" with a 120g Maxtor as "b" drive (PC indicated upgrade was sucessful), and no matter what the jumper config, it would get to "A few more seconds" screen, and reboot.

    I sucessfully restored my backup image to the stock drive (38 hours of recordings still on stock drive), and removed the "-s 127" from the restore command, and performed "mfsadd" a second time.

    Instant success! I don't think I did ANYTHING different, but "mfsadd" worked the second time no problems - 144 Hours. Weird. My recordings are still entact on the old drive, and all is well on the new drive.

    Later :cool:
     
  4. RageKing

    RageKing New Member

    3
    0
    Aug 26, 2004
    I see that you got everything working after you did a second mfs add, but did your original drive just work by itself after doing the restore withtout the -s 127 option? I ask because I originally did an mfsadd and couldn't get both drives to work together, then ended up just restoring my backup to a larger drive and putting it in my tivo and it worked fine. However, what I want to know is, after having done that mfsadd, can I restore my backup to my original drive without the -s 127 option and have it preserve recordings but still function in another tivo by itself?
     
  5. Robert S

    Robert S New Member

    9,725
    0
    Jul 8, 2002
    Cambridgeshi...

    Advertisements

    The only way your recordings will survive is if the partitions created by mfsrestore line up exactly with the partitions already on the disk.

    Obviously, changing the size of any of the partitions will move the other partitions.
     
  6. BLAZN420

    BLAZN420 New Member

    18
    0
    May 24, 2005
    Brooklyn, NY
    I tried to add a 40gig B drive to my existing stock 60gig, I was getting the same errors at startup that was discussed in this thread. I now have a 120gig that I want to use with the 60, how do I go about getting it to work. I have tivo 14***.
     
  7. scrapyd

    scrapyd New Member

    1
    0
    Mar 17, 2006
    hey i just read ur post about after doing an upgrade getting stuck at the few more minutes screen, well i was a dumb butt and didnt back up my original drive, do i need a new image/os of tivo, what do i do?
     
  8. classicsat

    classicsat Astute User

    17,877
    0
    Feb 18, 2004
    Ontario Canada.
    If the A drive is fine, you can backup from that.
     

Share This Page

spam firewall

Advertisements