MFS Tools 3.2

Discussion in 'TiVo Upgrade Center' started by jkozee, Jun 4, 2015.

  1. jmbach

    jmbach der Neuerer

    3,179
    475
    Jan 1, 2009

    Advertisements

    -a is for recordings
    -i is for the alternate partitions. Since both primary and alternative partitions are blank in a standard Roamio image, it is not needed.

    Sent from my SM-G988U using Tapatalk
     
  2. jmbach

    jmbach der Neuerer

    3,179
    475
    Jan 1, 2009
    I prefer red over purple.
    But people have great success with both.

    There are theoretical reasons to choose red over purple and there are reasons to choose purple over red.
    Sent from my SM-G988U using Tapatalk
     
  3. Finalrinse

    Finalrinse Member

    193
    14
    Jan 12, 2005
    S.E. Michigan
    Thanks again for all your help! Greatly appreciated!!
     
  4. Finalrinse

    Finalrinse Member

    193
    14
    Jan 12, 2005
    S.E. Michigan
    I just ordered a WD30EFRX, should get it Tuesday. If for some strange reason I get the same error when running the copy command, I read at least one or two people having success using a clone dock, is this for real? They are fairly cheap, but don't even want to go there if it's a hoax with TiVo drives?
     
  5. jmbach

    jmbach der Neuerer

    3,179
    475
    Jan 1, 2009

    Advertisements

    Cloning drives work as long as you go to the same size or larger drive. Issue is that you will likely copy and corrupted blocks and it may hang of the source drive itself is bad.

    Sent from my SM-G988U using Tapatalk
     
  6. Finalrinse

    Finalrinse Member

    193
    14
    Jan 12, 2005
    S.E. Michigan
    Ok, I understand. I will try mfscopy first, and hope I don't get the error.
    Thanks
     
  7. Sixto

    Sixto Member TCF Club

    272
    13
    Sep 16, 2005
    I recently went with 3 WD30PURZ drives. I also have a WD60PURZ for the surveillance system. Only drives I'd use.
     
  8. njweb

    njweb Member

    46
    2
    Aug 23, 2015
    Tivo GSOD forced intentionally by KS 57 20201226_002557.jpg

    Well, after 6 days of everything working fine, yesterday I ran into an issue with my TiVO Roamio (now has the new 8TB HDD with the recordings from my 3TB HDD - discussed in my mfscopy posts last week above).

    Guide was fine for first 5 days or so, but then the guide data ran out - i.e. all channels in the guide grid now show "to be announced".
    I tried the 'connect to TiVO service' multiple times, but it always fails on the final ('loading data') step.
    I tried to initiate kickstart codes *ks 58 specifically) 3 times, but it did not work - I hit and held 'pause' button for 2 seconds after the yellow/amber light started to flash per the following instructions from the weaknees site):
    "3. When you see the yellow/amber light begin to flash, wait a second and then press and hold the Pause button on the remote for two seconds, then release it.
    4. Within 5 seconds, press the kickstart code (see below) on the remote control.
    5. If you are successful, the green and amber lights will blink in alternating patterns to indicate the code has been accepted.[end quote from weakness site]"


    So I am now going through the 'Reset to Defaults, Clear Guide Data and To Do List.'
    Hope I will not get a bricked unit (like some reddit posts linked below) and have to redo everything. :(
    It has been on the 'clearing guide data and to do list; this may take up to an hour" screen for about 1 hour 20 minutes and counting...


    Edit - Well I knew based on posts that most likely since the 'CPG and TDL' was still running after almost 2 hours, based on other posts, it was stuck and not going to end.
    So I did some additional research and found this is a KNOWN bug and bricking issue on TE3 units with 'CGD and TPL' that TiVO is aware of).
    Thread: Premiere Stuck on "Clearing Guide Data"
    Was able to get kickstart to run (also did a 58 once earlier and did not do anything) and, per solution * on page 6 of above thread, used a KS 57 based on a recommendation in above thread that will hopefully help solve the issues...
    Got the forced GSOD (expected behavior) that should take about 3 hours, followed by a likely / potential (albeit hopefully quicker) CGD and TPL and then the issue will hopefully be solved per above thread.
    FINGERS CROSSED! Assume my recordings will also remain intact (KS 57 should not impact those)...

    * SOLUTION from above link: bricco said:
    "Hey Guys, good news on my Tivo Premiere. It was stuck on Clearing and Deleting Everything since February 22. Tivo customer support finally sent me the Roamio solution (not a Roamio). However, the KS57 did work. Unplug Tivo for 15 seconds, wait for yellow light press pause, enter 5-7, watch lights blink. Screen continues to power up until you get the green screen (indication that something was working). Green screen for about an hour and start up screen appears. I had given up on this unit but now it is back, lifetime intact. Good luck with your unit."

    So based on that I am cautiously optimistic...

    UPDATE -
    The good news is that it took less than an hour to perform the KS 57 and the TiVO was back on Live TV, so it is not bricked; all my recordings are in tact.
    The bad news is I still have 'to be announced' in the program guide on all channels...

    Any way to fix it (since Clearing Guide Data won't work since I am on TE3)?
    Does 'repeat guided setup' delete the cable card pairing?
    I did the M-Card / cable card pairing 5 years ago and it has been fine ever since... I prefer not to have to go through it again with my cable provider and / or TiVo phone support.

    EDIT - NEVER MIND:
    The guide came back by itself (about an hour or so after the kickstart 57 completed). :)
     
    Last edited: Dec 26, 2020
  9. gsutkin

    gsutkin Member

    146
    10
    Oct 7, 2007
    White bolt hard drive hours_ed.jpg Today I ran the 3 additional mfsadd/mfsaddfix's. Posting an image of my new system info. My 10TB WD102PURZ took me from 478 HD hours to 1606 HD hours. Thanks to everyone here, especially jmbach. You guys taught a "tinkerer" how to do this!
    I will post my setup in the Bolt hard drive upgrade thread.
     
    Last edited: Dec 26, 2020
  10. Jan 1, 2021 #1950 of 1988
    Jon Kranes

    Jon Kranes New Member

    21
    4
    Nov 25, 2020
    I am trying to backup up an old TiVo Premier drive with mfs backup in order to restore it to a brand new drive. If I am getting several "critical target error" messages during the backup, am I correct in assuming that means the resulting backup is unlikely to restore successfully to the new target drive? If I don't really care about preserving anything, would I be better off initializing the new drive from a new disk image? How would I request an image for model 748000? Thanks!

    [edit: trying the backup a second time, it completed without errors. I'm speculating that means the source disk has unreliable reads -- sometimes works, sometimes does not?]
     
    Last edited: Jan 1, 2021
  11. Jan 1, 2021 #1951 of 1988
    jmbach

    jmbach der Neuerer

    3,179
    475
    Jan 1, 2009
    First, I would use DvrBARS to backup and restore a premier image. If you do not want to save any recordings you can use the truncated backup. Won't take long to back it up. If you use the standard backup it will save your recordings but the drive you store the file on should be larger than the drive you are backing up.

    Second, run any drive that you are going to back into the premier through manufacturer diagnostic both a full read and write before restoring an image on it.

    Third, in the DvrBARS thread you can ask for an image. (Or if you wait around a little ggieseke might see the request here and send you one)

    Sent from my SM-G988U using Tapatalk
     
  12. Jan 1, 2021 #1952 of 1988
    Jon Kranes

    Jon Kranes New Member

    21
    4
    Nov 25, 2020
    Thanks. I tried backup using DvrBARS and got similar disk read errors, even with truncated backup. I'm going to give up on saving anything and just restore a new image, which I asked for on that thread.
     
  13. Jan 1, 2021 #1953 of 1988
    jmbach

    jmbach der Neuerer

    3,179
    475
    Jan 1, 2009
    If DvrBARS does not work, then it is less likely MFSTools would work.

    Sent from my SM-G988U using Tapatalk
     
  14. Jan 1, 2021 #1954 of 1988
    WVZR1

    WVZR1 Active Member

    994
    142
    Jul 30, 2008
    The WV...
    Doing MFSCOPY in a PC - 3TB - Roamio to new 8TB RED+

    Used Command: mfscopy -am 2040 dev/sda /dev/sdb. It copied .60% and the screen went to sleep, I assumed it was still running - is it? After a short while I just hit enter and it ran another line to 1.47% - screen sleep - enter key - runs again to 2.19%. Is the process actually continuing to run or is it 'timing out' as well'? I don't know that I used correct terminology but ......

    3TB was something close to 85% - how long will this run approx? Can I ignore the 'screen sleep' and walk away? Can I do a key command while it's running to keep screen awake?

    I used a USB to boot PC and the 2 drives are the only HDD connected.
     
    Last edited: Jan 1, 2021
  15. Jan 1, 2021 #1955 of 1988
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,651
    1,148
    Apr 6, 2000
    SF Bay Area
    Most likely, overnight.
     
  16. Jan 1, 2021 #1956 of 1988
    WVZR1

    WVZR1 Active Member

    994
    142
    Jul 30, 2008
    The WV...
    Thanks for checking on me!!

    I assumed much longer than that - it's a very old PC but main concern is the 'maybe the screen sleeping' isn't interrupting the task. When this completes do I just do a 'Control C' and then a 'shutdown -now' or just what?

    Do I need to do any of the extensions/adds before removing it back to the Roamio for a 'test'?
     
  17. Jan 1, 2021 #1957 of 1988
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,651
    1,148
    Apr 6, 2000
    SF Bay Area
    When it completes, it should just return to the prompt.
     
    WVZR1 likes this.
  18. Jan 2, 2021 #1958 of 1988
    WVZR1

    WVZR1 Active Member

    994
    142
    Jul 30, 2008
    The WV...
    Got the message 'copy done' - I 'shutdown' the machine. I believe I was told that now I install back to the Roamio run it and let it connect, acquire current guide etc then plan on removing it back to the PC to be expanded. Is that correct?

    I believe I need to be reminded of the 'kickstart code' that should/maybe be done after the HDD is put back to the Roamio this time.

    Is the correct KS 58?
     
  19. Jan 2, 2021 #1959 of 1988
    jmbach

    jmbach der Neuerer

    3,179
    475
    Jan 1, 2009
    Yes. KS 58

    Sent from my SM-G988U using Tapatalk
     
  20. Jan 2, 2021 #1960 of 1988
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,651
    1,148
    Apr 6, 2000
    SF Bay Area
    It should already be expanded.
     

Share This Page

spam firewall

Advertisements