MFS Tools 3.2

Discussion in 'TiVo Upgrade Center' started by jkozee, Jun 4, 2015.

  1. VinceJP

    VinceJP New Member

    1
    0
    Jul 22, 2017
    jmbach Thanks for taking the time to develop and share. Just upgraded drive on Roamio from 500gb to 3tb and it was a breeze with your utilities. Other than a couple of recordings not working, (V111 errors) everything else is perfect. Plus I'm not totally sure the shows worked before upgrade as I didn't verify all recordings prior to upgrade. Awesome job and much appreciated.
     
    Last edited: May 25, 2020
  2. mv916

    mv916 New Member

    5
    0
    May 27, 2020
    I took the latest version of mfstools 3.32-devel usb/hd from post 131. I copied over to a usb using hdd raw copy, booted to usb and logged in. I am trying to copy recordings from a 3tb roamio pro to a new 4tb hd. I ran the command:

    mfscopy -a /dev/sda /dev/sdb

    At about the 10% mark I started getting the error below. I tried 2x. I think the copy process stopped when the error occured but now that I think of it, I'm not 100% sure as the first time I ran, I came back to a screen full of errors and didn't double check the second time. Any ideas? As a backup, I ordered a clone station as I understand another option to retain shows is to clone the drive and then use mfstools to expand the partition to the full 4tb?

    INFO: rcu_preempt detected stalls on CPUs/Tasks: {0}
     
  3. 21364guy

    21364guy Member

    66
    1
    Oct 20, 2007
    I am trying to boot MFS Tools from USB using an 8GB thumb drive. I imaged the device twice, once from my Mac using 'dd' and, when that failed to boot on my PC, I instead used my PC and the recommended etcher utility. In neither case does the USB drive show up in the boot options on my PC (gigabyte B450 board). I even enabled CSM but it made no difference. Any suggestions on what may have gone wrong? I did check the md5 of the .xz file and it's correct. Here's the size and checksums I get for the decompressed image:

    1416626176 MFSTools_3.32-devel_openSUSE_Leap_42.1_JeOS.x86_64-0.0.2-Build4.1.raw

    % shasum MFSTools_3.32-devel_openSUSE_Leap_42.1_JeOS.x86_64-0.0.2-Build4.1.raw
    41cde577a31ec2c8e5d0b1414c38945cf4ebb8fa MFSTools_3.32-devel_openSUSE_Leap_42.1_JeOS.x86_64-0.0.2-Build4.1.raw

    % md5 MFSTools_3.32-devel_openSUSE_Leap_42.1_JeOS.x86_64-0.0.2-Build4.1.raw
    MD5 (MFSTools_3.32-devel_openSUSE_Leap_42.1_JeOS.x86_64-0.0.2-Build4.1.raw) = 324d4c13106ac92b40c255ba131e9f4e

    I would greatly appreciate any suggestions on resolving this. I don't have a built-in optical drive so was really hoping to boot from USB as I did when installing Win 10.
     
  4. 21364guy

    21364guy Member

    66
    1
    Oct 20, 2007
    Glad to say this is resolved. I had to turn on some USB legacy settings in the BIOS as well.

    Unfortunately it hangs while booting Linux. Is it possibly my box is too new? It's B450 chipset with Ryzen 3700X and RTX 2060 super. It hangs right after "fb: switching to..."

    My son's box is an older intel platform so I could give that a try instead...
     
  5. mv916

    mv916 New Member

    5
    0
    May 27, 2020
    I have a x470 chipset with Ryzen 2700x and was able to boot without issue. I have a generic graphics card though as the box is only for axis surveillance recording.
     
  6. jmbach

    jmbach der Neuerer

    2,959
    406
    Jan 1, 2009
    Can you post a screenshot of where it stalls?

    Sent from my SM-G988U using Tapatalk
     
  7. 21364guy

    21364guy Member

    66
    1
    Oct 20, 2007
    Yes, I'll try to post a screenshot tomorrow.

    I just tried the VHD running under VMware fusion on my Mac (2018 Mac mini). It says "loading initial Ramdisk" then I just get a black screen.

    So I'm failing two different ways... I'll try my son's computer tomorrow (with the USB thumb drive) to see if I have better luck.
     
  8. 21364guy

    21364guy Member

    66
    1
    Oct 20, 2007
    Today when I tried booting from USB thumb drive I got:

    "... core perfctr but no constraints; unknown hardware!"

    Previously it had made it further, to "fb: switching to..."

    Possibly this has to do with which menu option I selected when booting (e.g. advanced or not). But none of them worked.
     
  9. 21364guy

    21364guy Member

    66
    1
    Oct 20, 2007
    I guess I'm finally on the right track. I used VMware fusion and the ISO to build and boot a VM (the .VHD file doesn't work for me). Then after setting USB compatibility in the VM to "3.0" I'm able to mount disks using a couple of USB 3.0 docks I have. I haven't pulled my active TiVo drive yet, but I inserted my original Roamio 1TB drive into the dock and was able to run "mfsinfo" on it.

    I'm planning to do the upgrade from existing 2TB to new 3TB drive tomorrow. Once the drives are visible in Linux, is this all I need to do:
    Code:
    mfstool copy -ai <orig drive> <new drive>
    This will copy my recordings, maintain cablecard pairing, and let me use the 3TB of capacity on the new drive? And is running "supersize" still relevant on the new drive?

    Thanks :)
     
    Last edited: May 28, 2020
  10. 21364guy

    21364guy Member

    66
    1
    Oct 20, 2007
    Can anyone send me a pointer to the latest source for MFS Tools? Using VMware I was able to do my copying, but an OS X build would have been really handy. As I have some time on my hand these days I'd at least like to investigate the possibility and maybe save some other folks time in the future.

    I took a quick look on sourceforge but everything I saw there seemed to be from ~2005. So I'd be quite interested in the source for the very latest version that folks are using, 3.32 or better(?)
     
  11. jmbach

    jmbach der Neuerer

    2,959
    406
    Jan 1, 2009
    PMed you a link to the latest source code

    Sent from my SM-G988U using Tapatalk
     
  12. jmbach

    jmbach der Neuerer

    2,959
    406
    Jan 1, 2009
    Yes that will copy, expand, and save your recordings.

    Sent from my SM-G988U using Tapatalk
     
  13. mv916

    mv916 New Member

    5
    0
    May 27, 2020
    After 3 attempts to us mfstools to copy 3tb to 4tb (3rd attempt failed at 30%), I thought I would try a direct clone (using a clone dock). I was able to clone and boot and verify all recordings. Am I able to use mfstools to get the remaining 1tb? would I use the supersize command, another command...or will this route not work? I want to retain recordings.
     
  14. jmbach

    jmbach der Neuerer

    2,959
    406
    Jan 1, 2009
    You can follow the instructions in the 10 TB Roamio thread with one iteration.

    Sent from my SM-G988U using Tapatalk
     
    mv916 likes this.
  15. mv916

    mv916 New Member

    5
    0
    May 27, 2020
    Great. that worked like a charm. thanks for your help. It says that I can do the expansion 3 additional times. Is that because I have other drives in the same computer? @jmbach Do you have a donation link?
     
  16. Inventionroom

    Inventionroom New Member

    12
    0
    May 20, 2020
    Hi... I’m looking for MFSTools assistance for a TCD746320 image put onto a new 4tb WD40EFRX red drive.

    I’ve searched and searched but can’t find the solution to my issue.

    My TiVo premiere 4 drive died. From research here, I ordered a new WD40EFRX (WD Red 4TB NAS Internal Hard Drive - 5400 RPM Class, SATA 6 Gb/s, CMR, 64 MB Cache, 3.5"). Member and DVRBars author @ggieseke was kind enough to send me a link to the latest TCD746320 image. I’m using a laptop and external USB HD dock (Wavlink USB 3.0 Dual Bay Docking Station).

    I used DVRBars to restore the image to my new HD. This worked flawlessly. Now it was time to use MFSTools 3.32 to expand.

    Booting from MFSTools boot CD, entering user name (root) and PW (tivo), I was ready to “have a lot of fun.” :wink:

    [EDIT: The steps below did not work for me. I’m leaving the post up so anyone curious can see what happened in my case. For the steps that ended up working for me, view my update post.]

    I then entered the commands: mfsadd -x /dev/sdX

    Then apmfix /dev/sdX. (sdX represents my DVRBars restored image TiVo drive).

    During ampfix “contemplating if coalescing makes sense,” it says “Coalesced size is too large. Actual size is 7188894720 bytes but should not exceed 4294967295 bytes. The MFS media partition needs to shrink by at least 2893927425 bytes. Unable to coalesce. Processing of drive in incomplete.”

    I decided to see what would happen if I put it in the TiVo. What happens is it brings me to a screen asking me to remove external storage (I am not using external storage). It instructs me to press thumbs down 3 times and enter (to permanently remove external storage) and it reboots to the same screen. Tried multiple times and it’s stuck in this endless loop.

    I started all over again doing DVRbars and restoring the image to the drive again. Worked great.

    Booted into MFSTools and was ready to have a lot of fun.:)

    This time I tried the command mfsadd -xM 2000 /dev/sdX

    Followed by apmfix /dev/sdX

    It completed, but when I install into TiVo and go through setup then look at the system storage it showed 341 HD hours, so around half of the storage space was still unused (around 640 HD hours was what I was expecting... based on research).

    A few other notes—DVRBars says my 4tb HD is 3.64TB (seems like a lot of reserved/unused spaces). Based on this I thought I would start the entire process again and try: mfsadd -xM 1820 /dev/sdX

    1820 was picked because it’s half of 3640 (it was late and I was just trying stuff at this point)— I then did the same ampfix command and it worked... but now when I finally get to the TiVo system info it showed 310 HD hours. So, TiVo seems to be only seeing one partition?.. and 1820 was just limiting it to less than 2tb (2000 gave me 2tb/341 HD hours)?

    I also repeated everything and tried mfsadd -xM 4000 /dev/sdX — but when I do the ampfix I get the “Coalesced size is too large” and then when installed in TiVo I get the same (remove external drive) endless boot loop. Same thing when I tried 3000 (at this point I was just hoping to get lucky)... so while I am trying to have a lot of fun, I’m stuck... lol

    Pardon the length of this, but I wanted to document everything to help others seeking similar help.

    I’m hoping @jmbach or one of the experts here can review this and tell me what I should try? I also want to thank all who contribute here, it has been an amazing resource and great community. I also pledge to follow up and report the outcome (too often I search and find a post related to my issue that they abandoned without updating their progress... I will update my progress).

    ———————
    EDIT UPDATE: Anyone interested, please view my update post to see the exact steps that appear to have been successful for me.
     
    Last edited: Jun 2, 2020
  17. mv916

    mv916 New Member

    5
    0
    May 27, 2020
    @Inventionroom
    I'm not a pro. I was reading the 10tb roamio and used to expand my 3tb clone to 4tb drive for my roamio. I think you do the of add/fix and any overage gets taken care of when you boot. At the remove external drive, did you select "yes" to delete the external drive that doesn't exist?
    DIY 10TB Roamio
     
  18. Inventionroom

    Inventionroom New Member

    12
    0
    May 20, 2020
    @mv916 i did choose to remove/delete the external drive that doesn’t exist, but the same screen returns when the system reboots itself, I repeat and it happens again (endless loop).

    As for the add/fix, I think you are referring to the mfsaddfix command, but that is for Roamio or later versions of TiVo. Mine is a TiVo Premiere, series 4. The MFSTools write up says “mfsaddfix - Its purpose is to relocate mfsadd added partitions in Roamio and later TiVos“ so I don’t think it applies to my hardware. I thank you for the reply though!
     
    Last edited: May 30, 2020
  19. jmbach

    jmbach der Neuerer

    2,959
    406
    Jan 1, 2009
    Several things. So the issue is that you will not be able to expand the 320GB image to use the whole 4TB drive. This is because partition restrictions in the TiVo OS.

    The other thing is that ggieseke now has a 4 TB image you can restore to that drive directly.

    Sent from my SM-G988U using Tapatalk
     
  20. Inventionroom

    Inventionroom New Member

    12
    0
    May 20, 2020
    Oh wow. I couldn’t find that info anywhere when searching for hours on the forum.

    if I had an additional hard drive, with the 320GB image on it.. and married it to my TiVo, would MFSCopy be able to copy and expand the drive?

    If not are there any other solutions or am I stuck with a 2tb limit? I see a vendor on eBay sells a 4TB drop in drive, so there must be a way... thanks for any info.
     

Share This Page