MFS Tools 3.2

Discussion in 'TiVo Upgrade Center' started by jkozee, Jun 4, 2015.

  1. Sep 27, 2015 #141 of 1704
    jmbach

    jmbach der Neuerer

    2,940
    398
    Jan 1, 2009
    It will overwrite any drive you pick so as long as you pick the right drive, there will be no problem.

    What you are seeing I think is the fact it looks for partition 10 as the MFS header resides there.

    I am not sure why the ISO did not work for you. It was my first attempt at using SUSEStudio to make an ISO and perhaps some drivers were left out.

    I will look into it more. Thanks for the feedback.
     
  2. Sep 27, 2015 #142 of 1704
    Anotherpyr

    Anotherpyr Active Member

    449
    121
    May 6, 2015
    Thanks for all your help. First attempt failed. So I swapped the drives around. I was getting this bizarre behavior with the idsonix adapter where it would start to error and then reappear on another drive letter i.e. It would move from /dev/sdb to /dev/sdd. So I put the original drive in the pluggable adapter and the destination in the idsonix and that worked.

    Not sure what was going on with the iso. I couldn't even get mfstool info to work with the TiVo drive in either adapter.

    Follow up: it finished and I put the 3TB drive in the premiere. It booted and updated without any issues. I now have 476 HD hours of recording capability on original two tuner premiere. Decided to replace the noisy fan next.
     
    Last edited: Sep 27, 2015
  3. Sep 29, 2015 #143 of 1704
    egable

    egable New Member

    4
    0
    Sep 29, 2015
    I just tried cloning my 1.8 TB original TiVo drive from my TiVo Premier XL 4 onto a 4 TB WD Green drive and while the TiVo boots the drive and shows all the shows and recordings, I cannot get it to expand to the full 4 TB.

    I originally used JMFS tools live USB to copy the drive. I tried the Extend option from there, but it failed. Then, I tried the MFS Tools 3.2 Live USB image from jmbach to try to copy and/or extend the drive. However, MFS Tools keeps reporting an invalid MFS header and no /dev/sdb10 or /dev/sdc10. They both show as (null). MFS Tools seems incapable of doing anything with either the source drive or the 4 TB destination drive (even though TiVo boots both drives just fine).

    On a side note, I cannot get root access on the MFS Tools Live USB image. The password is not 'tivo'.

    Any suggestions on what to try next to expand the 2TB image into the full 4TB of space would be appreciated.

    Thanks.
     
  4. Sep 29, 2015 #144 of 1704
    jmbach

    jmbach der Neuerer

    2,940
    398
    Jan 1, 2009
    Try 'Linux' for the root password then. I may not have changed the default root. What do you get when you run 'fdisk -l' command.
     
  5. Sep 29, 2015 #145 of 1704
    egable

    egable New Member

    4
    0
    Sep 29, 2015
    The password was indeed "Linux". I unplugged the other hard drive I had in the system which made the source TiVo drive be /dev/sda and the destination drive be /dev/sdb. Then, MFS Tools started reading both drives just fine. I did:

    mfsadd -x /dev/sdb

    And it completed without any errors, creating partition 15 and 16. However, when I then put the drive back in the TiVo and started it up, it said something about removing an external storage device. Then it got stuck in a reboot loop. I tried using Kickstart codes, but none of them would work at all. Any suggestions?
     
  6. Sep 29, 2015 #146 of 1704
    jmbach

    jmbach der Neuerer

    2,940
    398
    Jan 1, 2009
    You cannot add a pair of partitions with MFSTools 3.2 to a premiere image. That is the result you will get. If you add a pair of partitions, you will have to coalesce the pair manually for it to work in a Premiere. A better option is to use MFSTools to copy and expand the drive from the source to the target. The target drive will have a similar partition layout as a native TiVo drive. (2 app and 2 media partitions with the OS located in the middle of the drive)
     
  7. Sep 29, 2015 #147 of 1704
    egable

    egable New Member

    4
    0
    Sep 29, 2015
    How do I expand it? I know mfscopy will copy it over, but does it also expand it?
     
  8. Sep 29, 2015 #148 of 1704
    jmbach

    jmbach der Neuerer

    2,940
    398
    Jan 1, 2009
    It will now copy and expand in one command. Use mfstool copy -a /dev/sdX /dev/sdY as your command.
     
  9. Sep 30, 2015 #149 of 1704
    egable

    egable New Member

    4
    0
    Sep 29, 2015
    After about 18 hours of copying, it completed, and the box now boots with all the expected available space. Thanks for the assistance.
     
  10. Oct 3, 2015 #150 of 1704
    nelem

    nelem New Member

    12
    0
    Apr 18, 2006
    Does any one have experience of this TiVo? I had a hard drive failure and managed to rescue virtually all data to 1 3TB drive using ddrescue so I have a 1TB image on a 3TB drive which I want to expand but not having any joy.

    JMFS-rev104 (from rosswalker.co.uk/tivo_upgrade) says No TiVo drives
    MFSLive 1.4 sees the partitions on the drive but I have been advised not to use it.
    MFS Tools 3.2 mfsinfo gives "ERROR Unexpected values for state/magic c1b2bdfd/00000000"

    Any suggestions?

    Cheers
     
  11. Oct 3, 2015 #151 of 1704
    jmbach

    jmbach der Neuerer

    2,940
    398
    Jan 1, 2009
    Looks like the MFS header is corrupt. If the backup header is intact you might be able to use that to fix it.
     
  12. Oct 5, 2015 #152 of 1704
    chalooch101

    chalooch101 New Member

    19
    0
    Nov 29, 2005
    i would like to copy my shows form an already expanded 2TB premier drive to a new 4TB premier drive....which command do i use?

    mfstool copy -a /dev/sdA /dev/sdB.
    or
    mfstool copy -ai /dev/sdA /dev/sdB.


    does the new drive then need to be expanded?
     
  13. Oct 5, 2015 #153 of 1704
    jmbach

    jmbach der Neuerer

    2,940
    398
    Jan 1, 2009
    It will expand while it copies.

    Either command will work. The latter copies the alternate root and kernel partitions and only adds a few minutes to the copy. What will take a while is copying the recording streams. If the drive is almost full it will take a couple of days. So use USB3 or SATA/eSata connection.
     
  14. Oct 7, 2015 #154 of 1704
    nelem

    nelem New Member

    12
    0
    Apr 18, 2006
    Where will I find the back up header? Is there thread about this I can read up on?

    Is it possible, then, that MFSLive is using a different copy of the header than JMFS and MFS Tools are? The TiVo still boots and runs fine.
     
  15. Oct 7, 2015 #155 of 1704
    jmbach

    jmbach der Neuerer

    2,940
    398
    Jan 1, 2009

    If the TiVo boots and runs fine with the current recovered image on the 3TB drive, then it is more than likely that there is something else other than a corrupted header. Since it is a Cisco box and not a standard TiVo box, the header information could be different than a normal TiVo made box. However, looking at rosswalker's site, looks like JMFS and probably MFSTools 3.2 should work. The header is the first block of partition 10 and the back up header is the last block of partition 10.

    If you could post or the header and back up header, perhaps the forum members cold help more. Might want to create a new thread to work on this.
     
  16. Oct 9, 2015 #156 of 1704
    nelem

    nelem New Member

    12
    0
    Apr 18, 2006
    Last edited: Oct 14, 2015
  17. Oct 9, 2015 #157 of 1704
    jmbach

    jmbach der Neuerer

    2,940
    398
    Jan 1, 2009
    First and last sector.
     
  18. Oct 14, 2015 #158 of 1704
    locksmythe

    locksmythe New Member

    10
    0
    Oct 9, 2015
    How are you attaching the second drive to the roamio? Is it a direct attach port multiplier on the internal sata connector?
     
  19. Oct 24, 2015 #159 of 1704
    JimWall

    JimWall Member

    104
    4
    Oct 19, 2002
    I just upgraded my Roamio from factory 1 TB green to 3 TB green.
    It took 5.5 hours to copy over.
    Everything went well except after reboot there are two issues:
    No channels
    No program guide information.
    No One Passes
    Roamio right away downloaded the channels
    Then sent a message it did so.
    I made a connection and downloaded the program information.
    One Passes now appear but not to do or guide information
    I guess the Garbage collector has to run a very large update which will take hours then program information will be there.
     
  20. Oct 24, 2015 #160 of 1704
    JimWall

    JimWall Member

    104
    4
    Oct 19, 2002
    GC completed at 8:16 PM and all is good.
    To Do list is there.
    Program info present
     

Share This Page