MFS Tools 2.0! An upgrade revolution!

Discussion in 'TiVo Upgrade Center' started by Tiger, Jun 15, 2002.

  1. Jul 2, 2002 #101 of 670
    alan

    alan Member

    152
    0
    Dec 27, 2001
    IN
    I'm using Tiger's 2.0 Mfs Tools Boot Floppy and noticed something that I didn't notice on the older versions of the Boot CDs.

    When I boot from the boot floppy, I see the hd[a-d] partitions fly by, but when I use SHIFT+PAGE-UP to go back and look for those lines they are missing from the output. The only size information I can see is the box left over from the initial BIOS configuration dump.

    Am I doing something wrong or does the floppy boot work differently from the CD boot?

    I would test the new CD boot, but I blew away my NT partition and either my CD burner is so old (Phillips 2000) or my Windows 95 system is so unstable that I can't reliably burn any CD's in Windows 95 anymore. My older Boot CD's were burnt with Nero on my NT partition.

    Oh, and by the way. You guys are gods!

    I pulled my A drive out of my DTiVo.
    Backed it up to my C: drive.
    Popped in my 80G Maxtor.
    Restored to the new Maxtor.
    Popped it in my DTiVo, Tested, it worked.

    Now I'm trying out the "dd" route. Seeing how saving everything works.

    Can I say it again? You guys are gods!
     
  2. Jul 2, 2002 #102 of 670
    gardavis

    gardavis Member

    140
    0
    Nov 24, 2001
    Deerfield...
    I noticed that problem too. I had to watch the screen closely to see that the drive's size was correct because after it scrolled off the screen, I was not able to back up to it. The last "x" lines of the scroll buffer were cleared.
     
  3. Jul 2, 2002 #103 of 670
    alan

    alan Member

    152
    0
    Dec 27, 2001
    IN
    It's reassuring to know that I'm not the only one seeing it. :D

    Nothing comes out after the last: PIIX4: not 100% native mode: will probe irqs later

    Unfortunately, right after that line is where the ide probing output begins.

    Anyway, I dd'd my 40G DTiVo A drive onto a 80G drive overnight (I went to bed). This morning I popped it in and tested it. Then mfsadd'ed it and finished up. Now I have 69 hours instead of 35 hours showing in the DTiVo status screen. I'm a happy man! :D

    Thanks Tiger! I used your 2.0 Mfs Tools Boot Floppy.

    Thanks Hinsdale! I followed your "new" instructions.
     
  4. Jul 2, 2002 #104 of 670
    alan

    alan Member

    152
    0
    Dec 27, 2001
    IN
    HTH,

    Does having DMA enabled slow transfers down?

    Or does this mean that a dd from Master to/from Slave is faster than going between Primary and Secondary drives? If so, why does that happen?

    I would have thought going between Primary and Secondary controllers would be faster because I thought Primary and Secondary were two separate controllers. I also thought that piping two dd's together would have gotten the controllers going full speed. Something like this:

    dd if=/dev/hda bs=1024k | dd of=/dev/hdc bs=1024k

    that is assuming that the pipe could take a 1024k write without causing an I/O block.
     
  5. Jul 2, 2002 #105 of 670
    HTH

    HTH No Avatar Selected

    4,075
    4
    Aug 28, 2000
    Lincoln, NE
    Actually, I got your first and second times reversed. I thought you said the second time was faster than the first. I see now that I misread it.
     
  6. Jul 3, 2002 #106 of 670
    bidger

    bidger Active Member

    3,426
    0
    Mar 30, 2001
    Elmira, NY
    Well, I can finally celebrate. I'm a little hurt that the Staples rebate for
    the hd came before I finished the project, but I'll take it. I checked the jumpers and four had gotten smooshed somewhere along the process(on
    the original hd). I straightened them out, connected everything, powered up, and *ping* GSOD! I didn't panic & it rebooted and I know have 30+ hrs.
    at Best and 109 at Basic! Finally!! I tried to remove my previous post. but
    for some reason I'm not being allowed, so please ignore it.
     
  7. Jul 3, 2002 #107 of 670
    cameronj

    cameronj New Member

    33
    0
    Apr 2, 2002
    Edit - found it
     
  8. Jul 3, 2002 #108 of 670
    springtyme

    springtyme New Member

    1
    0
    Dec 15, 2001
    miami,fl,us
    Hi!

    I have an SA 3.0 w/ a 15+60. I have another SA for hacking. Can I make an unmarried 15mb (image) or prefer direct copy with out divorcing my 15/60?

    I have video on my 15/60 I'd like to be able to access on the other SA 15 gig drive.

    But i don't want to effect the original 15/60.

    Thanks

    Jerry
     
  9. Jul 4, 2002 #109 of 670
    Savard

    Savard TiVo-ized Aug 2000

    68
    0
    Mar 5, 2002
    Tri-Cities,...
    I backed up both of my 2x60GB TiVos and noticed a very large difference in backup file size between the Sony and Philips. The Philips backup was about 415MB and the Sony backup was around 170MB. In each case I used the same backup command and used level 6 compression.

    I also did a backup of the original A drives from each unit (which were stored on a shelf since I upgraded quite a while back) and got basically the same results: Philips backup around 415MB and the Sony around 170MB.

    Anyone else notice something similar? Why such a large difference? The Philips was originally a 14Hr unit that my wife won in the TiVo essay contest a couple years back. The Sony of course was a retail 30Hr unit.
     
  10. Jul 5, 2002 #110 of 670
    NeZorf

    NeZorf New Member

    81
    0
    Oct 22, 2000
    I just posted this on the "upgraded tivo very slow" thread. (some points in the post below refers to stuff said in that thread, but thought it might be here as well as it relates to MFSTOOLS 2.0. Hope to hear your thoughts on this)
    ======================================

    After experimenting with the MFSTOOLS 2.0 utility for my upgrade and reading the threads, I think I might have a connection to the source of some of these problems.

    But first I just want to say that Tiger did a really awesome job to come up with the MFSTOOLS 2.0. and that his program has help a lot of people get on board.

    The command I used for upgrading from two drives to two new larger drives:
    mfsbackup -Tao ..... .... | mfsrestore -s 128 -xzpi ... ...

    All shows seems to be playback ok on the new drives.
    All seems fine until I would notice it would sometimes hang and crash. Sometimes crashing and rebooting by itself. Sometimes going through the menu and then a hard crash, requiring a reboot by me. And then the problem of the listing of programs in the search by name would generate a random list of repeating shows, and sometimes no shows at all. The wishlist searching also produced no shows for wishlists. My indexing after a call took a long time. I have since blown away that setup, I didn't see this thread to check the swap partition logs. But I have no doubt that was it, from what you guys are saying.

    I believe that the other threads of:
    1 the slow menus,
    2 search by name coming up empty/messed,
    3 wishlists producing no results,
    4 indexing after a call taking an enormous amount of time (days, not the usual ~1hr)

    are all related to the MFSTOOLS 2.0 use of the switches involved in the backup/restore command process: -xzpi

    Especially on the -p switch.

    Here is a post from the main 2.0 thread on what the -p switch does. That it attempts to reorganize the partition layout of series 1 systems to be similar to what the layout of series 2 systems.

    I think it is possible that there is a bug in this part of the program where it messes up the swap partition (it could mess up more partitions that we don't know yet)

    So that is why there are all there threads poping up after the MFSTOOLS 2.0 came out. The fact that v3.0 came out at the same time and the weird dial-up failed/interrupted error we experienced a few weeks ago only continues to dilute the source of the these problems.

    Back to my experiment, after all the problems that I was having, I redid the upgrade with the "dd" linux copying utility and then used the "mfsadd -x" expand command. and so far the systems has been as stable as it was before the upgrade, and all the functions reported above are operating normally.

    Of course there are probably many more people with perfectly working Tivos after using the MFSTOOLS 2.0 commands, and every Tivo system is a little different, so it would be best to use MFSTOOLS 1.1/dd when possible, after Tiger has looked more into this.
     
  11. Jul 5, 2002 #111 of 670
    bidger

    bidger Active Member

    3,426
    0
    Mar 30, 2001
    Elmira, NY
    Please pardon my manners. I now realise after seeing my previous post re
    upgrade success that I neglected to thank all those who helped make it
    possible. I was pretty tired when I posted ( I can see I wrote "know" when
    I meant "now") and wanted to correct that oversite.
     
  12. Jul 6, 2002 #112 of 670
    cmoidel

    cmoidel New Member

    6
    0
    Jul 6, 2002
    Massachusetts
    Last week I upgraded my 14hr Philips Series 1 Tivo (running 3.0) using MFSTools 2.0. I replaced the original A drive with a 120 MB Western Digital drive. I didn't have any problems doing the upgrade and at first my tivo seemed to be working wonderfully. I used the same command line options that NeZorf used. I grew the swap to 128 MB and used the -p option.

    However, this week my Tivo has been flakey. It has been rebooting for no reason at least once a day and almost every time I try to search by name I come up with no results. Something is definitely wrong, but I don't know what. (My season passes seem to be working just fine though. Also, I have never seen the GSOD after my Tivo reboots.)

    Should I give up on MFSTools 2.0 and go back to 1.1? Please help!
     
  13. Jul 6, 2002 #113 of 670
    HTH

    HTH No Avatar Selected

    4,075
    4
    Aug 28, 2000
    Lincoln, NE
    I've found my 14hr image doesn't like being upgraded under 2.5.1 and 3.0. Even when rebuilt with MFS Tools 1.1. I ended up having to use a 30hr base image.
     
  14. Jul 6, 2002 #114 of 670
    embeem

    embeem Member

    235
    0
    Apr 11, 2001
    edge of...
    Based on my experience mfstools 2.0 seems to have a few flaws in the way it rebuilds MFS. It seems that the rebuilt partitions fail fsfix, infact it crashed fsfix when I tried. This means that if anything causes the tivo to go GSOD it'll fail to repair itself and get stuck in a reboot loop misleading people to think that the drive had gone bad.

    I don't have enough resources to really test this and make sure it's an mfstools 2.0 problem so I need people to verify.

    After upgrading with mfstools 2.0 run mfsassert to force a green screen and then wait to see if it recovers or gets stuck in a loop of 'reboot, gsod'. As there's a chance you'll get stuck on a green screen I wouldn't suggest doing this unless you're willing to take the risk and recover the system without using mfstools 2.0

    (I've tried emailing tiger but he has yet to comment on the issues after a week)
     
  15. Jul 7, 2002 #115 of 670
    cmoidel

    cmoidel New Member

    6
    0
    Jul 6, 2002
    Massachusetts
    After reading a post by stormsweeper on TiVo Upgrade Center > upgraded TiVo very sloooow I checked the logs on my Tivo (using the backdoors) and found that there is a problem with my swap partition.

    I see:
    Activating swap space
    Unable to find swap-space signature
    swapon: Invalid argument

    I'm assuming that the lack of swap space is screwing up indexing on my Tivo. :mad:

    Does everyone using MFSTools 2.0 experience this? OR does it only happen to people that tried to grow their swap space from 64 to 128MB??
     
  16. Jul 7, 2002 #116 of 670
    tacohell36

    tacohell36 New Member

    5
    0
    May 19, 2002
    Restore has been going for abot 2-1/ hours.
    How long does it take?

    I am using a virgin image backup from a "single drive unit" and want to restore to a dual drive unit.

    This is my setup:
    I have a backup image store in my dos drive "hda" about 230 megs.

    hda: dos drive setup as Master with backed up image
    hdb: 120 gig drive setup as Slave
    hdc: 120 gig drive new "A" drive setup as Master
    hdd: cdrom setup as Slave

    After I booted up using the MFS tool 2.0 CD, and pressed enter a couple of times, I issued the following commands:

    mkdir /mnt/dos
    mount /dev/hda1 /mnt/dos

    then the commands to restore the backup

    mfsrestore -s 128 -xzpi /mnt/dos/tivo25.bak /dev/hdc /dev/hdb

    now the screen reads:

    Starting restore
    Uncompressed backup size: 816 megabytes
    Restoring 9 of 816 megabytes (1.12%)
    (1060.53% Compression) this numbers keep going up and down every second.

    Does these all look correct and how long should it take?
     
  17. Jul 9, 2002 #117 of 670
    totaltech

    totaltech New Member

    1
    0
    Feb 2, 2002
    Herndon, VA
    I finally upgraded my Sony SAT-T60 and don't see any of the issues you have seen.

    I was originally going to just add a 100GB 5400 RPM Maxtor drive (got it for $99 at CompUSA) to the 40GB that was already in the TIVO but when I saw MFS Tools 2.0 was available and offered a single step one to two drive upgrade I figured I would pick up a Maxtor 80GB 5400 RPM drive at Office Depot for $70 (on sale this week - $119 - $50 rebate).

    I wanted to preserve my recordings so MFS Tools 2.0 was the answer for me.

    I put an ATA-66 IDE controller in the PC so I would have an extra 4 IDE ports so I could not have an issue with the CD-ROM drive and the 3 hard drives.

    I put the original drive on one channel and the other two on the other channel on the ATA-66 card. The original drive was hdg and the two new drives were hde and hdf. Used the command listed in the Hinsdale drive and increased the swap to 512MB.

    mfsbackup/mfsrestore as a single command line command took 62 minutes for 38MB. Shutdown, put the drives back in the TiVo, reconnected everything and powered up.

    Now says up to 168 hours and tried playing back several of the shows in Now Playing that were on the unit. All that I tried worked fine. Also enabled backdoors and looked at the log file - no problems noted with swap.

    I will obviously monitor it over the next couply of weeks (have the 40GB on the shelf if I need it and need to recopy to the two new drives).

    Thank you Tiger and Hinsdale! What an easy upgrade! Only took an hour and twenty minutes. Ten minutes to remove the drives, an hour for the backup and ten minutes to put everything back. And most of the time, I was ignoring the TiVo completely. I checked the clock when I started the backup/restore, waited until it was 10% done, checked the clock again (6 minutes) and then figured I would check it at about an hour. When I went back to the unit, it was 98% done at 1 hour and I waited for it to completed (a couple of minutes). Did an mfsinfo to check the capacity, rebooted with byte swapping, checked with pdisk to make sure there was 512MB of swap and then shut down. Put the drives back in the TiVo, put the cover on and reconnected. Worked like a charm!

    Now I have one TiVo with up to 230 hours and another with up to 168 hours. Fantastic!
     
  18. Jul 9, 2002 #118 of 670
    cameronj

    cameronj New Member

    33
    0
    Apr 2, 2002
    I've got another thread addressing this, but this thread seems to be very popular and I'm praying someone else who has had a similar experience will read this and be able to help... Here's the issue:

    Followed Hinsdale's instructions for my Sony SVR2000. 30 hour unit, adding a second drive (80 gigs). Throughout the install process the drive was reporting 33 gigs in the bios. I ignored it (since I didnt see anywhere in the instructions showing how to fix it) and just went along with the install.

    Sure enough, on install in the Tivo all I had was 63 gigs! Aieee! Can anyone give me help with this? I did have to qunlock, but I presume that had nothing to do with it. I'm going to go back into the bios and check things out, but I dont really expect to find anything. I have a maxtor 80 gig drive.

    (((((THEN....))))))

    Get a load of what I just found:

    "The Maxtor Diamond Max drives 4K080H4, 4K060H3, 4K040H2 (aka D540X-4K) are identical to the drives 4D080H4, 4D060H3, 4D040H2 (aka D540X-4D), except that the jumper settings differ. A Maxtor FAQ specifies the Master/Slave/CableSelect settings for them, but the capacity clip jumper for the "4K" drives seems to be undocumented. Nils Ohlmeier reports that he experimentally finds that it is the J42 jumper ("reserved for factory use") closest to the power connector. (The "4D" drives use the J46 jumper, like all other Maxtor drives.)

    However, it may be that this undocumented jumper acts like the IBM jumper: the machine boots correctly, but the disk has been clipped to 33 GB and setmax -d 0 does not help to get full capacity back. And the IBM solution works: do not use any disk-clipping jumpers, but first put the disk in a machine with non-broken BIOS, soft-clip it with setmax -m 66055248 /dev/hdX, then put it back in the first machine, and after booting run setmax -d 0 /dev/hdX to get full capacity again. "

    The drive I have IS one of the ones in the list above, and it DOES 'clip' the drive at 33 gigs.


    AIEEEE! Help!
     
  19. Jul 9, 2002 #119 of 670
    DBordello

    DBordello New Member

    51
    0
    Apr 1, 2002
    Barrington IL
    I upgraded my DTivo a month ago. I added a 80gb to the stock 40gb. I believe i used MFSTools 1.0 to create a backup (and test it) and then just blessed the new drive (does that sound correct?). I did not add any swap or anything? Should I? Will the new version improve menu performence?

    Great work, keep up the good work. We'd be lost without you.

    db
     
  20. Jul 9, 2002 #120 of 670
    davork

    davork New Member

    2
    0
    Jul 7, 2002
    Jersey City, NJ

Share This Page