MFS Reformatter (mfsr)

Discussion in 'TiVo Upgrade Center' started by ggieseke, May 10, 2015.

  1. shwru980r

    shwru980r Well-Known Member

    2,841
    215
    Jun 22, 2008
    The rollback from hydra to the G3 interface was finally successful after I reformated the 8TB drive. The rollback process is advertised that you will lose all recordings and settings and you will have to rerun guided setup. I assume that means that the hard drive will be unconditionally formatted and the Roamio can't format the 8TB drive properly.
     
  2. tommage1

    tommage1 Well-Known Member

    1,081
    247
    Nov 5, 2008
    Sounds good, just wanted to make sure 8TB drive can be setup with G3.
     
  3. untfan

    untfan Member

    37
    4
    Jul 11, 2005
    In reading through the thread, I didn’t see this specially asked/answered:

    I have a new > 3TB drive, can I “bless” in on a different Roamio then it is destined for and then MFSR it and move it to the desired location, or does the MFSR tool pull specifics from the header which identifies which Roamio first formatted it?

    I have an old refurb Roamio OTA that I bought for the extra remote etc, and the Plus is still transferring shows so I am just trying to get one step ahead.

    Thanks.
     
  4. ggieseke

    ggieseke Well-Known Member

    5,448
    623
    May 30, 2008
    I think it would work, but I haven't tried it. The only thing I actually keep from the original "blessing" is a 16-byte field from the first sector on the drive that I think is a globally unique identifier for the drive.
     
    pmbrauer likes this.
  5. sfhub

    sfhub Well-Known Member

    2,883
    484
    Jan 6, 2007
    You might need to do a clear and delete everything after you move the drive to the new TiVo to get it working right.
     
  6. Jan 4, 2018 #1146 of 1433
    untfan

    untfan Member

    37
    4
    Jul 11, 2005
    Just to close the topic - I was finally able to finish transferring the shows of the 4TB drive in the Roamio Plus and had a 3-hour non-recording window to take down the system. I had previously "blessed" the 8TB drive in a refurb Roamio OTA which updated itself to Hydra on the first boot (as it wasn't active on any account). Then took the drive to MFSR and reformatted it. Plopped it in the Roamio Plus and proceeded. The Roamio Plus recognized the full 1200+ hours and had the proper TSN showing, so no need to do a C&D Everything. Note the Roamio Plus is running the GEN3 interface (I didn't think the "blessing" on Hydra would be a problem, but just wanted to add that data point).

    Donation Sent.
     
  7. Feb 2, 2018 #1147 of 1433
    aleckarty

    aleckarty New Member

    2
    1
    Sep 8, 2005
    Portland,...
    I'm trying to get a 10tb installed in my Roamio. Is it correct that MFSR apparently currently only will reformat to 8tb. Is there any plan to upgrade MFSR to reformat up to 10tb? Is the only other way to go to 10 tb is via Weaknees?
     
  8. Feb 2, 2018 #1148 of 1433
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    10,919
    754
    Apr 6, 2000
    SF Bay Area
    The limit on anything from here is 8TB. 10TB may be in the works when time permits for the original designer.
     
  9. Tivogre

    Tivogre Well-Known Member

    1,519
    128
    Jul 12, 2002
    Springfield, VA
    Pulled the trigger on the $159 Best Buy sale on 8TB WD external drives.
    I shucked out the drive (a White model WD80EMAZ), and ran through the process.

    The only hiccup was that my PC (relatively new) wouldn’t spin up the drive until I used external power w/o the 3.3v on pin 3 (and of course re-pairing the FiOS Cable Card).

    Hellooooooo 1281 hours HD!!!

    [​IMG]
     
    pmbrauer and DocNo like this.
  10. fishkorp

    fishkorp New Member

    12
    0
    Feb 18, 2008
    Do you have a quick way/number for Verizon to repair your CC? Every time I call it’s like these people never heard of it. I spend hours on the phone to get my premium channels to work again.
     
  11. Tivogre

    Tivogre Well-Known Member

    1,519
    128
    Jul 12, 2002
    Springfield, VA
    I always just call 1-800-VERIZON and say "cable card pairing" at the voice prompt. I tell them that my existing Cable Card has lost its pairing and I can not access premium channels. It usually takes about 15-20 minutes to get them to get it right, but it never seems like "they've never heard of it".
     
  12. fishkorp

    fishkorp New Member

    12
    0
    Feb 18, 2008
    Ok thanks. Wonder if that number routes to same support as number shown on the TiVo. Every time but 1 it takes either hours or multiple attempts then hanging up and calling back. The most common response is “I can’t help you if it’s not our equipment.” Maybe I just have really bad luck with Fios customer service reps. Will be putting new HDD in my Bolt Vox this weekend, so was hoping to make the call to them painless.
     
  13. DocNo

    DocNo Member

    671
    21
    Oct 10, 2001
    Bristow, VA
    Awesome utility - I used it on the 3TB seagate - SMR does indeed suck for Tivo's. I'll be using it on an 8TB WD Red tomorrow and kicking that Seagate to the curb (or for a time machine backup drive).

    Donated!

    EDIT: 8TB Red is working perfectly with the Bolt. Awesome! I just passed the SATA cable out the side of the case where the internal hard drive used to be. I had an external power supply from a USB Drive kit that had molex/SATA connector and it powered the WD drive perfectly. Which was good since the internal SATA power connectors in my desktop PC wouldn't power up the drive - must be that pin 3 thing. Oh well, no worries - just used my external supply for the time it took to process the drive in the PC before final installation to the Tivo. I just have the drive sitting on the shelf next to my Tivo. I doubt most people will even notice it; I certainly don't care :)
     
    Last edited: Mar 30, 2018
    ggieseke likes this.
  14. lapdog12

    lapdog12 Member

    53
    2
    Dec 14, 2013
    Just upgraded my roamio pro to an 8tb drive that I shucked from a WD Easystore. I got the drive on sale for $159 from Best Buy and shucked it. I broke the tabs while shucking because I wasn't careful enough. That's ok, since I don't really need the enclosure, maybe I could stick another drive in there at some point.

    Here's what I did:

    1) Completely erased the new drive with WD Diagnostics. That took over 12 hours. I just did this because I read a few people having problems with data on the new drive.

    2) Removed the cover of my Roamio Pro. Just (4) t-10 torx screws on the back of the case and just slide it backwards to get it off.

    3) I removed the old drive with the same t-10 torx screwdriver and took off the rails as well.

    4) I put the rails onto the new drive while I "blessed" it. Turned on the tivo until it got to the "country" selection and then pulled the plug. (This took about 5 min or less)

    5) I had to take off the rails because my computer case has a SATA dock on top of it that I had to slide into place.

    6) Then I ran MSFR in "Run as administrator" mode, right click to get that.

    7) Then MSFR detected the Tivo hard drive and said "click file to format the drive". So I went to the top left of the program and clicked "file" where it had a choice to reformat the drive. Then it worked it's magic. (Took just a couple of minutes.)

    8) Then I put the rails back on and mounted it into the Tivo. (I kept the case off until I finally knew everything was working.)

    9) Then I had to run through the set up. This of course takes 15-20min or so to input your info and download the data.

    10) Once all the data loaded I checked to see that I had my full 1281 hours of HD recording. I then had to call TWC/Spectrum Cable Card help to have them re-pair my cable card. Just in case, here's their direct number: 1-866-532-2598

    11) Once that was all set and completely working, I did another forced network connection to start downloading more guide info. I will do a couple more for sure, but this first one is taking a while.

    Luckily for me, everything has gone smoothly so far. Thanks again for the program and a donation has been sent.
     
    ThAbtO likes this.
  15. Saugus

    Saugus New Member

    4
    1
    Apr 10, 2018
    I just shucked the same HDD for upgrading my TiVo Roamio OTA (All-In). Does this drive work (i.e., spin up) in the Roamio OTA without modification even though it has the Power Disable Feature, or does the TiVo's SATA power connector's pin 3 have to be insulated or blocked somehow?
     
  16. MSL

    MSL New Member

    3
    0
    Apr 28, 2018
    I have a Roamio 1TB OTA that I purchased a new WD Red 8TB drive for. I installed the Red into my Tivo and waited until it got to the country screen then unplugged it and ran MFSR 1.1.04 which appeared to see and format the drive correctly.

    I then put the 8TB drive into my Tivo which started booting and then just stopped doing anything. I couldnt get a signal on my TV and the activity lights stopped flashing.

    I tried re-formatting the drive using MFSR 1.0.04 as well as 1.0.02 and both versions say that there is not a valid Roamio drive attached.

    Do you all have any ideas on what to do next? I am currently running WD Diagnostics to erase the entire drive and then try the process again.

    Thank you for your help
     
  17. Saugus

    Saugus New Member

    4
    1
    Apr 10, 2018
    As I just went through this process using an 8TB, WD80EMAZ White-label drive, shucked from a WD EasyStore external enclosure purchased from Best Buy, I'll relate my experiences:

    First, I attached the drive to my older PC's eSATA connection and attempted to run the WD Tools to remove the drive's factory contents and formatting. This proved problematic because this particular drive has the SATA 3.2+/3.0 Power Disable feature, and for some reason my PC's Motherboard-supplied Molex to SATA cables didn't work quite right: I ran into a failed erase and errors in a sector check. I disconnected the drive from the eSATA interface and used a stand-alone Molex to SATA power adapter on one of the Molex cables from my PC's Power Supply and a standard SATA data cable to connect the drive directly to the Motherboard.

    Knowing this would be a many days-long process (since my PC is still running Windows 7 and its SATA ports are all only SATA 3Gb/s) I first wanted to allay any doubts about a possibly defective drive. I started by using the Windows Disk Management utility to long-format the drive into a single NTFS partition and followed that up by mounting the drive in Windows and running a comprehensive chkdsk with testing and automatic sector repair enabled. All that completed normally and no errors were detected. Reassured that the disk was fine, I used WD Data Lifeguard Diagnostic for Windows to completely erase the drive and disconnected it from the PC.

    I loosely replaced my TiVo Roamio OTA's original 500GB drive with the now blank 8TB drive into its opened chassis, connected it all back up to the TV system, turned the TV system on and then connected the power cable to the TiVo and let it do its thing until the country-selection screen appeared. Then I disconnected the TiVo.

    I had been concerned that the Power Disable feature of the drive would pose a problem with the TiVo Roamio OTA, but it appears that at least this TiVo lacks the legacy +3.3vDC power to pin 3 of its SATA power connector, thus there is no problem using HDDs with, or without, the feature.

    I removed the 8TB drive from the TiVo and reconnected it to the PC's Motherboard; powered on the PC and ran MFSR 1.0.0.4. I Followed the onscreen prompts to complete the process, exited the program, powered down the PC, disconnected the drive and completely installed it into the TiVo chassis and fully re-assembled the Roamio OTA. I Connected it all back up to the TV system, applied the power cable to the TiVo and, when prompted, selected the country and ran through Guided Setup. Everything completed without a hitch and I now have a full 1281 hours of HD recording capacity in my TiVo Roamio OTA.

    One other thing that I should note is that prior to beginning this entire process I did roll back my TiVo Roamio OTA from Hydra to Gen3. I did that primarily because I still prefer the Gen3 user interface. While I cannot say for sure, I don't believe The HDD replacement process would change (or possibly fail) regardless of the firmware version. Upon first powering up, the TiVo's firmware automatically, and without user intervention, prepares the blank HDD for its use and formats it up to 3TB. It is only necessary to use MFSR if you are replacing the original TiVo HDD with one that has a capacity greater than 3TB.

    Here's hoping others will find my experience instructive and helpful. Good luck!
     
    Last edited: May 3, 2018
  18. ggieseke

    ggieseke Well-Known Member

    5,448
    623
    May 30, 2008
    I would hook it back up to a PC and run at least the short write zeros test with the WD diagnostics, then try the whole process again from scratch. Make sure that the SATA and power connections are seated correctly at both ends when you hook it back up to the Roamio.

    P.S. Is the Roamio running Hydra or the gen 3 software?
     
  19. MSL

    MSL New Member

    3
    0
    Apr 28, 2018
    Saugus

    The only part of that process I didnt do was erase the drive before connecting.

    I took the brand new drive, connected it to the Tivo and booted it to the country screen. Then I shut down the Tivo and connected it to my computer where I uses MFSR 1.0.0.4 and completed formatting with that, I shut down the PC and inserted the drive into my Tivo and booted it up.

    I get the initial splash screen and then the Tivo stays powered on but nothing happens. It stops outputting video. I took the drive back to my PC and zero wrote the drive, reconnected it back to the Tivo to get the initial boot screen and then used MFSR again, same result. I now took the original 1TB drive the Tivo shipped with and put it back in the Tivo to try that. Same result.

    Did I brick the unit?

    GGieseke - How do I tell what OS it is running when it doesnt complete the boot process?
     
  20. jmbach

    jmbach der Neuerer

    2,781
    357
    Jan 1, 2009
    Does the unit ever boot to the point that you can get into the Kickstart portal. If it does, try running a kickstart 58.

    BTW when/if you get to the initial start up screen, pressing the INFO key gives you the OS version and from there we can figure out the generation of the UI on the machine.
     

Share This Page