Metagenerator 3 -- Support & Downloads

Discussion in 'TiVo Home Media Features & TiVoToGo' started by dlfl, Jun 7, 2018.

  1. Mar 2, 2021 #681 of 720
    Zaphod

    Zaphod Member

    147
    7
    Feb 17, 2003
    Des Moines,...

    Advertisements

    Same here. I did have the cert issue back in December, but the new MG distribution that includes the new cert fixed that.

    That said, I haven't changed my TiVo password in years.
     
  2. Mar 2, 2021 #682 of 720
    elprice7345

    elprice7345 Active Member TCF Club

    416
    30
    Sep 28, 2009
    Denver, CO
    Just thinking out loud ... do you have another machine where you can install MG3?

    If the new install works, there must be something misconfigured on the old machine.

    If the new install doesn't work, then there must be an issue with your TiVo credentials.

    RPC calls are still working for me. I also haven't changed my PW in a long time.
     
  3. Mar 3, 2021 #683 of 720
    dlfl

    dlfl Cranky old novice

    9,143
    828
    Jul 6, 2006
    Dayton OH
    Well, who volunteers to change their TiVo credentials just to test if that causes this problem? (Not me, :rolleyes:)
     
    elprice7345 and PSU_Sudzi like this.
  4. Mar 3, 2021 #684 of 720
    Sparky1234

    Sparky1234 Well-Known Member

    2,331
    349
    May 8, 2006
    LOL.
     
    PSU_Sudzi likes this.
  5. Mar 3, 2021 #685 of 720
    PSU_Sudzi

    PSU_Sudzi Well-Known Member

    2,590
    955
    Jun 4, 2015
    Philly suburbs

    Advertisements

    Sadly no just have a work laptop and that’s locked down pretty tight. I think it could be a machine issue, it worked previously on my 2017 iMac loaded with Windows 10 in Bootcamp and now I have a 2020 iMac with Windows 10 in Bootcamp. But I am not sure exactly what configuration is causing the problem. For anyone not familiar with Bootcamp, the machine is running Windows 10 for real, not an emulator, etc. It’s a dual boot system.
     
  6. Mar 5, 2021 #686 of 720
    elprice7345

    elprice7345 Active Member TCF Club

    416
    30
    Sep 28, 2009
    Denver, CO
    Hmm ... a work laptop ...

    Could you borrow a friend's laptop to test? MG3 doesn't really install in the traditional Windows sense. You just copy the contents of the zip file into a folder, so it's easy to undo and shouldn't take long.
     
  7. Mar 7, 2021 #687 of 720
    PSU_Sudzi

    PSU_Sudzi Well-Known Member

    2,590
    955
    Jun 4, 2015
    Philly suburbs
    I was able to unzip everything onto my work laptop and get it running but am unable to save my TiVo user name and password in the settings, I am guessing its some kind of error trying to save data to the user folder on this setup. So no luck here either.
     
  8. Mar 9, 2021 #688 of 720
    dlfl

    dlfl Cranky old novice

    9,143
    828
    Jul 6, 2006
    Dayton OH
    What was the indication the credentials weren’t saving? Error message or what?
     
  9. Mar 9, 2021 #689 of 720
    PSU_Sudzi

    PSU_Sudzi Well-Known Member

    2,590
    955
    Jun 4, 2015
    Philly suburbs
    I would set the user name and password and then check the middle mind box and then close the form and do a search with program id. Would see red text something like “no rpc set” but that’s not quite the precise text, I know I’m off by a word. When I would go back to check the settings the user name and password and middle mind box are all set back to default values. Repeated this cycle multiple times.

    Update: the error in red is “RPC ERROR: Not Doing RPC”. This is after saving the name and password and checking the middle mind box then searching a program with get program id box checked. Going back to settings (mind RPC) box reveals no name or password saved.
     
    Last edited: Mar 10, 2021
  10. dlfl

    dlfl Cranky old novice

    9,143
    828
    Jul 6, 2006
    Dayton OH
    I suspect a permissions issue. I don't know if you were running as administrator or whether that should make a difference. I did the following as a test running on a non-administrator account on my PC:

    1. Downloaded Metagenerator383.zip and RPCSearch128.zip.
    2. In properties for each downloaded zip, checked Unblock and Apply.
    3. Extracted contents of both zips to a new folder (just created while running in this non-admin account)
    4. Created shortcut to MG3 executable on desktop
    5. Launched MG3 using shortcut
    6. Entered TiVo credentials and TSN in Mind RPC settings.
    MG3 ran normally, including RPC searches.

    Notes:
    The new folder used was NOT located either under Program Files or Program Files (x86)

    I extract zip contents by double clicking the zip to open it, hitting Ctrl-A to select all contents, right-clicking and selecting Copy, then focusing in target folder, right-clicking and selecting Paste. I would think any method of extracting should work but that's what I use.

    I didn't have to use run-as-administrator, or enter admin credentials, at any point.
     
    PSU_Sudzi likes this.
  11. PSU_Sudzi

    PSU_Sudzi Well-Known Member

    2,590
    955
    Jun 4, 2015
    Philly suburbs
    It must be permissions to the user folder, I just re-tested following all the steps as you did and still does not save the user name/pw and gives the same error. My only deviation from your steps initially is that I unpack zip files rather than open them and copy/paste. And this is a non-administrator account.
     
  12. dlfl

    dlfl Cranky old novice

    9,143
    828
    Jul 6, 2006
    Dayton OH
    If you use MG3, please let me know how important it is for it to continue accessing TV series data from theTVDB.com, as opposed to the Movie Database (TMDb) source, which was recently added.

    theTVDB.com will soon force the use of a new API (V4) which, in addition to requiring significant MG3 code modifications, will most likely require each user of MG3 to pay them $12/year for a subscription, to get a PIN which would have to be entered into MG3. The PIN would also give access to any other way you use theTVDB.com. They say they will have provisions to give free PIN's if you perform certain functions that support their database, but the details of this seem unsettled at the moment.

    I have asked theTVDB.com how much a blanket license would cost but am still waiting for a reply. This would eliminate requiring each MG3 user to subscribe. If they offer a reasonable cost, then all that remains is the code mods.
     
  13. elprice7345

    elprice7345 Active Member TCF Club

    416
    30
    Sep 28, 2009
    Denver, CO
    This is more of the same of what happened to me with my media app, JRMC, and why I asked you to add TMDB last summer.:thumbsup: TVDB evidently wanted a lot of $$ from JRMC and JRMC just switched to TMDB in a matter of a few weeks.

    I get that bandwidth, development, servers, etc. cost money, so I can't blame TVDB for trying to monetize their data. I also get that a lot of the internet believes everything should be free. I also think it's a sketchy business model to ask your users to maintain and build your product and then charge them for access. :mad:

    TVDB is trying to address my last concern with this approach:
    I try to use TMDB for all my shows. It is fairly up-to-date for any popular show, but less up-to-date and not as accurate for the less popular shows like documentaries, etc. I do think it is competitive with TVDB for most user's purposes.

    Even trying to use TMDB as my primary source, I find I still need to reference TVDB occasionally. I still use TVDB as my reference for many of these less popular shows, because I haven't put the time and effort into updating TMDB. If and when I ever finish updating my shows, I'll probably only use TVDB as a reference and not as a source to rename my shows.

    I would still like for MG3 to be able to access TVDB going forward, but I think we need to understand the costs. I would be happy to pay for a user license around $12/year, but that may be more than some MG3 users are willing to pay (then again, if users have to pay the fee, it shouldn't matter too much to you). I would even be happy to contribute to the MG3 master license if the cost is reasonable.

    Regarding v4, if you want to maintain TVDB access, you'll probably have to update to v4 at some point in the not too distant future. I haven't been paying attention to their updates, but I'll be happy to test if you decide to make the changes.

    Let me know what you hear about the licensing costs.
     
  14. elprice7345

    elprice7345 Active Member TCF Club

    416
    30
    Sep 28, 2009
    Denver, CO
    Bug
    Code:
    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
       at MetaDataSearch.TmdbSeriesSearch.BuildSeries(String id, String& status, String oaYear, Boolean yearSeasons)
       at TVSearchForm.TVSearchForm.bwShowSelected_DoWork(Object sender, DoWorkEventArgs e)
       at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
       at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
    What happened:
    • I searched for "Killing Eve" in TMDB
    • I double-click the series
    • The error above appears
     
  15. dlfl

    dlfl Cranky old novice

    9,143
    828
    Jul 6, 2006
    Dayton OH
    Caused by ill-formed episode record. For a crew member "second unit director", the "name" element (and other elements) is missing. Easy to catch and program around. Will fix.
     
  16. dlfl

    dlfl Cranky old novice

    9,143
    828
    Jul 6, 2006
    Dayton OH
    Try test version 3.94T1 in attached zip.

    Ver. 3.94T1 (18 March 2021)
    Fixed: Ill-formed crew field (missing name) in TMDb episode record crashed MG3
     

    Attached Files:

    Sparky1234 likes this.
  17. elprice7345

    elprice7345 Active Member TCF Club

    416
    30
    Sep 28, 2009
    Denver, CO
    Testing Ver. 3.94T1
    Killing Eve is fixed.

    I also did some regression testing and everything seems to be in order.

    If you want to give me a few days to use Ver. 3.94T1, I'll do more testing and then you can publish.
     
  18. elprice7345

    elprice7345 Active Member TCF Club

    416
    30
    Sep 28, 2009
    Denver, CO
    Testing Ver. 3.94T1
    I haven't found any more issues. Feel free to publish whenever you're ready.

    Thanks @dlfl!
     
  19. dlfl

    dlfl Cranky old novice

    9,143
    828
    Jul 6, 2006
    Dayton OH
    Ver. 3.94 released, see first post for changes and download.

    Thanks @elprice7345 for debugging and testing!
     
    Sparky1234 and elprice7345 like this.
  20. buffalova

    buffalova Member

    33
    0
    Jul 7, 2006
    i have a really odd issue i am not sure how to fix... i have been using metagen 3 for sometime but probably not the way it was intended.. i use it mainly to group shows in a single folder that may or may not be the same show.. anyway i was doing a rpcsearch for a seried id for the show "mom" ..i kept getting an error that it couldnt search or something like that so i gave up.. but now when i use mg3 no matter what show i want to create metadata for i enter the series id (not "mom" show) and click save on the video.. every time no matter what it changes the name of the show and meta text file to "mom".. so annoying.. obviously that is stored somewhere but have no idea how to clear it...greatly appreciate any ideas of what to check.. and or possible fix...
     

Share This Page

spam firewall

Advertisements