MCE 64-bit won't play .tivo files

Discussion in 'TiVo Home Media Features & TiVoToGo' started by tburrel, Dec 29, 2008.

  1. tburrel

    tburrel New Member

    10
    0
    Jun 9, 2007

    Advertisements

    Odd behavior here: 64-bit Vista Premium system w/Tivo Desktop Plus installed. I can play .tivo files from inside TDT+, or from WMP with no problems. BUT when I try to play them from Media Center, I get a screen with just the desktop flanked by the black bars on either side, and no action. When I hit "play" I get a message "cannot play this file"

    These files work fine on my 32-bit system so I know they aren't corrupt. They also work fine in WMP or Tivo Desktop on the 64-bit machine, so I figure I must have the right codec in there. Anyone have any ideas?
     
  2. sixseven

    sixseven New Member

    98
    0
    Jan 6, 2005
    just checked... I have the same problem...
     
  3. jdwolff

    jdwolff New Member

    2
    0
    Jan 21, 2009
    I have the exact same problem. Files play great in Windows Media Player, but not in Media Center. My machine is dual boot 32-bit and 64-bit Vista Ultimate. I only have the problem in 64-bit. I've tried every combination of codecs but never get more than a blank screen. Any ideas?
     
  4. dvhouseh

    dvhouseh New Member

    1
    0
    Jul 20, 2007
    I have the same problem...
     
  5. Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007

    Advertisements

    No expert, but it sounds like you only have 32-bit codecs :)
    64-bit programs can't dynamically load 32-bit dlls. So probably any program compiled as a 32-bit application is working fine, but any program that is a 64-bit application is failing...

    Either find a 64-bit codec to play the file (I don't know of any.. unless tivo has released a 64-bit tivotogo, I doubt there is one), use a tool to convert the files to something like an mp4 file that anything can play, or see if there's a 32-bit version of MCE you can install instead..
     
  6. jdwolff

    jdwolff New Member

    2
    0
    Jan 21, 2009
    I found a set of 64bit drivers in a K-Lite codec pack at start64.com, but that didn't work.
     
  7. rb47

    rb47 New Member

    9
    0
    Aug 7, 2007
    Pittsburgh, PA
    I've got the same problem but I am running 32-bit Vista Ultimate. I can play .tivo files fine in WMP, but when I try it in Vista Windows Media Center I get the "Cannot Play Video" error.

    I actually started a new post about this yesterday in this same forum. (I would post a link but I can't until I have 5 or more posts...)

    From what I understand VMC has it's own setting for what MPEG-2 codec to use. You can change it using a utility called Vista Media Center Decoder Utility. I didn't work for me but maybe it will for somebody else. I am not sure if the utility works for x64 VMC though...

    Rich
     

Share This Page

spam firewall

Advertisements