Lock on Welcome!

Discussion in 'TiVo Series3 HDTV DVRs' started by jscozz, Sep 26, 2007.

  1. jscozz

    jscozz Member

    156
    0
    Sep 28, 2002
    I had trouble with my original series 3 a few weeks ago where it was rebooting every few minutes and pixelating on HD terribly leading up to reboots. Tivo sent me a new unit (after charging my creidt card $799; they could not tell me why they were holding $799 of my money when I could buy a new one from them for $599). So, teh new one arrived and worked great... until yesterday when (after reading it on here) I forced a reset to see if I get the ver 9 update (it had been calling in via network every day with no problem up til then), the first time it failed aftet preparing with an N17? error... I tried again... it seemed to work... on the last item it rebooted without warning. Now, when it comes up it goes to Welcome and after about a mniute teh front panel lights all go out and it stays on Welcome forever! I have pulled teh cable cards... network... and still the same.

    TIVO wants to send em anotehr one... but since my first one is "less dead" than the second one I want to keep it until I get the third and then send them both back... Tivo said they will have to charge me anothe $799 (not $599) and I might not get the credit back for teh first unit since it may be past their deadline... the real problem is the lack of ability for even a Tivo supervisor to think for themselves and solve this problem for me... all I wanted was assurance taht if I wait another week to send unit #1 back taht I will get all of my $1600 back!!!!! They said it was another dept and that the computer would not let them do taht. What BS!!!

    So, if anyone has advice:
    1) On teh problem itself... any ideas or is sending it back the only option.
    2) Is there really a deadline for refund of an exchange unit?

    Jeff
     
  2. jscozz

    jscozz Member

    156
    0
    Sep 28, 2002
    Nobody ever experienced a lock up on Welcome?
     

Share This Page