Live recording defaults to second tuner

Discussion in 'TiVo Premiere DVRs' started by ~kyle, Jan 6, 2012.

  1. Jan 6, 2012 #1 of 10
    ~kyle

    ~kyle Member

    45
    1
    May 14, 2009
    I'm having an issue with the latest update (14.9.2.2) where if I'm watching live TV and decide I want to record the program I'm watching, it will start recording from that spot on the second tuner instead of the tuner it's already on. So the buffer doesn't record and I don't get the whole show. I can even have the second tuner paused and it will still use it.

    To clarify (I hope), after I push record, both tuners will be on the same channel I'm wanting to record but it will only use the second tuner to start recording and only record from the spot where I told it to record.This never happened before this update and does it 100% of the time now.

    I have suggestions turned off on this particular unit and it will do this even if there's nothing at all scheduled to record for that day. Is this a new bug or is there a setting I've overlooked that was reset after this update? Does anyone know how I can change this behavior? I've searched but haven't seen this behaviour mentioned by anyone else.
     
  2. Jan 6, 2012 #2 of 10
    aaronwt

    aaronwt UHD Addict

    23,187
    1,127
    Jan 31, 2002
    Northern...
    That is weird. I have not run across it with any of my boxes.
     
  3. Jan 6, 2012 #3 of 10
    L David Matheny

    L David Matheny Active Member

    1,632
    6
    Jan 29, 2011
    SE Ohio
    I tried this on my Premiere (14.9.2.2, SDUI, OTA only, no suggestions).

    First I pressed Record and selected "Record this showing" during live TV while the other tuner was already recording. The new show recorded on the available tuner, capturing from about a minute before the start of the show (which had been on about 8 minutes). This seems to be ideal behavior, and an improvement over instances where TiVo unnecessarily captured clear back to the beginning of the 30-minute buffer.

    Later I tried again while nothing was recording. Again I pressed Record and selected "Record this showing" during live TV. This time it recorded from the beginning of the buffer (starting about 6 minutes earlier) to the end of the show. Why the difference? Does the TiVo program code have several different sections that handle the Record button depending on the exact circumstances? And note that my Premiere did not switch tuners to record.
     
  4. Jan 6, 2012 #4 of 10
    cherry ghost

    cherry ghost Well-Known Member

    6,332
    340
    Sep 13, 2005
    Chicago
    Just tried it with both tuners available and the current show already 15 minutes into a two hour show. That means the 30 minute buffer included 15 minutes of the previous show.


    did not switch tuners

    grabbed 10 minutes of the previous show, leaving current progress at the 25 minute mark

    only shows 2:00 for the total of current recording, not 2:10. Looks like the last 10 minutes won't get recorded.



    ETA - went to Now Playing, highlighted the show, and hit play. Started playing at the 10 minute mark, which is the correct location for the start of the show. Still only shows 2:00 for the total, leading me again to believe the last 10 minutes won't be recorded.


    all of this is with the HDUI




    Update - when the recording hit the 2:00 mark, another minute was added on to the total, making it 2:01. This continued every minute until the entire 2:10 was recorded. Strange that it wouldn't show the total as 2:10 right away.
     
  5. Jan 6, 2012 #5 of 10
    TerpBE

    TerpBE Go Terps!

    697
    1
    Jan 23, 2003
    Philly 'burbs
    I ran into what might be a similar issue. I get ABC on two channels 506 (HD) and 6 (SD).

    Assume I'm watching the live TV buffer on 506. Let's say it's 7:10PM, and I'm watching the buffer from 6:50. If I realize I want to record something I see in the buffer, I can't just hit record because the next show has already started. No problem - just do a manual recording, right?

    So I set up a manual recording to record from 6:30PM to 7:30PM on channel 506 (and get the "this has already started" message). This should create a recording from the beginning of the buffer until 7:30, right? Well, that's what I thought. But, I was in this situation on two different occasions recently, and instead of recording the buffer and the channel until 7:30, Tivo changed the channel to the SD version (6) and began the recording right then.

    I have no idea how or why it would do this. I'm 100% sure that I set the manual recording channel to 506, but for some reason it decided to change the channel to 6! It's truly bizarre.

    If the latest update doesn't fix this problem, I'll try to get a video of it happening. Has anybody else seen this occur?
     
  6. Jan 6, 2012 #6 of 10
    ~kyle

    ~kyle Member

    45
    1
    May 14, 2009
    I have all of my SD channels disabled but either way, this was happening with the same channel. If I'm watching 432 (NBC-HD) and I'm 5 minutes or so into the show and the other tuner is on another channel, say 433 (CBS-HD), when I select to record the channel I'm watching the other tuner that's on 433 will switch to 432 and start recording from that spot. If I hit record after that point on either tuner it will ask if I wish to cancel the recording. At this point both tuners will be on channel 432 but only records the clipped show.

    Very frustrating and it's never done this before. I haven't tried this lately on my TivoHD but this has only happened since I got 14.9.2.2 on my Premeire so I doubt the HD is affected.

    Aaaargh! :mad:
     
  7. Jan 6, 2012 #7 of 10
    ~kyle

    ~kyle Member

    45
    1
    May 14, 2009
    I think I just found a workaround. I was apparently wrong in my original post. If you first go to the second tuner and hit pause and then go back to the tuner with the program you want to record and select record, it will start recording on the that tuner and will catch the buffer. I thought I had tried this before but apparently not.

    A fairly easy workaround but definitely a bug, that is if others can confirm that they have this same issue.

    Anyone?
     
  8. Jan 6, 2012 #8 of 10
    mattack

    mattack Well-Known Member

    24,929
    578
    Apr 9, 2001
    sunnyvale
    Call Tivo.

    At least the S3 and higher have always done the "record the whole buffer, even if it is from before the show has started" routine..
     
  9. Jan 6, 2012 #9 of 10
    cherry ghost

    cherry ghost Well-Known Member

    6,332
    340
    Sep 13, 2005
    Chicago
    Have you tried it lately? That wasn't my experience today on a Premiere.
     
  10. ~kyle

    ~kyle Member

    45
    1
    May 14, 2009
    Just as an update, I emailed Margret Monday and asked for the 20.2 update. I got it yesterday morning and I no longer have this issue.
     

Share This Page