Linksys router will not cooperate with Tivo

Discussion in 'TiVo Help Center' started by Sisaacson, Jun 14, 2011.

  1. Sisaacson

    Sisaacson New Member

    5
    0
    Jun 14, 2011
    When I try to connect with tivo service, it says connection interruption. After talking to Tivo, they said it is the router and gave me a list of ports to open? I'm totally confused. How in the world do I open the router to allow for those ports? Thanks!!
     
  2. Joey P

    Joey P New Member

    469
    0
    Oct 20, 2002
    Milwaukee, WI
    Go to the Port Forwarding page and put those ports in along with TiVo's IP address. You might have to turn off DHCP to do this, but I don't think so. If you are able to leave DHCP on, you'll have to update the table anytime the TiVo get's a new IP address (which would typically happen if the TiVo or the Router loses power or resets, but even then it might get the same one back)
     
  3. orangeboy

    orangeboy yes, I AM orangeboy!

    4,089
    0
    Apr 19, 2004
    East Moline, IL
    I have zero ports open on my router. The only time port-forwarding is needed is when you have a server sitting on your LAN, and you want external requests from the WAN (Internet) to be answered by that server. I can't claim that I know all the ins-and-outs of TiVo DVRs, but from my understanding, it is the DVR that acts as the CLIENT to reach out to the TiVo corp. servers. If it worked the other way around, there would be a lot more folks with problems. Now if a router blocked both incoming and outgoing traffic, then yes, ports would need to be opened. But if a router did that, it wouldn't be much of a router (the routing typically takes place between your LAN and WAN, routing traffic from 192.168.x.x (for example) to your ISP's gateway and beyond)...
     
  4. Joey P

    Joey P New Member

    469
    0
    Oct 20, 2002
    Milwaukee, WI
    Orangeboy makes a good point. In layman's terms, what he's saying is that no one else has this problem and it sounds like TiVo is trying to pass the blame (provided you don't have a different home network setup then the rest of the world).
    Have you done some basic troubleshooting?
    Was the TiVo previously connecting and suddenly stopped or has it never worked properly?
    Does the TiVo have an IP address (should be 192.168.1.xxx)?
    Power cycle the Tivo.
    Power cycle Router.

    Start with that and let us know what you come up with. Also, how is the TiVo connected (wired/wireless)? Are you having problems with anything else connecting?
     
  5. Sisaacson

    Sisaacson New Member

    5
    0
    Jun 14, 2011
    Yes, have troubleshooted. Cycled everything. It connects to the internet but does not get info. It has worked fine up until today. I'm using a wired connection. The cable is fine. There is an IP address on the Tivo but it is not anywhere near the number you listed.
     
  6. curiousgeorge

    curiousgeorge Member

    676
    1
    Nov 28, 2002
    If you remove the router from the equation and plug the TiVo directly into the Cable modem or DSL modem, then power cycle both (modem first, then Tivo), can the TiVo connect?

    Which Linksys router and version are you using? (should be on a sticker on the bottom or back)
     
  7. Sisaacson

    Sisaacson New Member

    5
    0
    Jun 14, 2011
    I bypassed the router, and plugged in directly to the modem. still did not work or connect to the internet even. The router is a WRT54G....
     
  8. Sisaacson

    Sisaacson New Member

    5
    0
    Jun 14, 2011
    oh...and the router is version 8.2
     
  9. E94Allen

    E94Allen New Member

    267
    0
    Oct 16, 2005
    Maybe your modem went bad and you might want to call your ISP to check or/and replace your modem.
     
  10. orangeboy

    orangeboy yes, I AM orangeboy!

    4,089
    0
    Apr 19, 2004
    East Moline, IL
    Is the TiVo set to use DHCP? During Network Setup, there are options for setting the IP address:

    Get automatically from a DHCP server (typical)
    Let me specify a static IP address
    Let the DVR assign itself an IP address

    If the IP address is assigned by a DHCP server, and such a server is not available, I believe it will give itself a 169.x.x.x address, or complain with an Nxx error.

    What is shown when you go to "View network status" or "View network diagnostics" on the TiVo?

    You mentioned "There is an IP address on the Tivo but it is not anywhere near the number you listed." What is that number?
     
  11. Sisaacson

    Sisaacson New Member

    5
    0
    Jun 14, 2011
    I don't know HOW...after troubleshooting this for 5 hours yesterday. I went to try again this morning just to make sure and it worked first time!! What the heck? I didn't do anything different, just tested it, and it worked. Thanks for everyone's help!!! Much appreciated!
     
  12. lessd

    lessd Well-Known Member

    7,958
    91
    Jan 23, 2005
    CT
    The IP address for the TiVo may not have a 1 in the third number set, could be a 0,1,2, or another number. I use 0 as in 192.168.0.xxx
     
  13. orangeboy

    orangeboy yes, I AM orangeboy!

    4,089
    0
    Apr 19, 2004
    East Moline, IL
    Or they could be any of these:
    10.x.x.x,
    192.168.x.x, or
    172.16.0.0 - 172.31.255.255

    192.168.x.x is typical though.
     
  14. Joey P

    Joey P New Member

    469
    0
    Oct 20, 2002
    Milwaukee, WI
    I'd be willing to bet that anyone who asks how to set up port forwarding has all the defaults in tact. Having said that, out of the box, Linksys hands out IP addresses in the range of 192.168.1.xxx.
     
  15. Stuxnet

    Stuxnet Alien Infidel

    356
    0
    Feb 8, 2011
    That's not correct. The first three numbers in the IP address should match the router's first three. As Joey P noted, linksys router default is 192.168.1.1 ... so the TiVo would be 192.168.1.xxx... where "xxx" is a value not to exceed 255 and distinct from all other network users on that router.
     
  16. lessd

    lessd Well-Known Member

    7,958
    91
    Jan 23, 2005
    CT
    That number (1) can be user changed, but I agree that 99% of users will not change the 1 to a different number like i did.
     
  17. Stuxnet

    Stuxnet Alien Infidel

    356
    0
    Feb 8, 2011
    I'm with you... changing the third position is a simple step to help obsfucate your wireless network from casual freeloaders, a good practice to use in partnership with WPA2, rotating passwords, MAC-filtering, SSID non-broadcast, and time of day restrictions (and don't forget to change your router default password).
     
  18. P42

    P42 Active Member

    1,269
    3
    Jan 7, 2003
    01460
    MAC-filtering and SSID non-broadcast are not going to prevent someone leeching your wifi or hacking your network if they want, but they will make your life more bothersome.

    Glad things started "just working" for the OP.
     
  19. Stuxnet

    Stuxnet Alien Infidel

    356
    0
    Feb 8, 2011
    Certainly there is nothing that will stop a determined hacker, no more than a deadbolt won't prevent someone from breaking into your house, but simple measures will keep casual snoopers at bay. Bothersome? Good luck with that.
     
  20. P42

    P42 Active Member

    1,269
    3
    Jan 7, 2003
    01460
    MAC-filtering (easy to sniff and spoof) and SSID non-broadcast (so easy to find even MS suggest not bothering) provide the appearance of security, without actually providing any real security, yet increasing administrative overhead.

    It is all about balance, and I call it a day at WPA2 and a decent password, granted I might feel differently if I felt at greater risk of been leeched from...
     

Share This Page