Lettering Rubbing Off S3 Remote

Discussion in 'TiVo Series3 HDTV DVRs' started by Gleklen, Aug 25, 2007.

  1. Gleklen

    Gleklen New Member

    16
    0
    Nov 6, 2005
    Anyone else have a problem with all of the lettering rubbing off their S3 remote? (Actually, it looks like the black on the keys is rubbing off, leaving the white underneath.)

    Has anyone tried to get Tivo to replace it? It works fine, but it looks crummy for a $700 piece of electronic equipment.
     
  2. sfhub

    sfhub Well-Known Member

    2,883
    484
    Jan 6, 2007
    Better not try the control pad on the unit itself. It'll annoy you even more.
     
  3. gargoyle999

    gargoyle999 New Member

    39
    0
    Oct 28, 2006
    Lakeville, MN
    I'm seeing this as well. My 'input' button is almost gone. I only use this one to turn my receiver off and on. Strangely, the '30 second skip' button, used all the time, is currently ok. It's been a long time since I've worn the button off a remote so it seems a little redesign is in order.
     
  4. ah30k

    ah30k Well-Known Member

    2,493
    156
    Jan 8, 2006
    Most, if not all, of my buttons are worn off. Sucks for a deluxe remote.
     
  5. noah82

    noah82 Cox San Diego

    24
    0
    Aug 1, 2007
    San Diego, CA
    Get a Logitech Harmony!!!
     
  6. windracer

    windracer joined the 10k club

    12,258
    214
    Jan 3, 2003
    St. Pete, FL
    Technically the remote is only $50. :rolleyes:
     
  7. vman41

    vman41 Omega Consumer

    10,879
    564
    Jun 18, 2002
    My lettering is fine, but I'm getting some wear on the tips of the crescent-shaped >> and << buttons. The silver (or is it more of an antimony) paint around the bezel is wearing pretty bad though.
     
  8. ThreeSoFar'sBro

    ThreeSoFar'sBro Sports Nut

    1,524
    14
    Oct 10, 2004
    Macomb Twp., MI
    Black on buttons is wearing, especially the Clear, Enter, and << >> buttons. Grey paint on body of remote is also wearing. Kinda disapointing....
     
  9. ah30k

    ah30k Well-Known Member

    2,493
    156
    Jan 8, 2006
    Ditto here as well.
     
  10. jfh3

    jfh3 Active Member

    4,471
    2
    Apr 15, 2004
    Denver area
    Wow. I've been using my S3 remote since September, seemingly non-stop, and it still looks new.
     
  11. Dr_Diablo

    Dr_Diablo Dr_Diablo

    916
    0
    Nov 23, 2003
    Midwest
    How long was it that you began to notice the lettering rubbing off?

    I had a bad habit of holding the remote, until I would lay it down
     
  12. dtobey

    dtobey New Member

    5
    0
    Oct 5, 2006
    Is there a thread here about the new series 3 remotes failing? The lettering is the least of my problems. The remote just doesn't want to do it's job all the time, even with fresh batteries. I sometimes have to wait a second between button presses or else it just ignores me altogether. I know there was a thread about plasma's interfering, but I have an LCD. Also, I've been using my old Series 2 remote lately, and it still works like a charm.

    I think I have a bad remote. Has anyone else had this problem?
     

Share This Page