KMTTG not working on Tivo Bolt TE

Discussion in 'TiVo Help Center' started by OrangeTurtle, Mar 16, 2020.

  1. OrangeTurtle

    OrangeTurtle Member

    83
    31
    Jul 17, 2015
    I occasionally use KMTTG to transfer stuff from my Tivo to my Macbook pro- which means my expertise level is pretty low. I get it to work, but don't know it in depth. I have a Tivo bolt running TE3.

    I tried to launch it today and it said I need to download Java Developer Kit. So I found that (I believe possibly at Oracle). Did the download jdk-13.0.2_osx-x64_bin.dmg. Then tried to launch again, but this is what I am now getting a pop up box saying this...

    The Java JAR file "kmttg.jar" could not be launched.
    Check the Console for possible error messages.


    Any insight or suggestions?
     
  2. OrangeTurtle

    OrangeTurtle Member

    83
    31
    Jul 17, 2015
    Here is more info that might be helpful, but again I am not sure what this means. ANy help would be greatly appreciated!! Trying to transfer a video to upload for my students.

    Exception: java.lang.NoClassDefFoundError thrown from the UncaughtExceptionHandler in thread "main"
    Shutdown hook executing

    Exception: java.lang.NoClassDefFoundError thrown from the UncaughtExceptionHandler in thread "Thread-0"

    [Process completed]
     
  3. lhvetinari

    lhvetinari Si non confectus, non reficiat TCF Club

    254
    67
    Jun 24, 2019
    Chicago
    KMTTG only works with legacy java (8-10) not 11+


    Sent from my iPhone using Tapatalk
     
  4. KevTech

    KevTech Active Member

    381
    198
    Apr 15, 2014
  5. OrangeTurtle

    OrangeTurtle Member

    83
    31
    Jul 17, 2015
    HUGE help! Would have been lost without this. Thank you! This got KMTTG to launch finally... Still having some issues though.

    Can't get any of the shows to list- just says "no content in table." I tried to do a refresh and got this...


    >> Getting Now Playing List via RPC from Family Room ...

    RemoteInit - (IP=172.16.0.13, port=1413): Operation timed out (Connection timed out)

    [java.net.PlainSocketImpl.socketConnect(Native Method), java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350), java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206), java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188), java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392), java.net.Socket.connect(Socket.java:606), sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:666), sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:426), sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:88), com.tivo.kmttg.rpc.Remote.RemoteInit(Remote.java:206), com.tivo.kmttg.rpc.Remote.<init>(Remote.java:172), com.tivo.kmttg.main.config.initRemote(config.java:635), com.tivo.kmttg.task.NowPlaying$1AutoThread.run(NowPlaying.java:90), java.lang.Thread.run(Thread.java:748)]
     
  6. reneg

    reneg Well-Known Member

    1,119
    220
    Jun 19, 2002
    Not sure if this is your issue or not. RPC relies on your tivo credentials being configured in kmttg. Under File->Configure in the Tivos tab, make sure Enable RPC-style comm is checked for your tivo and the tivo.com username and tivo.com password are configured correctly.
     
  7. OrangeTurtle

    OrangeTurtle Member

    83
    31
    Jul 17, 2015
    Thanks for the suggestion about RPC- I checked it out and everything seemed to be as you suggested. I didn't have a username or password entered- it was blank. I added my info- but it didn't seem to make a difference.
     
  8. MPSAN

    MPSAN Well-Known Member

    1,477
    27
    Jun 20, 2009
    Portland,...
    Last edited: Mar 20, 2020
  9. KevTech

    KevTech Active Member

    381
    198
    Apr 15, 2014
  10. OrangeTurtle

    OrangeTurtle Member

    83
    31
    Jul 17, 2015
    I am using it for my macbook pro... running Catalina. As previously mentioned it launches now, but can't get it to actually show my shows in the list. It does recognize my tivo bolt in my house though. Any other thoughts on what I am doing wrong?
     
  11. MPSAN

    MPSAN Well-Known Member

    1,477
    27
    Jun 20, 2009
    Portland,...
    No idea I just came here to see why mine did not start and did not mean to thread crap. I will look at Java.
     
  12. OrangeTurtle

    OrangeTurtle Member

    83
    31
    Jul 17, 2015
    SOLVED!

    OK- so after looking into many possible issues and just trying to adjust settings I noticed that while my Tivo showed up and was named correctly, the IP address was for some reason showing up slightly different. It ended in .13, but on my tivo it said .16. So I had to uncheck the "search for tivos", delete what was there, then manually type in the ip address.

    Now everything is loading and I can transfer recordings to my macbook pro. Thank you again for the help earlier in this thread to help me get to this point to trouble shoot more on my own and get it back up and running!!!
     
  13. MPSAN

    MPSAN Well-Known Member

    1,477
    27
    Jun 20, 2009
    Portland,...
    Well, so far my KMTTG will not run. I loaded JAVA again and now need to look at what they said about making sure that the JRE can find it.
     
  14. MPSAN

    MPSAN Well-Known Member

    1,477
    27
    Jun 20, 2009
    Portland,...
    Quick fix I think. I right clicked on kmttg.jar and told it to "open with" and a list offered JAVA. It then came up. Will see how it goes from there.
     

Share This Page