July 30th Update

Discussion in 'TiVo Stream 4K' started by Johnwashere, Jul 31, 2020.

  1. Johnwashere

    Johnwashere Member

    298
    23
    Sep 17, 2005
    Columbus, Ohio

    Advertisements

    Just saw this on the tivo Reddit page:


    Stream 4K Firmware Update and Stream App Updates
    [​IMG]
    Hi All,

    Along with the Pluto VOD update we released yesterday we are rolling out new Stream 4K device firmware as well as Stream App updates over the next week or so. These have a number of additional features and functionality in them as well as fixes and general improvements! We've detailed some of that information below:

    • Apps are now accessible from the Left Navigation Menu on the Stream App

    • Remote Control pairing and TV/Audio Improvements

    • Additional Dolby Atmos support

    • Fixes for flashing video playback in some apps

    • HDMI-CEC Improvements

    • Many additional fixes
    We know many of you have experienced a number of these issues and we hope these releases are well received. One item I know you're also concerned about is the HDR issues - whilst the changes in functionality missed this release please rest assured we'll have those in another release shortly.
     
    Noelmel likes this.
  2. TivoJD

    TivoJD Active Member

    414
    92
    Feb 7, 2005
    Polk Co,...
    They appear to have locked out the developer options with the new update I received this morning. I had available before update and now I get developer options are not available for this user when I try to go into the developer menu option. Clicking the build just tells you that you are already a developer.
     
    Noelmel likes this.
  3. rczrider

    rczrider Active Member

    185
    96
    May 15, 2020
    I guess they didn't like the community fixing issues on their own using the adblink method.

    Maybe they've decided they'd like to keep the firmware buggy and prevent folks from fixing some aspects on their own? Actually, the truth is that they realized folks like me aren't interested in sending them gobs of viewing data for them to sell.

    I actually just received a second TS4K (after returning the first one almost 2 months ago), this one ordered from Amazon since dealing with TiVo customer service is such an ordeal. If this new update does indeed block the adblink access - which I used to correctly pair the remote to my TV and soundbar, since TiVo borked that on its own - and the supposed fixes coming from TiVo undo it / prevent me from fixing it, I'm done with them. Enjoy processing yet another returned TS4K, TiVo. I'm guessing you're accumulating a nice stack you can sell as "renewed".
     
    WOT Time likes this.
  4. SugarBowl

    SugarBowl Member

    874
    13
    Jan 4, 2007
    north carolina
    In the guide, there is no longer a page break between the end of the Tivo+ channels and the Sling channels.


    "Apps are now accessible from the Left Navigation Menu on the Stream App"
    I don't see how to do this.
     
    Noelmel and WOT Time like this.
  5. Alex_7

    Alex_7 Well-Known Member

    410
    257
    Jun 24, 2020

    Advertisements

    Did it fix the video flashing/flickering issue?
     
  6. convergent

    convergent Active Member

    453
    25
    Jan 3, 2007
    Raleigh, NC
    The update does have a lot more settings options related to the remote and looks like the ability to set TV and Audio settings. It made my old LG work again. I've not got the time today to try it on my Sony which was the one that never would work for audio in spite of all the great hacks from this forum.

    But, the update broke streaming of MPEG2 so Channels DVR, HD Homerun, Emby and other apps won't stream OTA correctly. Channels has a work around, but the other apps I don't think do.
     
    Noelmel and SugarBowl like this.
  7. cybergrimes

    cybergrimes Legend

    380
    103
    Jun 14, 2015
    Minnesota
    Yeah it looks like in the remote/accessories setting, under the TiVo remote, there are settings screen to setup the TV and separately select an audio receiver.
    That's great actually, assume shouldn't need a workaround if that's the case.
     
    Noelmel likes this.
  8. WOT Time

    WOT Time New Member

    11
    1
    Jun 6, 2020
    Yeah, me too. So I tried a reset and going back in to build, clicked 7 times then it's asking for a 4 digit pin. tried all the usual suspects like 0000, 0123, 1234, 9999 etc, no luck.
    Someone suggested the first time might be setting the pin, but nope. 0000 was the first I tried and re-entering that gives me the same "Wrong PIN, try again" message. Oh, and 5 false attempts, denies you access for 60 seconds!
    I'm fuming - anyone know what the pin is?
     

    Attached Files:

  9. SugarBowl

    SugarBowl Member

    874
    13
    Jan 4, 2007
    north carolina
    Confirmed that my HDHomeRun with cablecard won't stream anything now thru the HDHomeRun app on Tivo Stream.
    Nest app still works.
     
  10. TivoJD

    TivoJD Active Member

    414
    92
    Feb 7, 2005
    Polk Co,...
    How about 8486 (TiVo on phone keypad)?
     
  11. cybergrimes

    cybergrimes Legend

    380
    103
    Jun 14, 2015
    Minnesota
    Did you try to set one up after the update? I was able to program mine to IR control my Sonos Playbase earlier today using on screen selection. I had to do a factory reset first to wipe out the workaround programming I did a few months ago though (might have been another way to reset but this worked well enough)

    [​IMG]
     
    Last edited: Jul 31, 2020
  12. cybergrimes

    cybergrimes Legend

    380
    103
    Jun 14, 2015
    Minnesota
    I tried that earlier, no luck
     
  13. convergent

    convergent Active Member

    453
    25
    Jan 3, 2007
    Raleigh, NC
    I had trouble with TV remote configuration before and was a nightmare and never got it to control volume on my Sony. After the update, I've moved it back and forth between the older LG and Sony X900F a couple times and works great with volume control on both, and just required redoing the TV setting. So that is fixed. One oddity is on my LG it seems to be thinking my Sonos system is there and configures for it. To get rid of it, you need to go into scanning for that and then back out of it and it will lose the Sonos. Its not obvious. So the main show stopper for me has been fixed.

    In addition to the MPEG2 being broken, I now also have when configured for 1080P 60hz, it has a red line down the right side of the display on my Sony. If I switch it to 4K 30hz, this goes away.
     
  14. osu1991

    osu1991 Well-Known Member

    1,444
    474
    Mar 6, 2015
    Oklahoma
    Hopefully they've stopped this update from going out. I do use one on my old 1080p office tv for watching local OTA with an HD Homerun and streaming SiriusXM. I don't need it autoupdating and ruining the only acceptable use I've found for this. The other one I bought is still in a drawer
     
  15. TivoJD

    TivoJD Active Member

    414
    92
    Feb 7, 2005
    Polk Co,...
    3000? internet search came up with that for android tv
     
  16. cybergrimes

    cybergrimes Legend

    380
    103
    Jun 14, 2015
    Minnesota
    Nope, also tried the build number for giggles
     
  17. foghorn2

    foghorn2 Well-Known Member

    1,557
    470
    May 4, 2004
    Las Vegas
    I said it here weeks ago Mpeg2 was being screwed around with by Tivo, now they killed it altogether. My 3 AirTv Minis have no issues with MPEG2, never did and Im sure never will.

    F Tivo
    F Amazon Sticks

    The AirTv Mini 4K and the upcoming Android dongles are/will be far superior.
     
  18. SugarBowl

    SugarBowl Member

    874
    13
    Jan 4, 2007
    north carolina
    My audio has stopped working. Connected to an insignia tv. Tried rebooting the Tivo Stream and still no audio.
     
  19. cybergrimes

    cybergrimes Legend

    380
    103
    Jun 14, 2015
    Minnesota
    They didn't kill it. My MPEG2 DVD rips still work, maybe something to do with MPEGTS.
     
    Last edited: Jul 31, 2020
  20. NashGuy

    NashGuy Well-Known Member

    4,199
    2,079
    May 2, 2015
    That would be my guess. The Amlogic S905Y2 chipset in the TS4K has native support for TS (MPEG transport stream) input. Apparently this firmware update did something to mess that up.
     

Share This Page

spam firewall

Advertisements