iPad app update is out!

Discussion in 'TiVo Premiere DVRs' started by bradleys, Dec 20, 2011.

  1. bradleys

    bradleys It'll be fine....

    4,116
    236
    Oct 31, 2007
    An iPad app update is out today. It is working great - I didn't even have to reboot my router this time! :)

    Looks like they sped up grid load time
    You can now view content that has already aired
    They claim to have improved connectivility
    Other updates as well

    I do love this app - I use it all the time.
     
  2. sbiller

    sbiller Active Member

    1,917
    0
    May 10, 2002
    Tampa, FL
    http://itunes.apple.com/us/app/tivo/id401673976?mt=8&ls=1

    What's New in Version 1.6
    » Resolves issues finding TiVo Premiere DVRs
    » Resolves misidentification of Premiere DVRs as Series3 DVRs
    » Provides one-touch access to actor info within show descriptions
    » Enables programming guide to go back and display shows that have already aired
    » Resolves sign-in failure issues in “Away” mode
    » Enhances “Get From” display and functionality
    » Multiple performance enhancements
     
  3. smbaker

    smbaker Well-Known Member

    24,751
    1,932
    May 24, 2003
    Fantastic! I might even be able to start using the iPad app again...
     
  4. nelin

    nelin New Member

    5
    0
    Dec 6, 2011
    yeah its a good news:up:
     
  5. aadam101

    aadam101 Tell me a joke

    7,114
    12
    Jul 14, 2002
    Massachusetts
    Ahhhhh......Release notes......I long for those days.
     
  6. Saberj

    Saberj New Member

    50
    0
    Sep 29, 2006
    Oddly enough, I never had an issue with my Premiere and iPad app. My iPhone app was another matter entirely, though.
     
  7. bradleys

    bradleys It'll be fine....

    4,116
    236
    Oct 31, 2007
    Theses updates really helped in loading to the Grid.

    And I love that I can go back in time to see what has already played...

    Now... Let me stream (or even just move) a recording to my ipad :)
     
  8. mmf01

    mmf01 Member

    146
    10
    Jan 31, 2011
    Orange...
    Too bad they STILL haven't fixed the issue with the app hijacking the ipad's audio. I reported the issue to TiVo months ago and apparently it has fallen on deaf ears.

    Basically, If your listening to music on the iPad in the background and initially open the TiVo app (App not running in background), even with all sounds disabled in the app, the TiVo app will hijack and mute the current audio playing on the iPad.

    Overall great app, just annoyances like this I'd like to see fixed.
     
  9. Rodger

    Rodger New Member

    4
    0
    Jun 16, 2002
    Columbus, MS
    Does anybody know of a good source to help with getting my iPad and iPhone connected to my Premiere? I recently had to replace my router, and I upgraded the iOS 5.0 on both and now I can't get either connected. I dont know which of those caused my issue I have done the following:

    Upgraded to 1.6
    Rebooted everything
    Deleted and reloaded the app
    Tried to reenter the media key, but can't get to that even after reloading app and rebooting
    Went to the Router advanced settings and put all the ports in that need to be unrestricted

    Not sure what to do now. Any help is appreciated.
     
  10. mmf01

    mmf01 Member

    146
    10
    Jan 31, 2011
    Orange...
    What router are you using? Also, if running any hubs/switches between TiVo and router, we're those rebooted as well?
     
  11. Rodger

    Rodger New Member

    4
    0
    Jun 16, 2002
    Columbus, MS
    Not at home right now but I think that is correct. I do not have any switches or hubs.

    (ETA I think it is a 615, not a 614)
     
  12. buzzword

    buzzword New Member

    54
    0
    Jun 9, 2002
    Glendale, CA

    Make sure you have multicast enabled in you router.

    TiVo uses Apple's Bonjour protocol for device discovery and that in turn requires multicast enabled in your router in order to work reliably.

    I had the following problems:

    - Having to reboot my router every time I wanted my Apple TV to stream from my PC because the Apple TV would not see the pc the next time I went to use it,

    - When I just recently downloaded the TiVo iPad app, I could not get it to see my two premieres no matter what I did.

    - My Tivos would lose sight of each other, I would have to reset the network connection on one or both to make them visible to each other in order to transfer a program from one to the other

    After a lot of research here and elsewhere, I *finally* stumbled upon a single message (on an obscure website found thru a google link) that mentioned enabling multicast...I checked my router, a Dlink DIR-655 and sure enough multicast was disabled, I'm not sure if that was the default, or if I disabled it when I set up the router (likely, I usually disable anything I don't specifically need).

    To make a long winded story short, I enabled multicast and voila, all the problems mentioned above went away! I can only imagine that multicast is normally enabled by default in routers, otherwise this solution would be more widely known.

    Hope it works for you
     
  13. Rodger

    Rodger New Member

    4
    0
    Jun 16, 2002
    Columbus, MS
    And the multicast selection is not checked on the default or emulator page under Advanced tab and Advanced Network. I will come back and post if that solves the issue when I get back home and give it a try. Reading about multicast on the support page, that sounds like it may be my issue like it was for you. It also sounds like it is not normally enabled by default, the help page says if you have problems, try enabling multicast which sounds like not default enabled.

    Thanks for the heads up.
     
  14. Rodger

    Rodger New Member

    4
    0
    Jun 16, 2002
    Columbus, MS
    I have run out of ideas.
     
  15. mmf01

    mmf01 Member

    146
    10
    Jan 31, 2011
    Orange...
    Double-check remote access is enabled on the TiVO? Also, what error does the TiVO app show?
     
  16. jayb3369

    jayb3369 New Member

    6
    0
    Sep 1, 2011
    Every time I use the iPad app, my TiVo Premiere reboots. If I use the app, I have to start it, do whatever I want to do, and then shut the app down. I have to hope the app doesn't reboot the TiVo in the short time I have it running. if I forget to shut the app down, the TiVo will reboot within 1/2 an hour.

    I can never use it while something is recording, for fear it will reboot the TiVo.

    I stopped using the app for two weeks, and the TiVo did not reboot once. Then I saw that the most recent update was available, so I downloaded it, hoping it would fix the rebooting problem. Within 15 minutes of downloading and using it, the TiVo rebooted.
     
  17. mmf01

    mmf01 Member

    146
    10
    Jan 31, 2011
    Orange...
    Well, based on the symptoms above, it doesn't sound network or app related. Sounds like something is corrupt on the TiVo box itself.

    Here is what I would try.
    1) Disable remote access on the box.
    2) Delete the app
    3) Perform a network connect
    4) Reboot the box
    5) Turn on remote access
    6) network connect for good measure
    7) Install iPad app again
    8) Give it a go..

    If no dice, the last "all else fails" option is to reset the TiVo box either completely ("Clear and Delete Everything" option) or partially using the options that lead up that. But be warned, in addition to loosing all season passes, recordings, ratings, etc, last time I personally did "Clear and delete everything" on one of my boxes, for some odd reason it killed my cablecard too and required a truck roll. It might help to remove the cablecard first, but haven't needed to test that theory, so YMMV.

    EDIT: Are the reboots perhaps related to what others are experiencing here? http://www.tivocommunity.com/tivo-vb/showthread.php?t=477833
    http://www.tivocommunity.com/tivo-vb/showthread.php?t=480533
     
  18. buzzword

    buzzword New Member

    54
    0
    Jun 9, 2002
    Glendale, CA
    Try rebooting the router, then reboot the tivo.
     
  19. jayb3369

    jayb3369 New Member

    6
    0
    Sep 1, 2011
    I'm going to try the steps you suggest. I don't believe it's related to the threads you reference, as I don't believe the TiVo spontaneously reboots except when I am using the iPad app.
     
  20. morac

    morac Cat God TCF Club

    12,624
    1,337
    Mar 14, 2003
    NJ
    Version 1.9 is out and it adds a bunch of new features including a browse tab, the ability to view and edit the My Shows, To Do and Season Pass lists in away mode on the Series 4 boxes. It also supports the To Do List and Season Pass Manager on the Series 3 boxes.

    The full version notes are available at http://itunes.apple.com/us/app/tivo/id401673976?mt=8&ls=1 but I can't copy and paste since I'm posting this on my iPad and that takes me to the app store and I can't copy the version notes from there.
     

Share This Page