iOS 5.1.1 no longer works with TiVo v20.4.7a

Discussion in 'TiVo Help Center' started by Linderhof, Jun 5, 2015.

  1. Jun 5, 2015 #1 of 17
    Linderhof

    Linderhof New Member

    9
    0
    Jun 5, 2015

    Advertisements

    My 1st gen iPad worked reasonably well with the TiVo v3.2.4 iOS application until TiVo pushed out DVR v20.4.7a. Now I have the typical problem with the app "Sign In" not working with the MAK or TiVo account. Says MAK invalid and says "Network error, try again" with the TiVo account sign in.

    The TiVo support specialist that I spoke to said that they had gotten a lot of calls from TiVo users who have 1st gen iPads. The 1st gen iPad is limited to iOS 5.1.1 and so forced to take the older v3.2.4 of the TiVo app.

    I'm pretty bummed. My 2nd gen iPad with iOS 8 works fine. My 1st gen iPad is 64G with cellular data. Hate to give up on it.

    TiVo web site says that they work with iOS 5.1 and later. Hmmm..

    Anyone know more about this?
     
    Last edited: Jun 5, 2015
  2. Jun 6, 2015 #2 of 17
    telemark

    telemark Active Member

    1,544
    4
    Nov 12, 2013
    The story is all the iOS apps expired, except the newest one.

    Tivo needs to run an old app build for iOS 5.1.1, I don't know if they will.
    Apple does allow this though.
     
    Last edited: Jun 6, 2015
  3. Jun 6, 2015 #3 of 17
    Linderhof

    Linderhof New Member

    9
    0
    Jun 5, 2015
    The 3.2.4 version worked reasonably well so let's hope that they do something with that for the 1st gen iPad community. I have been with TiVo from the beginning with the early Phillips units with dial up modems. My basement is like a TiVo museum.
     
  4. Jun 6, 2015 #4 of 17
    rfc19061

    rfc19061 New Member

    23
    1
    Mar 5, 2015
    I'm with you. App worked fine up until about a week ago, then belly up! I can understand Apple trying to force you to buy new hardware to enrich their pockets, but you'd think TiVo would try to keep customers happy. Especially those of us that have been with them from the beginning. Very disappointing.
     
  5. Jun 7, 2015 #5 of 17
    Barrister

    Barrister Barrister

    5
    0
    May 18, 2013
    Mesa, AZ

    Advertisements

    Yes it stinks. I have an iPad2 and therefore have options, but I do not want to upgrade beyond IOS 6 and will be forced to if it is not fixed.
     
  6. Jun 7, 2015 #6 of 17
    Linderhof

    Linderhof New Member

    9
    0
    Jun 5, 2015
    So Barrister, v20.4.7a doesn't work with iOS 6 either? :mad:
     
  7. Barrister

    Barrister Barrister

    5
    0
    May 18, 2013
    Mesa, AZ
    No, it doesn't. Rats.
     
  8. USN1Guy

    USN1Guy New Member

    6
    0
    Jul 22, 2011
    Brthesda, MD
    Jennifer: Thank you for waiting, my name is Jennifer and I am happy to assist you. I would like to confirm the information you have provided.
    Jennifer: In order to access your account, can you please provide the following account information?

    *name on the account
    *address (including city/state/zip)
    *phone number
    You: Patrick Martin//XXXXXXXX//YYYYYYYY
    Jennifer: Thank you for verifying your account information! How may I assist you today?
    You: Until today, I've used my Gen 1 Apple 1Pad to remotely view programs on my 2013 Roamio. Today, the network connection always fails. See my initial request for the error message I get.
    You: Also, I can sign in today using an iPad that's ~1 year old.
    Jennifer: I am sorry, but with a recent update to the TiVo Apps, the Apple iOS devices do require having the iOS version 7.0 in order to use the app functionality.

    Most generation 1 and 2 Apple iOS devices do not have the appropriate iOS versions to support use of the app,
    You: Wait! When I "update" my Tivo app on the older iPad, I mentions the iOS 7 rqmt but gives me the opportunity to D/L an older app that I have used in the past. Why doesn't the older app work now?
    You: Are you saying that Tivo has canged their 'older' app to disable all Gen 1 & Gen 2 iPads?
    Jennifer: I do apologize, but the "Classic App" that you are referring to is no longer supported and is discontinued. That is odd that the app store is still offering it.
    You: Please pass along my displeasure with Titio's decision to change their system that disables many iPads.
    Jennifer: I do apologize for the trouble and inconvenience. Is there anything else I can assist you with today?
     
  9. Barrister

    Barrister Barrister

    5
    0
    May 18, 2013
    Mesa, AZ
    How about this:

    Niles: Thank you for waiting, my name is Niles and I am happy to assist you. I would like to confirm the information you have provided.
    Niles: In order to verify your identity, can you please provide the following account information?

    *name on the account
    *address (including city/state/zip)
    *phone number
    You: XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
    Niles: Thank you for verifying your information Dennis. I can definitely assist you with questions today. The TiVo app would need the newest iOS version in order to function.
    You: What if I cannot update to IOS 7 or 8? Am I SOL after using the Tivo stream with my iPad for the last 2 years?
    Niles: You would want to look at getting an updated version of the software or upgrade the iPad generally.
    You: Cannot get an updated version of the software, because the latest version does not run on my version of IOS, although my existing Tivo App ran fine until you updated the firmware on my Premier. I am not talking about "generally," I am talking about specifically.
    Niles: I understand what you are talking about and we apologize for that frustration. However, that app would need the newer iOS software in order to work, so there isn't a work around to let it work with the older iPad devices.
    You: Oh, I think I get it, but let me confirm: I had a perfectly working system for the last 2 years and now you update the firmware and make my iPad and Tivo Stream obsolete and do not intend to fix it. Did I get that right? Just want to confirm so when I get my transcript I can forward it to the appropriate people at Tivo.
    Niles: Partially correct, it is like how DVDs eventually stopped the need for VCRs and newer Windows updates stopped older software installation. It would be the similar to those. Your Stream is still working for those newer iOS options. Hopefully we will see a way to install the app to the older iOS software, but at this time there are no official announcements if or when that is coming.
    Niles: You may even check with Apple why that can't be updated to new software.
    Niles: You may even check with Apple to see why that can't be updated to new software.
    You: Well, you see, Apple lets me stay with my current IOS and does not force an update that makes my hardware obsolete. So, really no need to check with them.
    You: Seems easy enough to make Tivo App 3.2.4 compatible with your latest firmware. Any plans to do so?
    Niles: Not at this time.
    You: Well, OK I guess that's about all the information gathering I can do. Just send me the transcript -- but I wouldn't include a survey if I was you.
    Niles: There should be an option to email in your chat box and I would expect a survey will be sent automatically. Feel free to delete it if you want though.
    You: Not a chance.
    Niles: Then we will await your survey results for that update.
    You: Without a doubt.
    Niles: Is there anything else I can help you with today?
    You: No, I've had about as much help as I can stand.
    Niles: Being the bearer of bad news isn't often fun. Thank you for using TiVo Chat and have a great day!
    You: I'm sure it isn't.
     
  10. rakes5

    rakes5 New Member

    22
    1
    Sep 22, 2003
    naperville, IL
    There is something else going on as I cannot access via the old free TiVo desktop either.
    I am able to use kmttg to see my shows, delete shows or to do lists, but cannot download using windows 7.
     
  11. Zinfandel

    Zinfandel New Member

    6
    4
    Nov 30, 2008
    Seattle, WA
    Let me add my voice to those disappointed that the latest update broke the Tivo app on the iPad 1. I've been using that app for several years, mainly to download and watch shows when travelling. Now I discover that the app no longer works and my only option is to buy a new iPad. Furthermore, there was no announcement that the app was being discontinued. I had to learn about it by reading this forum after getting login error messages that didn't reflect the actual problem. Bad job, Tivo.
     
  12. mitsirrah

    mitsirrah New Member

    7
    0
    May 29, 2005
    Extremely bad job Tivo.
    I have been a Tivo customer since 2000. In fact I still have a working Series 1 Tivo. While I can understand hiccups here and there it seems to me to be callous disregard for customers who have invested in the Tivo ecosystem (in my case Tivo Premiere/Stream/ another Tivo Premiere, and an iPad to stream with) to update their software in such a way (or fail to update if a certificate has expired) such that the investment is wasted. Does Tivo think I should buy a new $500 iPad every couple of years? You know who's app still works on my iPad? Comcast's. I never thought Comcast would be more customer friendly than Tivo...
     
    Last edited: Jul 4, 2015
  13. HerronScott

    HerronScott Well-Known Member

    7,632
    1,141
    Jan 1, 2002
    Staunton, VA
    Comcast's app did not work on my old Android 2.3 tablet and that was a few years ago when it wasn't that far out of date. Do they expect me to buy a new Android tablet every couple of years??? ;)

    Scott
     
  14. mitsirrah

    mitsirrah New Member

    7
    0
    May 29, 2005
    Did Comcast advertise an add-on device with lifetime service that supported your Android 2.3 device?

    If this is a security certificate expiration they knew of in advance they could have advertised support for iPad Gen 1 until only 6/1/2015...

    Perhaps Android tablet owners won't be experiencing the same issue. That said much of the blame is probably on Apple for this, but Tivo should have been more honest up front and communicated better as the date of expiration approached. If it is possible for them to patch the old version of the app with a new cert I think they owe it to us.
     
  15. HerronScott

    HerronScott Well-Known Member

    7,632
    1,141
    Jan 1, 2002
    Staunton, VA
    I don't know but the point was that you were trying hold Comcast up as better than TiVo because their application happened to still supported your older iPad tablet.

    I do believe though that iOS devices like gen 1 iPad's that are stuck at an older version of iOS are going to see more lack of support from applications just like Android tablets that have been stuck at 2.3 or 3.2. It looks like production of the gen 1 iPad tablet was March 2011 so you have a tablet that's over 4 years old which is ancient when it comes to a tablet.

    Scott
     
  16. guyjr

    guyjr New Member

    20
    0
    Oct 20, 2002
    I too have had the issue with a brand new Roamio Pro and 1st gen iPad. However, I tried to escalate this up the chain a bit. I found the Corporate Relations support page, did as several of you did and chatted up support, but instead of just ending the call I got an incident number out of them, which I then used on the Corp Rel support page to submit a message directly to that team. Who knows where that winds up, but it's at least worth a shot to poke and prod the development bean counters into action. Especially if the issue is simply that the cert they use for encryption is expired... a simple rebuild, day or two of smoke testing, and certification should be all that is needed.

    Update - I have to retract what I had posted earlier regarding TiVo - I received not one but two phone calls this afternoon from executive relations, indicating that they would be filing a formal product feature request to update the older version of the app. Now, whether or not it can be done, or will be done, is another question entirely, but I have to say, receiving follow up directly from TiVo is a very positive step!
     
    Last edited: Jul 29, 2015
  17. whynotthisname

    whynotthisname New Member

    16
    0
    Dec 12, 2011
    Holy disablement!

    I wish guyjr's "poke" had worked.

    6 months later and iOS app 3.2.4 is still broken/does not work with updated Tivos.

    How annoying.
     

Share This Page

spam firewall

Advertisements