Installing Galleon on Linux

Discussion in 'TiVo Home Media Features & TiVoToGo' started by smoothtivo, Nov 8, 2005.

  1. Nov 19, 2005 #41 of 138
    Malibyte

    Malibyte Took the red pill

    128
    0
    Jun 12, 2005
    Simi Valley, CA

    Advertisements

    Can anyone give me a clue as to why my TiVo can't find the Galleon server, from the log I posted? Any help would be appreciated. I'm sure it's something simple/obvious...it usually is. :) I just don't see it at the moment.
     
  2. Nov 19, 2005 #42 of 138
    azitnay

    azitnay Active Member

    2,977
    0
    Jan 20, 2003
    Washington,...
    That TiVoListener error must have something to do with it.

    You're definitely running Galleon as root, right?

    Drew
     
  3. Nov 19, 2005 #43 of 138
    smoothtivo

    smoothtivo New Member

    28
    0
    Apr 26, 2004

    Sorry still a little new. How would I do that?

    Thanks again,
    smooth
     
  4. Nov 19, 2005 #44 of 138
    Malibyte

    Malibyte Took the red pill

    128
    0
    Jun 12, 2005
    Simi Valley, CA
    Yes, it's running as root.

    Here's a dump after restarting Galleon and rebooting the TiVo:

    Code:
    
    [root@kenobi: ~]$ /etc/init.d/galleon start
    Starting Galleon TiVo HME server:
    [root@kenobi: ~]$ Galleon 1.9.0 is starting...
    Galleon is ready.
    tail -f /srv/galleon/logs/log.txt
    11:12:38,042  INFO [main] StandardQueryCache - starting query cache at region: net.sf.hibernate.cache.StandardQueryCache
    11:12:38,042  WARN [main] EhCache - Could not find configuration for net.sf.hibernate.cache.StandardQueryCache. Configuring using the defaultCache settings.
    11:12:38,042  INFO [main] HibernateUtil - Initialized Hibernate
    11:12:53,397  INFO [main] ShoutcastStations - Exceeded daily search limit for Shoutcast.com
    11:12:53,577 ERROR [main] TiVoListener - java.io.IOException: Operation not permitted
    11:12:53,645 ERROR [main] AppFactory - java.io.IOException: Operation not permitted
    11:12:53,776  INFO [main] BroadcastThread - High frequency enabled
    11:12:53,778  INFO [main] Server - Broadcast port=2190
    11:12:58,824  INFO [ListenThread] BroadcastThread - High frequency enabled
    11:13:38,296  INFO [ListenThread] BroadcastThread - High frequency enabled
    11:25:49,665  INFO [ConnectionThread] ConnectionThread - New connection accepted /192.168.1.11:1026
    
    Still getting the error message, but it did apparently get *something* from the TiVo.
    :confused:

    Edit: Tried it with 1.9.1 also. No difference. :(

    Bob
     
  5. Nov 19, 2005 #45 of 138
    Malibyte

    Malibyte Took the red pill

    128
    0
    Jun 12, 2005
    Simi Valley, CA

    Advertisements

    Which Linux distribution are you running?
     
  6. Nov 19, 2005 #46 of 138
    smoothtivo

    smoothtivo New Member

    28
    0
    Apr 26, 2004
    Fedora Core 4
     
  7. Nov 20, 2005 #47 of 138
    azitnay

    azitnay Active Member

    2,977
    0
    Jan 20, 2003
    Washington,...
    chkconfig is the easiest way. Add the following two lines to the top of /etc/rc.d/init.d/galleon, right after the #!/bin/sh line:

    # chkconfig: 345 99 01
    # description: Galleon is a TiVo HME server.

    Then, run chkconfig --add galleon

    Note that this makes galleon start by default on runlevels 3, 4, and 5 (3 is usually normal operation). It should be fine, but to change this, you can change the 345 above.

    Drew
     
  8. Nov 20, 2005 #48 of 138
    azitnay

    azitnay Active Member

    2,977
    0
    Jan 20, 2003
    Washington,...
    I'm a bit stumped... Perhaps Leon knows more, but I doubt he follows this thread since it's about Linux. Maybe you should repost that code snippet in one of the other threads.

    Drew
     
  9. Nov 20, 2005 #49 of 138
    javahmo

    javahmo New Member

    1,538
    0
    Aug 11, 2003
    Enable debug logging using the Galleon configuration GUI and email me all of your logs.
     
  10. Nov 20, 2005 #50 of 138
    Malibyte

    Malibyte Took the red pill

    128
    0
    Jun 12, 2005
    Simi Valley, CA
    Sent...thanks!
     
  11. Nov 24, 2005 #51 of 138
    jstaffon

    jstaffon New Member

    21
    0
    Nov 24, 2005
    Idaho
    Sorry to jump into the middle of this post but I'm having similar problems as some of you. I'm trying to run version 1.9.2 on Mandriva LE 2005. My TiVo is a Toshiba SD-H400. I don't get any error messages in the log files and I can see my server entry in the screen that lists all my recorded shows. If I select the server entry I can see and transfer files from my linux server to my Tivo. If I start the gui.sh on my linux server, I can see my Tivo unit and the recorded shows. What doesn't work is the following: None of the apps that I've added via gui.sh show up in the "Music, Photos, and More" area. I've successfully run Galleon on a Windows box without any problems. I must be missing something easy. I've done most of the suggestions above such as making sure java pointed to the right place and making sure the /etc/hosts file has the entry and ip for my server. I'm hoping since most of the installation on my Linux box works, except for all the apps, that it would be something obvious.
    Thanks in advance.
    Jeff.
     
  12. Nov 24, 2005 #52 of 138
    azitnay

    azitnay Active Member

    2,977
    0
    Jan 20, 2003
    Washington,...
    Is IPv6 definitely disabled?

    Drew
     
  13. Nov 24, 2005 #53 of 138
    jstaffon

    jstaffon New Member

    21
    0
    Nov 24, 2005
    Idaho
    Nope.....I will try that. I thought I read in one of the posts that IPv6 didn't need to be disabled....or maybe I read someone had Galleon running without disabling it. I'll go back and try that.

    Thanks for the reminder.
    Jeff.
     
  14. Nov 24, 2005 #54 of 138
    azitnay

    azitnay Active Member

    2,977
    0
    Jan 20, 2003
    Washington,...
    Well, it says right in the Linux installation instructions on http://galleon.sourceforge.net/html/install.html to disable it.

    I've never even tried running Galleon with IPv6 enabled, but I remember from the early days of HME that I couldn't get any HME apps running on Linux until I disabled IPv6.

    Drew
     
  15. Nov 24, 2005 #55 of 138
    jstaffon

    jstaffon New Member

    21
    0
    Nov 24, 2005
    Idaho
    I disabled it and everything works fine....thanks man! Sometimes you have to hit someone with a brick to get them to see the light! I'll bet I read the instructions a dozen times.

    Thanks again! Jeff.

    BTW, what functions will I lose by not having ipv6 running? Not sure I know what it does.
     
  16. Nov 24, 2005 #56 of 138
    azitnay

    azitnay Active Member

    2,977
    0
    Jan 20, 2003
    Washington,...
    At the present time, pretty much nothing. IPv6 is the "future" of IP; it's the successor to the current IPv4 (dotted quad) style of IP address. It's meant to deal with the inevitable shortage of IPv4 IP addresses, since there are only roughly 4 billion (2^32) available. IPv6 will give us 2^128 total IP addresses, which is something like 600 IP addresses per square millimeter of the Earth's surface.

    Unfortunately, though, IPv6 seems to cause problems with HME. I forget exactly what the problem is; something pertaining to multicasting. Regardless, IPv4 should be supported for another couple decades or so.

    Drew
     
  17. Nov 24, 2005 #57 of 138
    jstaffon

    jstaffon New Member

    21
    0
    Nov 24, 2005
    Idaho
    Ah yes....I should have known that. Brain cramp......

    Thanks again. Hope your holiday was enjoyable.

    Jeff.
     
  18. Nov 28, 2005 #58 of 138
    crumley

    crumley New Member

    42
    0
    Jan 22, 2003
    The issue with ipv6 comes up often. Personally, I have never had a problem with ipv6 and Galleon, but it seems like a lot of people do.
     
  19. Nov 28, 2005 #59 of 138
    dachtler

    dachtler New Member

    34
    0
    Oct 21, 2002
    I'm getting the following messages on my FC4 server running Galleon 1.9.2:

    Internet[#1,uri=null] warning: resource 2066 not found.
    Internet[#1,uri=null] warning: resource 2066 not found.
    Weather[#1,uri=null] warning: resource 2062 not found.
    Weather[#1,uri=null] warning: resource 2062 not found.
    Traffic[#1,uri=null] warning: resource 2062 not found.
    Traffic[#1,uri=null] warning: resource 2062 not found.
    Internet[#1,uri=null] warning: resource 2066 not found.
    Internet[#1,uri=null] warning: resource 2066 not found.
    java.lang.Exception: missed flush
    at com.tivo.hme.sdk.Application.writeTerminator(Application.java:1463)
    at com.tivo.hme.sdk.Application.cmdViewSetPainting(Application.java:1055)
    at com.tivo.hme.sdk.View.setPainting(View.java:526)
    at org.lnicholls.galleon.apps.internet.Internet$ImageScreen.updateView(Internet.java:400)
    at org.lnicholls.galleon.apps.internet.Internet$ImageScreen.access$800(Internet.java:374)
    at org.lnicholls.galleon.apps.internet.Internet$4.run(Internet.java:420)

    The apps seem to be working fine that are generating the error messages. Anything I should be concerned about? Any idea how to fix these?
     
  20. Nov 28, 2005 #60 of 138
    javahmo

    javahmo New Member

    1,538
    0
    Aug 11, 2003
    The "resource not found" and "missed flush" warning messages are generated by the TiVo HME SDK. These can be ignored as they relate to various timing issues which are not critical to the HME apps.
     

Share This Page

spam firewall

Advertisements