1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Image for TiVo Series 3

Discussion in 'TiVo Series3 HDTV DVRs' started by digitaldiva, Dec 4, 2017.

  1. cragganmore

    cragganmore New Member

    1
    0
    Jun 19, 2018
    I, too, am in need of a TCD658000 image. Many thanks if someone has one to share!
     
  2. ThAbtO

    ThAbtO TiVoholic by the bay

    8,860
    348
    Apr 6, 2000
    SF Bay Area
    Sent.
     
  3. dewman01

    dewman01 New Member

    2
    0
    Jul 3, 2018
    Any Chance I could get an image of TCD652160. My Mothers TivoHD wont boot past the Tivo booting screen.

    Thanks
     
  4. ThAbtO

    ThAbtO TiVoholic by the bay

    8,860
    348
    Apr 6, 2000
    SF Bay Area
    Sent.

    You should also check all the capacitors in the power supply, its common for them to fail without any indication. Any electronics repair shop can do this.
     
  5. dewman01

    dewman01 New Member

    2
    0
    Jul 3, 2018
    Great Thanks for the tip.Will check the capacitors. I have upgraded series 1 and series 2 but nothing newer.
     
  6. Allen King

    Allen King GameTech

    4
    0
    May 22, 2016
    Would like to request a copy of TCD652160 image.

    Thanks in advance 'ThAbtO' for all of your hard work. :)
     
  7. ThAbtO

    ThAbtO TiVoholic by the bay

    8,860
    348
    Apr 6, 2000
    SF Bay Area
    Sent.
     
  8. Utilityman

    Utilityman New Member

    1
    0
    Monday
    Hello and thanks in advance. I have a TCD652160 with a failing hard drive and ended up loosing everything on the drive when I tried to copy it over to another 160G drive with WinMFS. I could get the new drive started if you could please send me the image file. A couple of capacitors are suspect, but appear easy to replace if I can get them somewhere. They're marked as C730 and C733 on their case and C503 and C403 on the board. Any advice on replacement capacitors would be appreciated as well.
     
  9. ThAbtO

    ThAbtO TiVoholic by the bay

    8,860
    348
    Apr 6, 2000
    SF Bay Area
    Sent.
     
  10. Mars

    Mars Member

    310
    2
    Sep 13, 2001
    Traverse...
    My TCD652160 TiVo will boot up and play for about 15 minutes, then goes to the "welcome powering up" screen but does not come back. If I leave it unplugged for an hour it will do this again. I checked the power supply voltages all good, no swelling caps. I think I need to ask for an image and reformat a new drive.
     
  11. ThAbtO

    ThAbtO TiVoholic by the bay

    8,860
    348
    Apr 6, 2000
    SF Bay Area
    Sent.
     
  12. Mars

    Mars Member

    310
    2
    Sep 13, 2001
    Traverse...
    ThAbtO, thank you for the fast reply and the link and info I need. Now I have to dig out my old computer that I still keep around for hacking TiVo drives. Been years since I last did this, but I think it will come back to me.
     

Share This Page