Image for TiVo Series 3

Discussion in 'TiVo Series3 HDTV DVRs' started by digitaldiva, Dec 4, 2017.

  1. Nov 2, 2019 #261 of 286
    Jimbur4

    Jimbur4 New Member

    5
    0
    Nov 1, 2019
    Thank you for prompt response ThAbtO and the file. It answered one on my questions, whether it was a bad drive or a corrupt image, looks like a need a new drive.
     
  2. Nov 2, 2019 #262 of 286
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    10,742
    708
    Apr 6, 2000
    SF Bay Area
    It may also be the power supply, the capacitors would need to be replaced if it hasn't already.
     
  3. Nov 2, 2019 #263 of 286
    ggieseke

    ggieseke Well-Known Member

    5,395
    609
    May 30, 2008
    746 sent.
     
  4. Nov 2, 2019 #264 of 286
    Jimbur4

    Jimbur4 New Member

    5
    0
    Nov 1, 2019
    Thank you for the image, you guys have been great.
     
  5. Nov 2, 2019 #265 of 286
    Jimbur4

    Jimbur4 New Member

    5
    0
    Nov 1, 2019
    yeah I have read many threads on power supplies, so I took an old pc and powered the drive with that and ran sata cable to motherboard with same results, it hangs up on "Welcome... powering up screen. Which led me to either bad drive or bad image. Just afraid of investing in new drive and stiil getting hung up on "welcome screen. Have you heard of any other issues that might cause a hang up on Welcome screen ? Maybe just have to bite the bullet and try brand new drive. Any suggestions on best drive for the buck for tivo HD and its programming ?
     
  6. Nov 3, 2019 #266 of 286
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    10,742
    708
    Apr 6, 2000
    SF Bay Area
    Recommended is WD10EFRX or WD20EFRX (max) on Series 3.
     
  7. Nov 7, 2019 #267 of 286
    bw50

    bw50 New Member

    2
    0
    Nov 7, 2019
    I'm looking for an image for TCD 652160. Many thanks
     
  8. Nov 7, 2019 #268 of 286
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    10,742
    708
    Apr 6, 2000
    SF Bay Area
    Sent.
     
  9. Nov 8, 2019 #269 of 286
    bw50

    bw50 New Member

    2
    0
    Nov 7, 2019
    Many thanks. Much appreciated. Rebuild completed
     
  10. streamitorbust

    streamitorbust New Member

    2
    0
    Nov 13, 2019
    Looking for Series 3 TiVo HD TCD652160 image. First time with this process, so any help is greatly appreciated. Thanks!
     
  11. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    10,742
    708
    Apr 6, 2000
    SF Bay Area
    Sent.

    Most importantly is that it still has Tivo service, especially lifetime, since Tivo will no longer activate Series 3 but will continue to provide service for active units.
     
  12. streamitorbust

    streamitorbust New Member

    2
    0
    Nov 13, 2019
    Awesome! Thanks so much!!
     
  13. eyankee01

    eyankee01 New Member

    5
    0
    Aug 22, 2002
    Plymouth,MI
    I'm looking for an image for a TCD648250B. Stuck in a setup loop with an s03 error, and I think my only solution is to reload. And my original HD sitting on the shelf went bad somehow. Thanks in advance!
     
    Last edited: Nov 20, 2019
  14. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    10,742
    708
    Apr 6, 2000
    SF Bay Area
    Sent.
     
  15. eyankee01

    eyankee01 New Member

    5
    0
    Aug 22, 2002
    Plymouth,MI
    Thanks you so much!!!
     
  16. eyankee01

    eyankee01 New Member

    5
    0
    Aug 22, 2002
    Plymouth,MI
    Well, I've tried many things, and have had no success in loading this image onto a drive. I've tried 3 drives, the one I was using in the tivo, the original drive from the tivo, and a 3rd drive I wasn't currently using. The original, a 250 GB drive, it said was too small. The other 2 just fail right away. I've tried with the drives connected externally with several different SATA to USB adapters, as well as opening the case, and having the drive connected to the motherboard SATA. I did a full reformatted of the 500 GB drive I was using in the tivo, as well as running at chkdsk /f /r /x to find a flag any bad blocks. I'm not sure where I'm going wrong here. Is there a way to confirm that the image is good? I re-downloaded it in case it somehow got corrupted in download. I've spent hours on something that should have taken a few minutes.
    I'm not sure what to do next.
     
  17. eyankee01

    eyankee01 New Member

    5
    0
    Aug 22, 2002
    Plymouth,MI
    OK, got it to work on a laptop. Not sure what's wrong with my desktop. Thanks again!!!
     
  18. Wayne#

    Wayne# New Member

    2
    0
    Dec 20, 2018
    My TIVO HD hardrive also died. I need the image for same ...TCD652160 Would appreciate any help. Thanks Much
     
  19. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    10,742
    708
    Apr 6, 2000
    SF Bay Area
    Sent.
     
    Wayne# likes this.
  20. IsaacW

    IsaacW New Member

    3
    0
    Nov 30, 2019
    Hi Scott,

    I saw you have helped others before. I'm in need of an image for TCD652160 and some instructions if possible. Appreciate it very much. Thanks.
     

Share This Page