I'm starting to hate my TivoHD

Discussion in 'TiVo Series3 HDTV DVRs' started by Doit2it, Oct 3, 2007.

  1. Doit2it

    Doit2it Member

    144
    1
    Jan 3, 2006
    Nashville, TN
    OK, maybe I'm just frustrated. This is my 3rd Tivo. I got a Series 2 40 hr for Christmas 2 years ago. 8 months later I upgraded to a S2 80hr DT. I upgraded to the TivoHD just 2 weeks ago and I never saw this many problems with the other 2 Tivos:

    When I first plugged it in, TivoHD hung on the first startup screen for 30 minutes or so until I did a hard reboot (unplug) then everything was fine on second boot.

    While navigating thru menus my TivoHD has locked up (background, border and Tivo guy on screen, no writing, remote bongs, but unresponsive) about 5 or 6 times. Hard reboot (unplug) is the only way to unfreeze.

    It has also lost picture twice. Black screen, no background, no TV images. Menu and guide data show, but have to reboot to get picture back.

    Menus are VERY laggy. As bad or worse as the Series2 ST was before one of the updates. I've had 9.1.L5 since 9/27 so the indexing problem after an update should have cleared up by now.

    Now after 9.1.L5 anytime I go look at the info on a Manual recording in my Season passes TivoHD will freeze up. Only a hard reboot will unfreeze.

    I have seen a little of the pixalization problem others have talked about, but I don't think mine is nearly as bad as others have had it.

    I know others are having the same problems. I read the forums. I'm just venting. Tivo has worked the bugs out of previous boxes, I've just been lucky not to have suffered from so many at one time as I have since I bought TivoHD.

    I do love the idea behind the TivoHD. HD recordings look as good as broadcast. Beautiful, crisp, clear. I can't wait till Feb '09 for full digital broadcasting (hopefully full digital rebroadcasting also...Comcast?!?). I love getting my QAM HD channels without having to have Cable Cards. If I had to install cable cards I'm sure that would be on my complaint list above too.

    Thanks for letting me vent. I still love the Tivo service. I'm just anxiously awaiting the exterminator (update) that will get rid of all my bugs!

    Doit2it
     
  2. jtown

    jtown New Member

    441
    0
    Sep 26, 2002
    It sounds like you have a bad hard drive.
     
  3. jmoak

    jmoak Beware of Conky!

    2,574
    0
    Jun 20, 2000
    florida
    You've got that many problems with a TivoHD less than two weeks old??!??!?

    Dude, you got a bad tivo. Swap that puppy before your thirty days are up.

    There's no way in god's green earth you should be seeing THAT many problems.

    Get yourself a new one NOW!!!
    :eek:
     
  4. moolman

    moolman New Member

    60
    0
    Dec 22, 2005
    I'm having the same problem with my S3. After the upgrade, if I try to change the settings in the manual recordings season pass, the Tivo freezes, so I have to unplug it. I think it's a bug in the new update. It did not happen before the update.
     
  5. kirk1701

    kirk1701 New Member

    194
    0
    Feb 4, 2007
    Just exchanged mine for the same issues, got the new one in last night and hooked it up and I maybe just over reacting since it might have still been indexing, but menue's were still slow as surup so I'll know more when I get home tonight.
     
  6. Doit2it

    Doit2it Member

    144
    1
    Jan 3, 2006
    Nashville, TN
    But I've seen each and every one of my problems listed in the forums here so other people are dealing with this too. Maybe I'm just the 1st one to itemize everything that's wrong with the TivoHD. And yes, if things don't smooth out in the next week or so I will return the Tivo. The only problem is I bought it thru Amazon.com. Do I have to ship it back to them, or does Tivo do 30 day returns no mater where you purchased?
     
  7. Doit2it

    Doit2it Member

    144
    1
    Jan 3, 2006
    Nashville, TN
    Yes that is a problem with 9.1, I've seen posts of others having the exact same problem we have. Hopefully it will be resolved in a future update.
     
  8. alansplace

    alansplace ------ Alan ------

    804
    0
    Apr 30, 2006
    Southern...
    probably, but i really don't know. but when it comes to amazon they are extremely easy to deal with. just go to:

    phone contact

    and choose the 'phone' tab then a small 'Request call back' window will pop up. fill in the info requested and a customer service rep will phone you immediately.

    return it and exchange it for a new one.

    i've got two TiVo Hds and never had any of the issues you describe.
    --
    Alan :D
     
  9. alyssa

    alyssa Active Member

    1,655
    4
    Dec 7, 2003
    Sunny SoCal
    I just swaped out my S3 for a new one via Tivo. I got it 10 months ago. It cost me $49 for the swap out. I stronly suspect my HD was bad.

    The CSR I spoke with wasn't very knowledgeable but it did seem as tho they've had this problem a bit.
     

Share This Page