How to wipe a drive so Roamio will reload software

Discussion in 'TiVo Upgrade Center' started by TivoJD, Jan 26, 2020.

  1. TivoJD

    TivoJD Active Member

    408
    87
    Feb 7, 2005
    Polk Co,...

    Advertisements

    I have a Roamio that is stuck in CPI&TDL. I've had it happen to two TiVo's recently, a Bolt and a Roamio Basic. Bolt being replaced by TiVo, but for the Roamio (I highly doubt there is anything wrong with the drive), can I just connect to laptop and format the drive in windows and then throw it back into the Roamio and it will reformat the drive and put the software back on it?
     
  2. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,200
    1,047
    Apr 6, 2000
    SF Bay Area
    It is not on the drive, so wiping will not help.
     
  3. TivoJD

    TivoJD Active Member

    408
    87
    Feb 7, 2005
    Polk Co,...
    Someone mentioned in another thread in help center with the same issue that putting a new drive in cleared CPI&TDL hang. So I wondered if I wiped the original drive and put back into TiVo if that would work.
     
  4. kpeters59

    kpeters59 Well-Known Member

    2,995
    615
    Jun 19, 2007
    Houston, Texas
  5. TivoJD

    TivoJD Active Member

    408
    87
    Feb 7, 2005
    Polk Co,...

    Advertisements

    tried every kickstart I could find, always right back to CPI&TDL.
     
  6. ggieseke

    ggieseke Well-Known Member

    5,812
    722
    May 30, 2008
    The SQLite database is on the drive (on Roamios), so it may work. I would use the write zeros test in WD's Data Lifeguard Diagnostics, but formatting it as a Windows drive will work too.
     
  7. TivoJD

    TivoJD Active Member

    408
    87
    Feb 7, 2005
    Polk Co,...
    Thanks! I'll give the Data Lifeguard Diagnostics a try.
     
  8. TivoJD

    TivoJD Active Member

    408
    87
    Feb 7, 2005
    Polk Co,...
    One quick question, should I use the full erase or quick erase?
     
  9. jmbach

    jmbach der Neuerer

    3,034
    428
    Jan 1, 2009
    Have you tried KS 76543210?

    Try the quick erase first, then the long one if that does not work.
     
    skypros, lyee, elbaz and 1 other person like this.
  10. TivoJD

    TivoJD Active Member

    408
    87
    Feb 7, 2005
    Polk Co,...
    Thank you so much, that kickstart code worked (I've never seen that one before), brought me back to guided setup. Lost recordings, but at least I have a working box again.
     
    V7Goose likes this.
  11. jmbach

    jmbach der Neuerer

    3,034
    428
    Jan 1, 2009
    It is basically a factory reset.
     
    V7Goose and TivoJD like this.
  12. VideoGuyTim

    VideoGuyTim New Member

    6
    1
    May 8, 2019
    I experienced the CPI & TDL hang/loop for first time on a Roamio OTA. I wiped the HDD with WD DLG diags and verified it as ok. Connected it back in to the box and it booted up to GS and completed/works just fine. I need TE3 for S3 transfers and didn't want to risk a factory reset forcing TE4. I called TiVo technical support on the hang. They mumbled something about a known problem with CPI & TDL depending on whether the box is "on line" or not. They recommended only doing CPI & TDL as a last resort. I have been doing it to mitigate/prevent S03 errors on S3 boxes with stale guide data. Had never had this hang problem with the S3.
     

Share This Page

spam firewall

Advertisements