How to revive a fried drive with dd_rescue

Discussion in 'TiVo Underground' started by PortlandPaw, Aug 16, 2004.

  1. Jan 9, 2011 #101 of 109

    ss_sea_ya New Member

    Sep 2, 2010
    Alexandria, VA
    Already there on the "hours of reading" :up:

    My premise is the hard drive is good, boot sector data screwed up, and recordings are good. (if recordings screwed up, no sense in proceding). My goal is to copy the data, and then restore a good boot image to the new drive. If this process isn't doable, hopefully someone will let me know to stop hitting my head against a brick wall.:D

    So I've tried dd_rescue from free download here:
    It has an old version of dd_rescue and evenutally caused kernel panic (locked up).

    So then tried tools from, as they appear more recent and a later version of dd_rescue (along with the start from end of disk option). Had some better luck, but still had same problem. Tried both dd_rescue and backup/restore (full w/recordings). Both crap out within 15 minutes or so (about 50Gig gets transferred with dd_rescue. -r command didn't make a difference, it still crapped out.). Can get backup/restore to work without recordings, but new drive doesn't boot (as I expected).

    I may be having hardware issues causing the kernel panic so may try another hardware platform. Still might try the spinrite, but not there yet.
  2. ss_sea_ya

    ss_sea_ya New Member

    Sep 2, 2010
    Alexandria, VA
    Ok used a different hardware platform to run this stuff.

    To summarize, my replacement drive (WD 320G) stopped working after about 4 years. HDVR2 would get thru "Power up" and "almost there" then go blank, like in standby. green light blinks in response to remote/front keypad button pushes, but does not come on (including directv buttons). Put original drive in, works fine. Thus an issue with the hard drive.

    WD Diags quick test shows no errors.
    - Using MFSLIVE and it configuration for saving recordings, I ran the backup/restore command line to copied to new drive.
    - No errors were reported (it had the q switch, but showed progress).
    - MSINFO, comes back with bunch of stuff, but nothing that would appear to be an error msg (not that i would recognize one at this point in my knowledge ;) )
    - Put new drive back in tivo, same result as failed drive, gets thru "almost there screen" then nothing (like its in standby, but with green light on front) and no effect (other than light flash on button pushes).

    Ran kickstart code 58, when at the "almost there screen" said "installing service update". Took a while (10 min) then back thru reboot process and then back to blank screen with green light. (one time after this I left it on, and it rebooted after 5 more min then back to blank screen).

    ran code 57, this time GREEN SCREEN OF DEATH for about 10 min. It rebooted and attempted a dial in then nothing. Dialin prob didn't connect. (phone line connected)

    Ran kickstart code 56, get message "connecting to server... error : Bad Connection.) (phone line was hooked up). Green and yellow lights stuck on. (update: Found some post saying this is no longer supported.)

    UPDATE#1: Ran kickstart code 56, THIS TIME W/DLINK USB ETHERNET ADAPTER (NOTE: network driver was never installed, still running "factory" 6.4a software). Get message "connecting to server... error : No Server Directory Specified" (phone line was hooked up). Green and yellow lights stuck on. (Just interesting to note different error msg, but still yielded same result. Of course, now I wish I had installed the networking....may not have made a diff. but...). Tried the other usb port, same result.

    Update #2: Ran kickstart code 54, goes thru almost there screen, then blank with Green and yellow lights stuck on. (green light flashes with remote button pushes).

    Ran kickstart code 52 , rebooted after "almost there" and then blank with Green & yellow lights on)

    Ran kickstart code 51 , rebooted after "almost there", and went thru boot screens again, then nothing again. green light on.
    Kickstart code 0. rebooted after "almost there", and went thru boot screens At "power up" screen, it did dial out. Where and who, I have no idea. but prob didn't successfully connect to anything, seemed to "Line in Use" (observed from another extension) for less than 30 seconds. Finished going thru power up, almost there, then back to blank screen with green light.

    May try code 0 a few times to see if I can get a successful connections.
  3. ss_sea_ya

    ss_sea_ya New Member

    Sep 2, 2010
    Alexandria, VA
    Well, I read many posts through many archives and multiple web sites and all seem to be left unanswered with those that have get through "almost there" and then nothing.

    Some updates:

    1. dd_rescue (from MFSLIVE): Copies, no errors, no change.
    (I used MFSLIVE version as it seems to have a newer version of dd_rescue than the DVRupgrade LBA48 Boot Disk V4.04).

    2. WDC Diagnostic results:
    Quick Test: Passes
    Extended Test - Fails a few minutes (maybe less?) into the test "too many bad sectors". My speculation is disk appears to be "99%" full, so maybe no room to move bad sectors.

    3. WINSMFS copy - no errors, but no change

    4. Backup/Restore (MFSLIVE CD) and MFSCOPY(WINSMFS) No Errors, but no change.

    5. WINSMFS MFSCOPY from the original drive to new drive. Works fine (with 1 minor artifact that live video plays while in menu's).

    6. MFS Info - reads fine (on original, failed, and replacement drives)

    Most of the above were run using USB/IDE interfaces (dd_rescue was run both ways, originally using IDE ports and then later using USB/IDE interfaces.

    Some ideas yet to try:
    1. Run tools to add in the USB Networking to the tivo and explore more from there. (Will run these on the copied new drive, since I'm sure I will have a learning curve).

    2. I am conflicted with the results of "no errors" on the dd_rescue, WINSMFS copy, and the backup/restore, yet WDC diags Extended Test fails very quickly. Thus, I am not if this problem is a candidate for Spinrite since the reads *apparently* produce no errors. Then again, maybe its exactly what it needs...So after I play with the usb networking stuff, I may be back to spinrite as a last resort.

    So I still have not given up yet, but even if not successful, this is actually turning into a fun learning experience and hobby. And I will be sure to post my final results somewhere.
  4. ss_sea_ya

    ss_sea_ya New Member

    Sep 2, 2010
    Alexandria, VA
    Just in case anyone finds this thread, I never tried anything else to recover the disk/data. As timed passed, recovering the shows became less relevant, so I have essentially shelved the project (for now) and just installed a new image on my new disk to get the system up and running.
  5. Sep 7, 2011 #105 of 109

    stopright New Member

    Sep 6, 2011
    Never, never give up

    Are you sure you don't wanna dig up all of those hours of greatness? I was recently in the video store office discussing a few things with a friend and we overheard somebody talking about how they have an archive over 50 terabytes worth of shows. There has to be some pretty good laughs, cries, and spooks in there wouldn't you say? Sounds like it is about time to bust out the dvd burning software.
  6. ciper

    ciper Active Member

    Nov 4, 2004
    Wanted to add useful information to this thread. One of my Tivo has two 1tb drives. I could tell a drive was starting to act up. I didn't want to wait for one to finish copying and then come back and start the copy of the second. I don't trust that connecting a drive to port one means automatically it will be /dev/sda like most guys assume. So I did the following -

    Hooked all four drives (two old 1gb drives and two new 1gb drives) to the computer using onboard SATA.
    Booted into MFSlive cd

    hdparm -l /dev/sdX
    (X being A-D for every port to make sure where each drive was connected by model number )

    dd_rescue -y 2048 -v -b 4M -B 256 -l /drive1.log & /dev/sdc /dev/sdb &
    (copy original A drive to new A drive)

    (to find the process ID number which happened to be 946)

    kill -stop 946
    (this temporarily pauses the dd_rescue process)

    dd_rescue -y 2048 -v -b 4M -B 256 -l /drive2.log & /dev/sda /dev/sdd &
    (copy original B drive to new B drive)

    kill -cont 946
    (to restart the previous A drive copy process)

    The Ampersand after every command lets it run in the background. Now the two drives are both copying simultaneously. The output of the two commands sort of fight for screen space but the refreshes are slow enough that you can catch a glimpse of both of them. Right now the separate AVERAGE copy speeds are 42MB per second and 35MB per second, or a total of 77MB per second. This is on an old as dirt Pentium 4 550 processor desktop.

    Oh and if anyone cares I am using a Seagate ST1000DM003 as my A drive. I was able to boot the system with this drive as a test so it is at least potentially compatible. I am afraid it may not work because its both 6gb SATA and has advanced formatting without jumpers to disable either.

    Edit: The transfer speed average has gone up. It is now at a combined NINETY FOUR megabytes per second! The current measured actual speed is well over 100MBps. The two lines shown are the individual drives (notice the progress is different between the two)
  7. sfhub

    sfhub Well-Known Member

    Jan 6, 2007
    The last & on each line puts the command in background, but are you sure you need the first & (after the drive?.log) ?

    Instead of the PS and KILL, if you want, you can run the first command in foreground, then press ctrl-z to suspend it. This will stop the output so you can type the 2nd command, then type "fg %1" to resume the first command. It achieves the same thing you wrote, but you don't need to look for the process id of the first command.
  8. Sep 9, 2015 #108 of 109

    JohnnyBnyc New Member

    Sep 9, 2015
    Hi all,
    I haven't read the entire thread but I am posting just to let people know that this has worked for me.

    I used the precess at the link above for my failed tivo premiere xl hard drive. My drive failed the short test, the extended test showed errors and I was told by weaknees that it would be futile for me to try to revive the drive and get anything off of it. It was done!

    Well I bought a western digital drive of the same size and type and followed the directions at the above link and lo and behold it worked with flying colors. My tivo booted up and I am copying shows to my new tivo as I type this.

    So when in doubt try it yourself, sometimes the experts are wrong.
  9. Oct 9, 2015 #109 of 109

    unitron Well-Known Member

    Apr 28, 2006
    semi-coastal NC


    But you could have used a larger drive as the target, and then expanded with jmfs on a Premiere.

Share This Page