Hook Up Through HT Audio Reciever

Discussion in 'TiVo Stream 4K' started by Rickjb, Jun 9, 2020.

  1. Jun 9, 2020 #1 of 10
    Rickjb

    Rickjb New Member

    8
    3
    Jun 9, 2020
    Has anyone had any luck using the Stream hooked up to an HDMI input on their home theater reciever. I hooked mine up that way but suffered from frequent loss of sound and video (flicking to black for a second). I could watch the reciever appear to initiate the handshake multiple times while this was happening. I liked the device but sent it back because it didnt seem capable of maintaining a 4k hdr connection through the recvr to the TV, in addition to the otyermajor issues throughout this thread.
     
  2. Jun 9, 2020 #2 of 10
    viplob

    viplob New Member

    1
    0
    May 18, 2020
    I have hdmi handshake issues going through my samsung q90r soundbar. Black screen on the tv, but the HDR logo comes u though ;-)
     
  3. Jun 9, 2020 #3 of 10
    mattyro7878

    mattyro7878 Well-Known Member

    1,600
    387
    Nov 27, 2014
    Southern CT
    I have the stream4k hooked into one of my Sony 1040's HDMI inputs. It immediately knew the codecs to use..DD+ and so on. Volume immediately worked. I was amazed. I keep CEC off.
     
  4. Jun 9, 2020 #4 of 10
    Rickjb

    Rickjb New Member

    8
    3
    Jun 9, 2020
    Mine QUOTE="mattyro7878, post: 12069408, member: 298798"]I have the stream4k hooked into one of my Sony 1040's HDMI inputs. It immediately knew the codecs to use..DD+ and so on. Volume immediately worked. I was amazed. I keep CEC off.[/QUOTE]

    Mine works fine, too, as long as I back down the "Stream 4k" video from HDR. But I bought it for the 4K UHD, Dolby Vision, HDR. It's the only device going through my Onkyo Tx Nr 646 that can't function at the highest resolution with the Dolby Vision (HDR). I'm not sure your 2013 Sony is capable of passing HDR so it's probably a non issue for you.

    [
     
  5. pshivers

    pshivers Retired

    261
    39
    Nov 4, 2013
    Lubbock, Texas
    I have my TS4K connected to hdmi on my Onkyo TX-NR1030 receiver. It works without any issues now that the CEC fix has been applied. I do not have a 4K TV yet as my 10 year old Samsung 55" refuses to die! lol

    I'm using the Tivo Stream full time now, replacing my TiVo Roamio and my Roku. I did add a Air TV2 for OTA channels using the Sling app which is also working out well.

    Just about ready to cancel cable TV from Suddenlink as I will be saving some money and have programming much more to my liking from Sling.

    I will miss a number of the Tivo Roamio's features...

    Paul Shivers
     
  6. aaronwt

    aaronwt UHD Addict

    23,120
    1,092
    Jan 31, 2002
    Northern...
    With my Onkyo 656, the Stream 4k did not have any issues. 2160P60 with DV or HDR10 had no flickering or black screen issues.
     
    Rickjb likes this.
  7. Rickjb

    Rickjb New Member

    8
    3
    Jun 9, 2020
    Thanks. That's the info I was looking for. My xbox one s and Bolt work perfectly through the Onkyo 646 but the Stream 4k didn't. Maybe its HDMI cable shopping time.
     
  8. pshivers

    pshivers Retired

    261
    39
    Nov 4, 2013
    Lubbock, Texas
    I got an overall improvement on my Onkyo NX1040 when I swapped out all of my 10 year old "Amazon Basic" hdmi cables with new high quality cables.
    Primary improvement is my ARC channel works 100% of the time now, it was very temperamental with the old cables. I did use a little hdmi gender bender so I could connect my TS4K using the cable that use to be for my Roku.

    Paul Shivers
     
    Rickjb and aaronwt like this.
  9. Steveknj

    Steveknj Lost in New Joisey TCF Club

    53,371
    3,457
    Mar 10, 2003
    New Jersey
    I have mine going through my Denon AVR and since they fixed the CEC issues (Ive gone into settings and turned CEC off), it works better, but still not perfect, but I don't know if the issue is with my Harmony Remote or the AVR. When I switch inputs on the Harmony it often doesn't switch to the input and turn on the screen for the TiVo streamer. Also switching FROM the streamer to another input doesn't always work as it should and usually puts the AVR into mute. But, I will say that when I added the device to my Harmony, it didn't have the device listed to it had to "learn" the device. Has it been added to the Harmony database? Maybe once it's added, all the functionality will work correctly.
     
  10. Rickjb

    Rickjb New Member

    8
    3
    Jun 9, 2020
    Use Nvidia as the manufacturer and shield as the model number when adding a device to Harmony, assuming you have the Harmony hub, this should work. Not perfect but, pretty near.
     
    Steveknj likes this.

Share This Page