HME/VLC video streamer, v1.0 -- watch NASA TV, etc.

Discussion in 'TiVo Home Media Features & TiVoToGo' started by wmcbrine, Aug 23, 2008.

  1. orangeboy

    orangeboy yes, I AM orangeboy!

    4,089
    0
    Apr 19, 2004
    East Moline, IL

    Advertisements

    I've given up on those streams. I altered vlc.py to hardcode in the same samplerate as the source (16000), and found no joy. I eliminated all audio parameters except for codec specification, and had a shade of success with not getting any error messages, but I also had no audio. Meh. The content of those lectures in the streams wasn't what I thought it would be, so I'm not too bummed about not being able to view them on my TV.
     
  2. arrarrgee

    arrarrgee New Member

    39
    0
    Dec 21, 2010
    Hi Could someone help me install pytivo app pls...I tried adding the vidmgr to the pyhme framework of wmcbrine...(HME/VLC folder) i am posting my config file below with the changes I have made..pls help

    [hmeserver]
    port=9043
    datapath=C:\hme-vlc-3.6
    apps=vidmgr
    apps=hmevlc

    [tivos]
    tivo1.name=Family Room
    tivo1.tsn=313-22221-9044-1111

    [pytivos]
    pytivo1.config=C:\hme-vlc-3.6\start.conf
    pytivo1.ip=192.168.1.201
    pytivo1.port=9032
    pytivo1.sep=/

    [hmevlc]
    vlcport=9044
    vbitrate=2048
    abitrate=384

    [Videos]
    dir=e:/Movies
    dir=E:/iphone
    dir=E:/pics
     
  3. arrarrgee

    arrarrgee New Member

    39
    0
    Dec 21, 2010
    could someone help me find instructions for installing pytivo pls
     
  4. orangeboy

    orangeboy yes, I AM orangeboy!

    4,089
    0
    Apr 19, 2004
    East Moline, IL
    Take the dashes out of the TSN, or replace the TSN with the TiVo Name:
    tivo1.tsn=3132222190441111
    or
    tivo1.tsn=Family Room
     
  5. May 5, 2011 #405 of 481
    J.R.

    J.R. New Member

    5
    0
    Jun 7, 2009

    Advertisements

    I added a scheduled task on Windows 7 to run HME/VLC hidden on start up. Getting the following errors:


    HME Server for Python 0.18
    Skipping: apples - No application class
    Skipping: icons - No module named icons
    Thu May 05 01:22:09 2011 Server Starts
    Registering: hmevlc
    192.168.0.142:47056 - - [05/May/2011 01:22:10] "GET /hmevlc/icon.png HTTP/1.0" 2
    00 -
    192.168.0.142:47057 - - [05/May/2011 01:22:14] "GET /hmevlc/ HTTP/1.1" 200 -
    192.168.0.142:47057 - - [05/May/2011 01:22:14] Starting HME: hmevlc
    ----------------------------------------
    Exception happened during processing of request from ('192.168.0.142', 47057)
    Traceback (most recent call last):
    File "C:\Program Files\Python\lib\SocketServer.py", line 558, in process_reque
    st_thread
    self.finish_request(request, client_address)
    File "C:\Program Files\Python\lib\SocketServer.py", line 320, in finish_reques
    t
    self.RequestHandlerClass(request, client_address, self)
    File "D:\Downloads\TiVo\HME VLC Video Streamer\hme-vlc-3.6\start.py", line 139
    , in __init__
    client_address, server)
    File "C:\Program Files\Python\lib\SocketServer.py", line 615, in __init__
    self.handle()
    File "C:\Program Files\Python\lib\BaseHTTPServer.py", line 329, in handle
    self.handle_one_request()
    File "C:\Program Files\Python\lib\BaseHTTPServer.py", line 323, in handle_one_
    request
    method()
    File "D:\Downloads\TiVo\HME VLC Video Streamer\hme-vlc-3.6\start.py", line 230
    , in do_GET
    self._page(True)
    File "D:\Downloads\TiVo\HME VLC Video Streamer\hme-vlc-3.6\start.py", line 184
    , in _page
    appinst.mainloop()
    File "D:\Downloads\TiVo\HME VLC Video Streamer\hme-vlc-3.6\hme.py", line 1120,
    in mainloop
    while self.active and self.get_event():
    File "D:\Downloads\TiVo\HME VLC Video Streamer\hme-vlc-3.6\hme.py", line 1201,
    in get_event
    handle()
    File "D:\Downloads\TiVo\HME VLC Video Streamer\hme-vlc-3.6\hmevlc\__init__.py"
    , line 184, in handle_active
    self.push_menu(TITLE, items, RED)
    File "D:\Downloads\TiVo\HME VLC Video Streamer\hme-vlc-3.6\hmevlc\__init__.py"
    , line 289, in push_menu
    self.set_background(color)
    File "D:\Downloads\TiVo\HME VLC Video Streamer\hme-vlc-3.6\hmevlc\__init__.py"
    , line 192, in set_background
    self.root.set_image(self.graphics[color])
    File "D:\Downloads\TiVo\HME VLC Video Streamer\hme-vlc-3.6\hme.py", line 1021,
    in set_image
    self.set_resource(Image(self.app, name, f, data), flags)
    File "D:\Downloads\TiVo\HME VLC Video Streamer\hme-vlc-3.6\hme.py", line 716,
    in __init__
    f = open(name, 'rb')
    IOError: [Errno 2] No such file or directory: 'apples/red-hd.png'
    ----------------------------------------
     
  6. May 5, 2011 #406 of 481
    wmcbrine

    wmcbrine Well-Known Mumbler

    11,774
    848
    Aug 2, 2003
    Make sure you change to the HME/VLC directory before starting it.
     
  7. May 5, 2011 #407 of 481
    J.R.

    J.R. New Member

    5
    0
    Jun 7, 2009
    Thanks! I added the HME/VLC directory (C:\Program Files\hme-vlc-3.6) to the "start in" option in scheduled task.
     
  8. srhodian

    srhodian New Member

    4
    0
    May 10, 2011
    Hi Guys,

    I've installed HME/VLC and set it up as a scheduled task in Windows 7 but when I try to access any of the RSS feeds or my local videos I get an 'error reading from stream' on The Tivo.

    Looking at the HME logging, it does not appear to be doing anything, please see below:

    config.ini looks like the following:

    Any help that you can provide would be greatly appreciated.
     
  9. srhodian

    srhodian New Member

    4
    0
    May 10, 2011
    I added the "vlc=" line into the hmevlc section and got a little further...

    Now I get the following:
    Thanks again....
     
  10. J.R.

    J.R. New Member

    5
    0
    Jun 7, 2009
    Add start.py folder location in scheduled task > actions tab > start in option > C:\startpy\folder\location
     
  11. srhodian

    srhodian New Member

    4
    0
    May 10, 2011
    Thanks J.R.,

    Already done....
     
  12. wmcbrine

    wmcbrine Well-Known Mumbler

    11,774
    848
    Aug 2, 2003
    Yeah, that's not the issue here. What those errors say is that the TiVo doesn't like your file. You might try rebooting it... I dunno; it should automatically retry it with transcoding, but that doesn't seem to be happening. Is your VLC actually working?

    You might also try running qtfaststart on the file to make it streamable, assuming that it isn't now.

    You should still be able to access some files and most of the RSS feeds even without a working VLC, though.
     
  13. srhodian

    srhodian New Member

    4
    0
    May 10, 2011
    Rebooted the TiVo and still no good.... Can't even get to the RSS feeds.

    VLC is installed and working, how do I check to see if it is working with hmevlc?

    The files are streamable, they were created using MP4box (converting MKV to MP4) and I can view them if I initiate a push from PyTiVo (no transcoding occurs).

    Also tries disabling my firewall, just in case!
     
  14. wmcbrine

    wmcbrine Well-Known Mumbler

    11,774
    848
    Aug 2, 2003
    pyTivo incorporates qtfaststart, but HME/VLC doesn't, yet. (I've got to add that in one of these days.) My guess is that the files are of the type that need qtfaststart processing.

    When you say "can't even get to the RSS feeds"... what exactly are you seeing?
     
  15. TheWGP

    TheWGP Hmmm...

    299
    0
    Oct 26, 2007
    Hmm, I was linked here by a question someone posted elsewhere, but I'm actually trying to deal with the same issue right now - is there a way to use this to play .avi or .mkv with .srt subtitles on the Tivo? I actually don't care if it's streaming or copying, I'm just trying to figure out a way to get video + subs on the TV screen!

    I realize I can reencode to burn the softsubs in as hardsubs, but I'm willing to go to some length to avoid this for family-friendly reasons. ;)
     
  16. orangeboy

    orangeboy yes, I AM orangeboy!

    4,089
    0
    Apr 19, 2004
    East Moline, IL
    Use Streambaby:

     
  17. MrJedi

    MrJedi Member

    73
    1
    Apr 13, 2011
  18. wmcbrine

    wmcbrine Well-Known Mumbler

    11,774
    848
    Aug 2, 2003
    That's a good question. I get the NASA HD feed on my Roku, which I don't think uses Flash, but I don't know a URL for it.
     
  19. TheWGP

    TheWGP Hmmm...

    299
    0
    Oct 26, 2007
    EDIT:

    I managed to get PyTivoX working using the BETA version of it, which solved the issues I was having with 1.3.

    wmcbrine, apologies for the threadjack - your solution does look interesting but it's not quite what I need now. :)
     
  20. rajiv

    rajiv New Member

    13
    0
    Apr 1, 2002
    Cambridge, MA

Share This Page

spam firewall

Advertisements