HME apps on linux not visible on TiVo

Discussion in 'TiVo Home Media Features & TiVoToGo' started by s2kdave, Sep 5, 2007.

  1. s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005

    Advertisements

    Do any of you have HME apps running on linux? Have you ever seen the problem where they don't show up in your tivo, but if you run the HME simulator, it sees them fine?

    I just set up a linux machine and and moving my hme apps from my windows box to linux. It runs fine and I can use the application from the simulator on my windows machine, but when I go to my tivo, it can't see it. It's not a firewall problem because I've added iptables logging to log all traffic from my tivo. I can see it sending packets to my linux machine and they aren't being denied. It just doesn't show up in the list. I've also used wire shark to sniff the MDNS UDP packets that are sent for app discovery. I can see my app listed in the packet, however the packet doesn't look exactly the same as when the same app runs on my windows machine (excluding the IP).

    Any ideas?
    David
     
  2. F8ster

    F8ster The Very Last One

    232
    0
    May 26, 2002
    Hrmph. I swear I've had this working but I just tried it and I have the same problem as you. I know this works; I wrestled with the TrafficCam Viewer a while back a go and got it working (for Mac, at least) with the help of some other kind folks. See:

    http://www.tivocommunity.com/tivo-vb/showthread.php?t=352655

    I use Ubuntu in VMWare to test my releases, running in bridged mode, so it's a bit different. However, I now have the same problem as you: from Ubuntu, I run the app; I Ctrl+Alt back out to Windows and run the simulator, and the app shows up in the list at 192.168.1.104 (which is the correct bridged mode address for the Ubuntu instance) and runs fine. However, when I pop over to the TiVo, it's not in the list. I'm pretty sure I've successfully tested it in the past on both the simulator and on TiVo, but I wouldn't bet my life on it.

    I'll poke around and see if I can find anything.
     
  3. gonzotek

    gonzotek tivo_xml developer

    2,538
    59
    Sep 24, 2004
    Outside...
    IPv6 conflict possibly? I know the Galleon docs say to disable the ipv6 stuff for Ubuntu at least. Under Ubuntu 6.10 (Edgy Eft) and 7.04 (Feisty Fawn), it's enabled by default.

    For the record, I've got Galleon and several other tivo server programs running under Ubuntu 7.04, and can see them on both my 649 and 540.

    /edit: Reference to setting Galleon up on 6.06 (basically the same under 7.04):
    http://galleon.tv/component/option,com_joomlaboard/Itemid,26/func,view/id,901/catid,9/
     
  4. s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    Thanks gonzotek! That was it. I had ipv6 enabled and just had to disable it and reboot. Apparently that's a restriction with all HME apps and not just galleon. Or at least the ones that use the hme sample host.

    David
     
  5. F8ster

    F8ster The Very Last One

    232
    0
    May 26, 2002

    Advertisements

    Yay! Worked for me too. Good call.
     
  6. Albert Miller

    Albert Miller New Member

    3
    0
    Sep 3, 2007
    Las Vegas
    I had this same problem and disabling IPV6 stack solved the problem too.

    However, I am curious why when identical HME apps are ran on my Linux machines they don’t send out IGMP group membership packets as with the window machines. On the Windows machines an “IGMP Membership Report” packet is sent when the app is started, and “IGMP Leave Group packets” is sent when the app shuts down. All MDNS packets appear from both Windows and Linux machines.
     

Share This Page

spam firewall

Advertisements