Here's how to get Series2 to connect via broadband, step-by-step

Discussion in 'TiVo Underground' started by domlicious, May 6, 2004.

did this help resolve your broadband issue?

  1. hells ya!

    2 vote(s)
    14.3%
  2. yes

    1 vote(s)
    7.1%
  3. no

    3 vote(s)
    21.4%
  4. hells no!

    8 vote(s)
    57.1%
  1. domlicious

    domlicious New Member

    9
    0
    May 6, 2004
    fort...
    here's the skinny on getting your new series2 broadband tivo box actually connected over broadband (wired or wifi via usb) out of the box if you don't have a phone line!

    For those of us that ran out and snagged a series2 tivo unit because of the broadband ability, were probably cursing tivo when it turned out that you still have to make your very first guide-setup call over a phone line! Seems a bit self defeating if you ask me, but apparently they will start shipping series2 units with the ability to use a USB network connection to make your initial, and all subsequent calls, via broadband and never ever have to use a phone line even once.

    Until then, how do those of us that use our cell phones for everything and don't need a landline get past the initial guide-setup screen?? That was the question I was asking myself and through a mosaic of info posted via the tivo community, plus my own trial and error, my tivo series2 is now on my wireless WEP LAN and connects great to tivo for updates.

    The whole process, when you know what you are exactly supposed to do and in what order, is very simple... so have fun! For an FYI my unit is the Tivo brand Series2 40hour (pre-hack) 240 model.


    1) Follow the instructions per Otto's excellent walk-thru at: http://www.b-lan.com/otto/tivo3xp/
    You'll need a 9-pin female/female gender bending adapter and a "null-modem" adapter... which will come to a whopping $15 at your local Radioshack.

    *NOTE* Everything in Otto's "how to setup PPP via Serial" is correct except, one of the lines he has you change in the mdmhayes.inf file still didn't let me connect over the serial port after following all of his steps. If you find yourself in the same boat, attached is my .INF file that I downloaded from within the TivoCommunity site. Just replace your existing one with this one and your PPP connection should be good to go. This assumes that you have a general understanding of networking.

    2) Once you have completed the setup from step 1, execute the "test connection". The tivo should now be connecting via serial connection into your computer.

    3) Now that you have a tested and proved method of connecting to tivo without a phoneline, continue on with the initial guide-setup. Once the connection is complete, read the message that tivo sends you. Once my initial call was complete, I was no longer able to use the PPP over serial to make any form of connection... not even a test one. Maybe just something that happened to my configuration, but just a heads up.

    4) Now, your tivo should be processing all the data it downloaded and getting the box up to date with your cable's guide. Once that process is complete, move on to the next step.

    5) Your tivo software (if using Tivo's brand, or most others) will be version 4.0.1. "So can I get connected wirelessly now??" Not yet my friend.

    6) Supposedly from Tivo's approved list of adapters http://www.tivo.com/adapters, at this stage you should now be able to use a Linksys WUSB11 wireless USB adapter and you're off to the races. HOWEVER this was NOT the case for me. Since the WUSB11 I bought was pretty new, it shipped with v2.8 of the firmware (and version 4.0.1 of tivo's software only supports v2.6 of the firmware for WUSB11). Confused yet? :) Go ahead and try it if you like, maybe you'll get lucky and get one with the right firmware, but the sure fire way to get up and running broadband style from here is to go to the next step.

    7) Since none of my wireless USB adapters were working (NetGear's MA111, D-Link's DWL-122, not even the tivo recommended Linksys WUSB11) I ran out and returned the WUSB11 for the Linksys USB100M (but they say the USB200M will work too). Long and behold, I plugged in the USB100M to the tivo, plugged in a network cable from my Belkin Wireless AP/Router/switch and to the USB100M, and then restarted tivo via the GUI.

    *NOTE* You'll have to wait until tivo is done processing the initial data pulled down from your serial port call.

    8) After Tivo came online, I went to the setup screen and changed the connection option to use the Network instead of a phone line (an option not previously provided), and configuring the DHCP to be blank (all via Tivo's walk-thru). I logged into my router's administration page via my laptop and voila, there was the tivo box serial number, the usb mac addy and the DHCP assigned IP address. I followed that up with going to the settings section from within Tivo and it showed the MAC addy and IP address there as well. A test connection passed on the first go. So next I forced a download by connecting to Tivo and... can it be true??, the tivo was now running version 4.0.1b. The b version has all kinds of driver support, even for the NetGear MA111 and D-Link DWL-122 I use for wireless connections to desktops else where in the house.

    IF YOU ARE HAPPY WITH A WIRED CONNECTION, THEN THERE IS NO NEED TO CONTINUE... FEEL FREE TO READ ON TO SEE IF ANY OTHER INFO APPLIES - OTHERWISE, READ ON FOR WIRELESS


    9) Finally!! Then I simply unplugged the USB100M and plugged in DLink's DWL-122 wireless adapter and instantly tivo picked up the new hardware. It said that the firmware of the DLink device would need to be updated and tivo prompted if I wanted to continue. I first went back to the setup screen and changed the network connection's wireless settings. If your SID of your WirelessLAN is being broad-casted, your usb device will pick it up and alert tivo, and you should be able to select your LAN as the network you want to connect. Then, I setup the WEP configuration by telling tivo my encryption level and entering the key alphanumerically (HEX just takes too long to type in!). So thank god for tivo having the ability to hex convert a string of text into the WEP code you desired. The very last step was to make sure the DHCP was still set to blank in the TCP/IP settings of Tivo. So one restart later and a tivo walk-thru of the USB firmware download, the firmware for the DLink DWL-122 USB device was set and I was rocking and rolling.

    *NOTE*
    you may need to do an additional restart post firmware update but regardless... you should now be wirelessly connected! Oh, and don't forget to return that USB100M or USB200M if you don't need to use it else where... that's good money you can spend towards a bigger drive. :)
     

    Attached Files:

  2. yayalolo

    yayalolo New Member

    1
    0
    Dec 2, 2004
    I´m following each and every step, but I have a serius problem.

    I can´t find the following file

    c:\windows\inf\mdmhayes.inf

    Do you know what can I do if I don´t have it?

    Regards
     
  3. domlicious

    domlicious New Member

    9
    0
    May 6, 2004
    fort...
    have you tried doing a search on your entire drive for that file? If you still can't find it on your machine, maybe try grabbing the file that I attached in the initial post and place it in the correct path. Not sure if that'll work if you don't first have the file, but give it a go.
     
  4. wakti

    wakti New Member

    4
    0
    Dec 14, 2004
    Is there any way to adjust the intervals at which tivo connects for updates?
     
  5. tweak72

    tweak72 New Member

    3
    0
    Sep 18, 2005
    Hi,

    I found an excellent, detailed description of another way to get connected - i.e. by using a usb-to-ethernet adapter:

    Unfortunately, I can't tell you exactly what the URL is because this forum won't let me post a URL until I've made five posts; this is my first, and probably only post, now that this setup nightmare is finally over... (The forum worries I'm spamming or something by posting urls... geez try to do something nice.... )

    Anyway, if you google broadband, everything2 and phone, I think it should be the first item in the list. It's the only thing that worked for me. I was able to get set up using the belkin f5d5050 but NOT the linksys 200m usb-to-ethernet adapater. (the linksys one is a piece of crap, by the way.)

    Good luck.
     
  6. TiVOrange

    TiVOrange New Member

    1
    0
    Oct 24, 2005
    Virginia
    Found that the following inexpensive WIRED ethernet adapter works great with TiVo.

    "USB to 10/100 Mini Ethernet Adapter"
    Part: USB1100S
    Mfr: StarTech

    I got it for $9.95 online. I like it because it has a short cable. I just plugged it in, and it was detected without problems.
     
  7. Mako

    Mako Member

    79
    1
    Sep 22, 2002
    Blackwood, NJ
    This was helpful to know. My mother is getting a series 2 today and this is the cheapest at compusa. Nice to know it works.

    Thanks for posting your results. :)
     

Share This Page