Help test bug - unintended skip ahead

Discussion in 'TiVo Help Center' started by thenightfly42, Nov 26, 2005.

  1. thenightfly42

    thenightfly42 Señor Senior, Jr.

    836
    7
    Mar 5, 2002
    Connecticut

    Advertisements

    Over in the thread Unintended Skip Ahead, a few of us have been trying to track down a bug when you are fastforwarding, and you suddenly find yourself further ahead in the program than you expected.

    I have developed a set of instructions that demonstrate the bug. I'd like some help in narrowing down which portions of the instructions are not important.

    1. Schedule a 4 hour block recording in Medium quality (I found that Educational Access has 4 hour blocks).
    2. When 2 hours and 58 minutes have been recorded, begin watching the show from the start.
    3. Hit the fastforward button twice; the current position indicator will start moving forward along the green bar.
    4. Watch the right end of the green bar as it approaches the 3 hour tick mark.
    5. When the end of the green bar hits the 3 hour tick mark, the current position indicator (the white line with the time above it) should suddenly leap ahead by about 8 minutes.

    My stats:
    Series 2 60 hour TiVo. (I recently replaced the A drive with a larger Weaknees unit, but I had the problem before the replacement as well.)
    TiVo System 7.2.1. (I saw the problem in 7.2 and 7.1 as well. I've had the TiVo for a couple of years, and didn't see the jump on any previous system software.)
    Cable input, no box.
    Recording quality: medium. (I have also observed the problem in High.)
    Recording length: at least 3 hours.
    Watching "live behind the buffer".

    It is possible that the recording length and quality don't matter, but that it is more likely to hit the magic moment when watching a sports event, as there are more fast forwards and you are more likely to be watching as it records. It may be hardware specific.

    Things to test:
    1. Does it occur at 1x and 3x fast forward speeds?
    2. Does it occur on all hardware that has at least System 7.1?
    3. Does it occur at every tick mark?
    4. Is there a minimum recording length for this to occur?
    5. Is there some other criterion that I missed?

    Please help.
     
  2. NotVeryWitty

    NotVeryWitty Too Big to Fail

    904
    50
    Oct 3, 2003
    Central Mass.
    Hi Nightfly.

    I saw the problem three more times during the long Thanksgiving weekend (lots of football to watch). As before, it always happened when I was watching a show that was still being recorded. Also, the amount that it skipped ahead did not seem consistent, but was approximately 10 to 20 minutes ahead.

    FWIW, I record the shows in medium quality, and have only ever observed the problem at 2FF speed (I seldom use 3FF speed). I have seen it on two different Tivos running 7.X software (where X has been 1, 2, and 2.1) -- both unmodified Series 2 boxes, one 80-hour and one 140-hour.

    One thing I don't understand on your instructions to reproduce the problem -- you say to start doing 2FF when the recorded show hits 2:58, but then you say it should jump ahead by 8 minutes at the 3:00 mark. Won't it hit the end of the recording before 3:00 (or at least 3:08)?
     
  3. thenightfly42

    thenightfly42 Señor Senior, Jr.

    836
    7
    Mar 5, 2002
    Connecticut
    I'll edit for clarification -- is it clearer now?
     
  4. NotVeryWitty

    NotVeryWitty Too Big to Fail

    904
    50
    Oct 3, 2003
    Central Mass.
    I think so. I'll try it out in the next day or two...
     
  5. thenightfly42

    thenightfly42 Señor Senior, Jr.

    836
    7
    Mar 5, 2002
    Connecticut

    Advertisements

    To add to this analysis: under 7.2.2, the problem still exists. While my above steps-to-reproduce relied on the 'live time' crossing a tick mark, I have also now experienced this problem when the 'viewing time' crosses a tick mark.

    Show: Lost, 4-13 episode, with 2 minutes padding on either side (total: 1:08)
    Recording Quality: High
    Live Time: 9:53 PM EST
    Viewing Time: fastforwarding through the 0:30 mark

    The TiVo jumped during the fastforward from 0:30 to 0:35 with no audio indication of a jump.
     

Share This Page

spam firewall

Advertisements