help nuked my box

Discussion in 'TiVo Underground' started by gfr7, Oct 24, 2005.

  1. gfr7

    gfr7 Linux lacking user

    11
    0
    Oct 20, 2005

    Advertisements

    i have been tryn for the last week to get my mfsstream or tytools working on dtivo with 401b running on it. i have read the fourms untill i was crosseyed. today i tried to install xplus and twp+ kicked out this error

    hackman has found that /cron is being started by sysinit.author, and by rc.sysinit.
    hackman found $xPlusz_dir/cron startup commands in ect/rc.d/rc.sysinit but found /busybox/crond in the file scan cronpathname has been set to $xPlusz_dir/cron

    so thinking i was starting to get the hang of editing my files, i went into rc.sysinit and put a # in front of the lines (they were at the end of the file and easy to find)that were loading xPlusz ,thinking i had it figured out i rebooted and poof stuck at powering up.
    so i figure i have to put hd back in pc, run bootdisk and fix the file, the easy way would be to use a backup of sysinit but who learns that way?
    can someone please help me learn?
    p.s. i searched the fourms for an answer to this probb and found zilch

    Thank You ahead of time
    GfireRescue
     
  2. gfr7

    gfr7 Linux lacking user

    11
    0
    Oct 20, 2005
    #

    echo "rc.sysinit is complete"
    #/var/index/tyindex > /dev/null 2>&1 &
    #/var/index/tyserver >if [ -e /tvlib/xPlusz.anchor ]; then
    # xPlusz_dir=$(nthword 3 $(cat /tvlib/xPlusz.anchor))
    # if [ -e $xPlusz_dir/xPlusz.tcl ] && [ -x $xPlusz_dir/xPlusz.tcl ]; then
    # $xPlusz_dir/xPlusz.tcl >> /var/log/tvdebuglog 2>&1 &
    # fi
    # if [ -e $xPlusz_dir/sdelaysz.tcl ] && [ -x $xPlusz_dir/sdelaysz.tcl ]; then
    # if [ -e $xPlusz_dir/cron ] && [ -x $xPlusz_dir/cron ]; then
    # $xPlusz_dir/sdelaysz.tcl 180 $xPlusz_dir/cron
    # fi
    # fi
    #fi

    lines i tried to remove with what i think is a comment
     
  3. kaplansa

    kaplansa New Member

    5
    0
    Mar 26, 2005
    Probably not a big deal. Odds are you messed up the permissions of the file. This happens if you're not careful - rc.sysinit has to be CHMOD 755 in order for Tivo to start. When you saved your mods, your file probably changed to 644 or something like that and you didn't know to check before you rebooted. The easiest way to fix this now is to remove the drive(s) from Tivo, hook them up to a PC and boot one of the many Tivo boot CDs out there. Next, mount your Tivo drives and chmod rc.sysinit (and rc.* for that matter) to 755, umount and remove the drives and stick them back into Tivo. Good luck.
     

Share This Page

spam firewall

Advertisements