HELP.....MY TIVO IS DELETING EVERYTHING........

Discussion in 'TiVo Help Center' started by wjbatlanta, Feb 3, 2020.

  1. Feb 3, 2020 #1 of 64
    wjbatlanta

    wjbatlanta New Member

    17
    1
    Jun 29, 2011
    .....I noticed about a month ago.....with >50% frees space, programs started disappearing. I've lost my copy of yesterday's Super Bowl along with everything else back to December. When i go to recently deleted, I see 3 programs that i deleted over a year ago.....I called tivo tech support and they said they'd never heard of this but would submit the problem.........

    .........has anybody else had this problem.?? This is my 19th year with a TIVO - never had a problem like this before......(oh, any i ran diags - disc...etc check out ok).
     
  2. Feb 4, 2020 #2 of 64
    dianebrat

    dianebrat wait.. I did what? TCF Club

    12,665
    1,852
    Jul 6, 2002
    boston'ish
    50% space left means different things if you're on a 3TB unit vs a 500GB, knowing that would be helpful.
    Random and widespread deletes are frequently related to excessive usage of the KUID (keep until I delete) flag, just out of interest how many OnePasses do you have set to KUID and how many recorded programs have the same?
    It's also always worth a reboot if neither of those items above lead to answers..
     
    Willy92 likes this.
  3. Feb 4, 2020 #3 of 64
    wjbatlanta

    wjbatlanta New Member

    17
    1
    Jun 29, 2011
    thanks Diane for your response. I always get suspicious when something works differently that it has in the past 10-15yrs. I've had my drive (1tb) over 80% full and this has never happened......I think there may be a ton of stuff in my one passes but most is obsolete......could I have reached a point where there's too many even though most are not relevant?
     
  4. Feb 4, 2020 #4 of 64
    dianebrat

    dianebrat wait.. I did what? TCF Club

    12,665
    1,852
    Jul 6, 2002
    boston'ish
    The issue with excessive KUID is that when you have generic data for shows in the future that will clean up, the Tivo will prepare by making space for all those items, eventually that generic data will become specific data but it's too late.
    The answer is that if you have more than 2 or 3 KUID OnePasses this can happen, I can't explain the 3 old items, but the KUID issue is one of the most common for when someone all of a sudden says a Tivo is wildly deleting things.

    Between my 3 Tivo's 2 of which are 3TB with 70% used I have 3 KUID programs and zero KUID Onepasses and it has never deleted a show on me.
     
  5. Feb 4, 2020 #5 of 64
    wjbatlanta

    wjbatlanta New Member

    17
    1
    Jun 29, 2011
    ....OK - here's what I know. I bought a new desktop computer last week and installed pytivo. there was a problem with the disk so Dell sent me a replacement and i reinstalled the system - and again, installing pytivo. I just tried to copy a movie from my pc to my TIVO Premier and all of the program that are NOT KUID are gone......including the network news that i'm watching at the moment.

    Is there someone that knows the workings of pytivo that i can reach out to?

    thank you again!
     
  6. Feb 4, 2020 #6 of 64
    wjbatlanta

    wjbatlanta New Member

    17
    1
    Jun 29, 2011
    .....one other fact that i can add is that it will not allow me to move anything from my pc to the TIVO (I can do the reverse). When I try, what I mention above happens. The TIVO will sometimes hang and require a restart. I am running the last version of pytivo that was made available thru notification of a newer version.
     
  7. Feb 4, 2020 #7 of 64
    kpeters59

    kpeters59 Well-Known Member

    2,860
    582
    Jun 19, 2007
    Houston, Texas
    I'd guessed that you were copying files back to the TiVo.

    While the file is transferring, the TiVo sees a VERY HIGH bit rate, which TiVo (seems) to use to miscalculate the required disk space for the transfer.

    -KP
     
  8. Feb 5, 2020 #8 of 64
    wjbatlanta

    wjbatlanta New Member

    17
    1
    Jun 29, 2011
    yes - thank you - that is correct.... I recorded a couple programs tonight w/o KUID. Tried to transfer a movie and it happened again - everything w/o KUID was gone.
    I've used pytivo for quite a while and never had a problem......i tried an old release with the same result. the only other variable that changed is the new computer running win10 64bit.

    does anybody know what changed?
     
  9. Feb 5, 2020 #9 of 64
    Sparky1234

    Sparky1234 Well-Known Member

    2,275
    336
    May 8, 2006
    Never ran across your issues with various TiVo boxes and pytivo. I never set KUID for recordings but have used it on a limited basis for specific programs or movies. I've filled TiVos to 95% without issue too. I usually try to keep them under 80%.
    Are you using TE3?
    What TiVo box?
     
  10. dianebrat

    dianebrat wait.. I did what? TCF Club

    12,665
    1,852
    Jul 6, 2002
    boston'ish
    OK, that's the kind of information that would have helped in your original post and would have changed my answer to more of what @kpeters59 has pointed you at, that's not "deleting for no reason" that's "doing something new and deletions are now happening"
     
  11. wjbatlanta

    wjbatlanta New Member

    17
    1
    Jun 29, 2011
    Sorry Diane......I didn't know that when I first posted the message. Odd that TIVO can't elaborate either?
     
  12. wjbatlanta

    wjbatlanta New Member

    17
    1
    Jun 29, 2011
    Hey thanks Sparky1234......same with me - I had my drive almost totally full with no probs. This just started happening every time i try to transfer from my pc to TIVO. I remember something this happening once back in November but ignored thinking it was a new TIVO OS and maybe a glitch (and, I was still on my old windows 7 64bit computer). I have a PremierXL w/1tb internal and 1tb eSata external. I've also run all of the diags and everything checks out.

    kpeters59's theory makes sense.....but scratching my head on how to proceed.....go back to TIVO's software? Like I mentioned yesterday, the only variable that has changed was the new computer. I've made sure it had the latest windows patches.....

    Funny, I've owned a TIVO since 2003 (series 2) - only problems were when I moved up to the Premier installing and pairing the cable card + (later) a very worn out remote.
     
  13. dianebrat

    dianebrat wait.. I did what? TCF Club

    12,665
    1,852
    Jul 6, 2002
    boston'ish
    Tivo support is useless and reads purely off a script since they were bought by Rovi, them not knowing is SOP
     
  14. Sparky1234

    Sparky1234 Well-Known Member

    2,275
    336
    May 8, 2006
    Could your external HD be causing problems?
     
  15. m_jonis

    m_jonis Member

    676
    6
    Jan 3, 2002
    Albany, NY
    I've noticed this just recently as well.
    Tivo Bolt
    and
    Tivo Bolt Vox
    Both are 500 GB drives

    I only have ONE onepass set for "KUID" all the rest are keep 25 episodes and "until space needed"
    I noticed on the "going away soon" or whatever, it showed a TON of stuff that was going to be deleted in 24 hours (on BOTH units), yet there's a crap ton of stuff in the "suggestions" folder.

    NONE of the stuff being deleted in 24 hours was "suggestions" but stuff that was in the "keep until space needed"

    One Tivo had 80% space used and the other was at 56%

    Now, whether or not it WOULD have deleted, I don't know, I didn't take any chances. I deleted everything in suggestions and binge watched a bunch of stuff, but it didn't make a difference according to the "going away soon".

    I think there's a bug, but that's just me.
     
  16. JoeKustra

    JoeKustra in the other Alabama TCF Club

    19,383
    3,500
    Dec 7, 2012
    Ashland, PA...
    No, the odds favor a bug. BTW, if you set your 1P (and default) to "Keep at most:" to ALL, those yellow dots will stop. They don't really mean much anyhow.

    Also, if you transfer a program to a different TiVo, it will become KUID without your help in a week or so. That is a bug.
     
  17. m_jonis

    m_jonis Member

    676
    6
    Jan 3, 2002
    Albany, NY
    Thanks for the info. I didn't know about the "yellow dots" stopping. I do think it deleted a bunch of Judge Judy's on me though.

    Hopefully in a week this'll be over/done as I'll upgrade the HD to a 2 TB drive in both units.

    Interesting. I didn't know that the transfer switched things over to KUID. The one Tivo had those, the other did not, so perhaps it's changed those settings and causing the issue on the one Tivo ( not sure about the other though as I did re-verify the OnePass settings and cleaned up a few things that I didn't want anymore).

    Either way, I'd think that theoretically if you set all your stuff to KUID that it would cleanup suggestions first instead of leaving those around.

    Thanks for the info!
     
  18. wjbatlanta

    wjbatlanta New Member

    17
    1
    Jun 29, 2011
    .....just to add - i took the eSATA HD off and it still performs the same. not only is everything (not KUID) deleted but, DELETED (not recoverable) - gone......and to recap - I've used pytivo for as long as i can remember and it's never done this before. I did try rolling Windows10 64bit back thru system recovery prior to installing pytivo - installed a very old version and it did the same, removing everything - could it possibly be a new version of TIVO OS?
     
  19. m_jonis

    m_jonis Member

    676
    6
    Jan 3, 2002
    Albany, NY
    Well, just double-checked everything. To clarify, both BOLTs are 500 GB units. Can't remember what my old XL4 is (1TB or 2 TB), but it never got above like 35% full.

    Tivo #1 - NO onepass had "KUID", and the Tivo just deleted a bunch of shows that weren't marked in "yellow" (they were blue icons I think). Non-recoverable. However, "space" was at like 76%

    Tivo #2 - ONE onepass had KUID, it also deleted a bunch of my stuff that had been transferred (via the Tivo website "transfer" process) from my old XL4. Fortunately I still have the XL4 and can re-transfer. Space was at 56%

    So seems like a bug, IMO, at the least, a really crappy design, as Tivo #2 HAS a bunch of "suggestions" that, IMO, should've been deleted before onepass stuff.

    Will be upgrading hard drives to 2 TB this weekend, hopefully, and hoping that'll solve the issue. I never saw this on my XL4 units, but then again, those had larger hard drives and never got more than 35% full.

    But then again, they were on TE3, I think and the Bolts are on TE4.
     
    Last edited: Feb 6, 2020
  20. shaggy2002

    shaggy2002 Member

    54
    1
    Dec 15, 2007
    I have used Tivos for over 17 years and always have KUID on my OnePasses (season passes.) I have never had an issue with this. I have noticed that one of my tivos that is at 100% full has been recording new content and I have deleted anything so I am assuming it is deleting programs on me behind the scenes as well.
     

Share This Page