Help - I think I killed my Tivo

Discussion in 'TiVo Upgrade Center' started by gogzhad, Jan 6, 2006.

  1. gogzhad

    gogzhad New Member

    7
    0
    Jan 7, 2003

    Advertisements

    Help - think I killed my Tivo - what options?

    --------------------------------------------------------------------------------

    hello all,

    I've been happily using my modified Series 1 Sony Tivo (extra drive) for a couple of years now with no problems. I've had a network card plugged in there for a long time, and finally decided to hook it up so I could ditch the phone line.

    Immediately prior to this, the Tivo had somehow gotten fouled up and wouldn't work - but it seemed to return to life after I unplugged it and plugged it in again, appearing to need only a daily call to get back up and running.

    I couldn't get it to make the daily call over the phone line (it kept failing during download - message was 'call interrupted') so I hooked up to the network and successfully made a daily call. I also modified the case to be able to use the network card.

    When I buttoned it all up, the Tivo works (tivo display comes through on channel three of the tv just as before) but it keeps telling me it can't receive channels (I get the channel title box when I change channels, but there seems to be no other effect - the tv remains on whatever is on channel three). I've checked the cable connection, it's good, I've restarted, and I've even redone guided setup, and still it will not receive channels - like the RF tuner is broken or something.

    Anyway, first, any suggestions for things to try? Second, if the tivo is indeed dead, what are my options? I have a lifetime subscription - will I lose it if I get a different tivo box, or can I re-use the number? Can I simply find an otherwise working series one box and put my hard drives in it?

    Btw, my Tivo is running software in the 3.xx range - is this current?

    Thanks in advance,

    dave
     
  2. funtoupgrade

    funtoupgrade New Member

    2,000
    0
    Mar 15, 2005
    Sounds like your RF tuner is bad. Lifetime goes with motherboard not hard drives so repair is only option to preserve lifetime. From previous posts it appears Sony only fixes and does not replace and I read somewhere their charges start at $150. They told me they will not even quote a price until the unit is received at their only repair facility somewhere on the east coast. Also sounds like your modem is toast.

    TiVo has no interest in upgrading software on old series one units. They would rather see them trashed and the user get a new series two.

    If I were in your shoes I would sell it off on eBay as is describing fully the problems and use the money to buy another TiVo. If you are trying to save money you could opt for a used Philips series one lifetime (they replace unit for $80 if hard drive good and transfer lifetime to new unit). If you want series two I would buy Humax since they are currently replacing defective units regardless of warranty status to build business.
     

Share This Page

spam firewall

Advertisements