Help! Horrible issues with Premiere since new update

Discussion in 'TiVo Help Center' started by myershouse, Sep 18, 2017.

  1. myershouse

    myershouse New Member

    1
    0
    Sep 18, 2017

    Advertisements

    I am please hoping for a little guidance with my TiVo premiere.

    Up until the latest software update, my premiere has worked like a dream.

    Now, there is no guide, and simple things like changing the channel are a task. Almost every time I even change the channel, it takes up to a minute to do it, and even then, the screen often goes black, and then it reboots. It's awful!

    It also won't connect to the network, however I know it's connected to my ethernet, because my internet is working fine, and I have been able to watch Netflix (even though it freezes from time to time).

    I was going to do a guided setup, but the warning on the screen beforehand makes me think it could possibly make things worse.

    I have looked on the forum to see if anyone else has a similar issue, but from what I've seen, it looks like most issues are just no guide for a while.

    If anyone has any suggestions, they are welcome! Thanks in advance.
     
  2. ACABThomas

    ACABThomas New Member

    4
    0
    Jan 30, 2005
    I'm having a similar experience with my Premiere and have not yet found a solution. In my case, it will record shows fine, I can watch both recorded shows and live TV, but then seemingly randomly, when I do anything that causes it to switch from the TiVo menus to start playing video (e.g., hit play on a recorded show, select a different channel in the guide, etc.), the screen goes black as it's switching over and never comes back. The only way to fix it is to unplug and reboot the TiVo.
    I tried running the Kickstart to check the hard drive, it reported no problems. Hoping someone here has other ideas.
     

Share This Page

spam firewall

Advertisements