HDVR2 Power Problem. Any Ideas?

Discussion in 'DirecTV TiVo Powered PVRs & Receivers' started by clueless2, Jan 24, 2006.

  1. clueless2

    clueless2 New Member

    62
    0
    Jun 24, 2004
    I have a Hughes HDVR2 that started getting stuck at "Powering Up" after an AC Power flicker. This was ~ 9 months ago. Since I had an HR10 on the primary viewing TV and the set the HDVR2 was on was used mainly for news in the morning I just hooked up an old standard received and put the HDVR2 in the storage room.

    Last week I found out a buddy of mine had just purchased a copy of Spinrite so we ran the HDVR2s disk thru a level 4 scan.

    Today I put the disk back in the HDVR2 and when I plug it up I get nothing. No power light. No fan. Nadda.

    I didn't see an obvious fuse or circuit breaker. I checked all the connectors.

    My voltmeter is busted but I did check and there is AC getting to the power supply.

    It has been disconnected from AC for ~ 9 months. I did NOT try it before I removed the disk.

    Any ideas?
     
  2. Dkerr24

    Dkerr24 Lost in Big Bend

    2,450
    0
    Oct 28, 2004
    Okla, USA
    Sounds like the Power Supply inside the unit may be toast. Only way to know for sure is to hook up a voltmeter to it.
     
  3. litzdog911

    litzdog911 TechKnow Guide

    12,021
    0
    Oct 18, 2002
    Mill Creek,...
  4. cheer

    cheer Registered Offender

    1,406
    0
    Nov 13, 2005
    Gurnee, IL
    Check the little stiff ribbon cable that goes from the motherboard to the front panel. It's very easy to knock it partially loose when you pull or reinstall the HD, and when I've done that I've gotten the same symptom -- no power, no fan, etc. Re-seating the cable into the slot on the motherboard fixed the problem.

    Worth a try before you buy a new power supply, anyway. :)
     
  5. clueless2

    clueless2 New Member

    62
    0
    Jun 24, 2004

    Didn't work. So it probably is the PS. Guess I'll buy a cheapo multimeter and make sure before I buy a new PS for $50.

    Thanks for the help guys.
     

Share This Page