HD250 HDMI finally bites the dust...

Discussion in 'DirecTV TiVo Powered PVRs & Receivers' started by marcries, Jan 7, 2006.

  1. marcries

    marcries New Member

    20
    0
    Sep 5, 2004
    I purchased a DTV HD250 in November of 2004 and have had no major problems as of this morning... when I turned on the unit and everything was in "solarization" video mode.

    Did the usual reboot, checked the TV via other devices, tried the component connections, etc. and they all worked. Then I noticed that unplugging and replugging the HDMI connector gave me good video for about 2 seconds.. then back to solarized video output.

    I purchased it thru Circuit City with an extended warranty and so called them up. Based on the accent, I will assume that I was speaking to INDIA. I was originally told by the CC salesperson that if it ever failed, I could just bring it to my local CC for an exchange/repair. However, the only choices "india" allowed is a refurbed unit in a week via a credit card deposit or a refurbed unit in two weeks w/o a deposit. Since the component output works and I hate giving my credit card number to foreign countries that don't have any privacy laws, I've gone with the 2 week option.

    After seeing a thread topic called "6 bad HD250's in a row" I don't have a very high level of confidence that the refurbed unit will be trouble-free for any length of time...
     
  2. litzdog911

    litzdog911 TechKnow Guide

    12,021
    0
    Oct 18, 2002
    Mill Creek,...
    The odds are good that your replacement will be just fine. Remember that most all of the people visiting this forum are here because they're having a problem, and they represent a very small percentage of the total HR10-250 owners.
     
  3. borgslayer

    borgslayer Master

    92
    0
    Mar 28, 2004
    SoFLa
    That was my thread... I acutally, insisted thru retention that a new unit be sent, I would no longer accept any refurbs. To my amazement a new unit showed up on my doorstep, followed by a refurbed 3 days later. Unbelievable but true, the new unit is working great, it has Ver. F installed AND the logos are intact!!!
    Good luck.
     
  4. wje

    wje New Member

    166
    0
    Jan 7, 2005
    New...
    If you get a unit manufactured after Dec 04, you shouldn't have any more HDMI problems; the card was redesigned to elminate the failures that were happening.

    The problem with a refurb, and one reason for multiple failures, is that DTV just seems to take returned units and ship them out to someone else without any testing or fixing at all. That happened to me twice. I finally ended up swapping parts until I had a working unit. Everything's been fine since then.

    Best bet would be a new unit, but if you can only get a refurb, it should be obvious pretty quickly if it works or not. Be sure to check both tuners and the HDMI output.
     

Share This Page