Hacking your Series 2 DTivo just got a WHOLE lot easier...

Discussion in 'TiVo Underground' started by Gunnyman, Oct 16, 2005.

  1. Oct 26, 2011 #11841 of 11850

    PortlandPaw Woodstock-era Hacker

    Jan 11, 2004
    It could be that you're using the wrong image. Not all 6.4a files are created equal. They differ by host machine, i.e. a Hughes image differs from a Philips image differs from a Samsung image. I'm reminded of that now as an admonition that I first saw about ten years ago -- "don't be a moron" was the mantra. Don't try to mix software and machines as it either won't work well or will mess with TiVo's and/or DirecTV's communications with the machine.

    Beyond that, I would stick with 6.2a as that version still has HMO and MRV available as a hackable option with the Zipper. The only advantage I saw to 6.4a was the unerase feature, but TivoWebPlus has had that for years.

    To be sure of using the correct image, www.dvrupgrade.com is still your best bet. Sorry to see that Lou has doubled his price to $40, though. Still worth it to resurrect an old machine.
  2. Oct 26, 2011 #11842 of 11850

    unitron Well-Known Member

    Apr 28, 2006
    semi-coastal NC
    Go here:


    Read and learn.

    It's only 6 pages.

    When you finish, go back and read it again.

    Not all SATA to IDE adapters are equal.

    You have to worry about which chipset you're getting, and if there's any way to set it for Master or Slave or Cable Select.

    As for the one you linked to, apparently you didn't read the reviews.

    Here's the pertinent one


    There's another, different adapter on Amazon that should arrive tomorrow. If it works in a Series 2, I'll post a link on that other thread and back here.


    Okay, something was at the back of my mind. Looks like the HDVR2 is a Series 1 Series 2, and can only use a Marvell chipset adapter.
  3. Oct 27, 2011 #11843 of 11850

    rpweaver New Member

    Sep 28, 2010
    Where is Zipper version 4.6? The Zipper_Version_History.pdf file created 6/3/2008 included in the zip file linked from this thread has this
    "4.5 Use updated enhancement script."
    as the last line. The instructions page starts with this:

    The Zipper
    Version 4.6
    Last Updated 7/10/08

    The version is different and the date is different. I would like to use the most up-to-date version and see if that solves my problem with 6.4a.
  4. Oct 27, 2011 #11844 of 11850

    PortlandPaw Woodstock-era Hacker

    Jan 11, 2004
    So let me ask: Is your 6.4 image file from the same brand of machine that you're trying to rebuild?
  5. Oct 30, 2011 #11845 of 11850

    rpweaver New Member

    Sep 28, 2010
    I had the same issue with a RCA DVR40 for a while with WD 500G EIDE hard drive (new). I also have a Hughes DVR80 that did not have the error with the same hard drive model. I rebuilt the drive for the RCA and the SMART error stopped. I never found out what the problem was, however.
    Unfortunately, I am having other problems...
  6. Oct 30, 2011 #11846 of 11850

    rpweaver New Member

    Sep 28, 2010
    I thought I figured out my problem. When I ran Zipper, I always answered to include wireless networking. This worked for 6.2 but not for 6.4a. I found a page that said I had to Monte to use wireless with 6.4a. (I can't find that page now, Is there an Index/roadmap somewhere?). It showed how to do a manual monte. I rebuilt the drive with 6.4a and Zipper and answered No to the wireless and everything seemed to be working. I was so positive about it that I created a backup and I did the same for the Hughes DVR80 and called DirecTV to activate it. After some hours later, I found that the RCA DVR40 was frozen, no response to the remote, no response to the serial line (lots of stuff on the HyperTerminal screen) and showing a gray screen on the TV. Later, I found the other DTIVO did the same thing. I have a Linksys USB200M that works until the thing freezes. With 6.2 I had everything working OK.

    After about 3 reboots each, things seem to be working now. One has been on for 15 hours. The other, Fakecall didn't work so I rebooted it again. I will report back in a couple days. I will need to power them off to put them back together before the weekend, otherwise I hope they don't need a reboot in the mean time.
  7. Nov 7, 2011 #11847 of 11850

    Dpordy99 Member

    Nov 7, 2011
    wow this is pretty helpful
  8. Nov 19, 2011 #11848 of 11850

    rbautch User

    Feb 5, 2004
    Chicago, IL
    There is a script I wrote called drivemonitor.sh that is running every day as a cron job. It constantly checks your hard drive for errors and checks your kernel log for error messages that are indicative of a drive failure. When it finds an error, it logs it to the messages screen on your tivo. When you ran the enhancement script, you answered "yes" to this feature. If you don't want it any longer, you can delete the cron job, or turn off the logging feature. Read the drivemonitor thread to learn how to do this. Hint: google drivemonitor.sh.
  9. Feb 28, 2012 #11849 of 11850

    joeblow17 New Member

    Nov 4, 2005
    Hey longtime everyone! I hope all is well...

    Has anyone have a chance to test the new THR22 TIVO? It has been quite a while since I have posted here, but wanted to see if this might bring the zipper back to life.

    I noticed the new device doesn't have MRV or the ability to transfer shows like the old TIVO HD boxes. I am hoping the hacks will become available soon and will likely purchase the set box in the near future.
  10. Feb 28, 2012 #11850 of 11850

    Wil Unknown Member

    Sep 26, 2002
    At "the other place" where all the good stuff began, there is zero discussion.

    The DirecTV hardware on which this DTivo resides has never been hacked as far as I know.

Share This Page