Hacking your Series 2 DTivo just got a WHOLE lot easier...

Discussion in 'TiVo Underground' started by Gunnyman, Oct 16, 2005.

  1. Jan 14, 2006 #2641 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL

    Advertisements

    Is your USB200M a version 1 or 2?
     
  2. Jan 14, 2006 #2642 of 11850
    Jefferson

    Jefferson New Member

    6
    0
    Apr 5, 2005

    I started with a blank drive and an instantcake image, but zipper detects my tivo as hr10-250, when i have a sd-dvr40. Could I have gotten the wrong image or is this the same problem that rabeten was having?

    Thanks
     
  3. Jan 14, 2006 #2643 of 11850
    Gunnyman

    Gunnyman Just a boring dude

    31,914
    956
    Jul 10, 2003
    Upstate...
    this IS most likely the result of the wrong instant cake image.
     
  4. Jan 14, 2006 #2644 of 11850
    stingerxxx

    stingerxxx New Member

    25
    0
    Jun 24, 2005
    Hey guys, great job on zipper, From what I've read and seen looks like a top notch script. Now I just want to be able to access my DTVtivo using the USB port from my laptop and maybe pulla show or 2 off. WIll zipper do this or do I need something else. I have a drive with zipper inatalled but I haven't tried it out in my Box because I dont have adapter to connect to my network. For now I just want to By-pass the network side. So was wondering if not zipper what will allow me to use my laptop and usb to access it? Sorry if this is in wrong thread.
     
  5. Jan 14, 2006 #2645 of 11850
    hpfanatic

    hpfanatic Member

    42
    0
    Jan 5, 2002
    Pacific NW

    Advertisements

    I got mine figured out. I do have a USB200M version 1 after all, it was the network cable I was using that was bad. I now have it on my network and finishing the install.
     
  6. Jan 14, 2006 #2646 of 11850
    Jefferson

    Jefferson New Member

    6
    0
    Apr 5, 2005
    looks like my image was old (3.1.1 i think) so i bought a new 6.2 image, but now i keep getting incomplete image restoration. It stoppes at 98.% and says "restoration failed: premature end of backup data."

    i even wiped the drive with zeros and tried again. Same result. Any thoughts?
     
  7. Jan 14, 2006 #2647 of 11850
    Gunnyman

    Gunnyman Just a boring dude

    31,914
    956
    Jul 10, 2003
    Upstate...
    how large a drive?
     
  8. Jan 14, 2006 #2648 of 11850
    lord-dogbert

    lord-dogbert New Member

    98
    0
    Jan 30, 2005
    Fontana, Ca

    Had the same problem, really wreaked havoc on my recordings, thank the gods for merge.
    1st go to hackman in twp and stop cron. I had constant odd reboots then actually ended up coinciding with the 5 minute checker. Let it run for a few days with cron off and see if that helps. Remember that cron will restart on reboot of Tivo.

    2nd check for a huge season pass. Wife added a keyword wishlist for "christmas" at the end of November. There were WELL over 1000 entries however Tivo could only deal of 200 at a time. This caused a bunch of havoc on my sd-dvr120.

    I've also heard of problems with the backported drivers for the hr10-250. Ran into this as well.
     
  9. Jan 14, 2006 #2649 of 11850
    Jefferson

    Jefferson New Member

    6
    0
    Apr 5, 2005
    80 gb western digital.
     
  10. Jan 14, 2006 #2650 of 11850
    hpfanatic

    hpfanatic Member

    42
    0
    Jan 5, 2002
    Pacific NW
    I got my HR10-250 all completely zipped and done and working perfectly. I then took the drive out and did a backup, and then used MFSADD to add on a 300gb drive as drive B. Seemed to be fine, no errors. Then I put both back in the DirecTivo and boot up. It goes to the Almost There screen for a few seconds, then I get the GSOD which reboots in about 5 seconds. It is now in an endless loop. I tried redoing the MFSADD, but got an error, Nothing To Add. I tried setting the jumpers on the drives to CS, but that did nothing. I was so close! What do I do now?
     
  11. Jan 14, 2006 #2651 of 11850
    Hick

    Hick New Member

    13
    0
    Jan 10, 2006
    Thank you for your awsome script! I now have 2 of my 3 Tivos Zippered!
    Here's a list of my netperf stats:
    Code:
    TCP STREAM TEST to 192.168.0.50
    Recv   Send    Send                          Utilization       Service Demand
    Socket Socket  Message  Elapsed              Send     Recv     Send    Recv
    Size   Size    Size     Time     Throughput  local    remote   local   remote
    bytes  bytes   bytes    secs.    10^6bits/s  % S      % S      us/KB   us/KB
    
    131070 131070 131070    10.15         4.57   16.46    73.86    295.084  1324.467
    
    Im scratching my head doing searches on a thread to help me decipher if the speeds are good? I am assuming I am getting 4.56mb/sec for speed, which seems slow, but I am able to copy files fairly quick from system to system. Are there any threads someone can point me to learn about netperf?

    Everything worked great, I ran into the same problem that JoeBlow17 did with the large drive not accepting the image when restored from the zipper.sh script. I restored the image manually with -b instead of -x and loaded the extra partitions manually. Once I did that, I had no problems.

    Here's the stats for my model as both units are identical:

    SIR-S4080R
    200 GB Drives
    Zippered 1/11/2005
    One has a Linksys USB100M
    Other is an Acton Technologies F=MA 1046A (Some generic thing that I got with my RR cable modem but it works!)
     
  12. Jan 14, 2006 #2652 of 11850
    Gunnyman

    Gunnyman Just a boring dude

    31,914
    956
    Jul 10, 2003
    Upstate...
    ok which image?
    if you got an 80 gig HD image, either buy a LARGER HD or a Smaller 40 hr image.
     
  13. Jan 14, 2006 #2653 of 11850
    Jefferson

    Jefferson New Member

    6
    0
    Apr 5, 2005
    after the restoration problems, i tried the instantcake method, and it still didn't work. It got to about 96% restored and the computer hung. The compression information started going berzerk.

    Well I re-downloaded the instantcake iso to see if I corrupted the file during download, i did get a 000001 file of a different size, so i burned a new tools disk, now i get a decomression error about 80% finished.

    Only thing i can think is that i got a bad image. I'm going to check with PTV, as even the Instantcake method isn't working.

    sorry i didn'd see your post. I am using the 6.2 instantcake image for the SD-DVR40 from PTVnet.

    The very first zipper i ran was flawless on this drive, it was just the wrong image (3.1.1) when i changed to the 6.2 image, can't seem to restore the image.
     
  14. Jan 15, 2006 #2654 of 11850
    boostin4hp

    boostin4hp New Member

    14
    0
    Jan 20, 2005
    Hey thanks for the reply but its a brand new hard drive.
     
  15. Jan 15, 2006 #2655 of 11850
    Jefferson

    Jefferson New Member

    6
    0
    Apr 5, 2005
    Thanks Zipper guys!!!!

    I finally downloaded instantcake a third time (this time through microblows IE instead of Firezilla) and the image worked great. I am now at the telnet stage.

    Do i HAVE to do any telnetting? Do I need any of the enhancements right away? It seems that i cant use the Now Playing to watch anything. I don't have the phone hooked up. Do i have to make one call initally or can i ignore the phone line?

    Sure wish i could use my wusb54g linksys adapter, it looks like i'll be digging around for a hunk of cat5 and hope i still have some ends laying around, so i can hardwire..
     
  16. Jan 15, 2006 #2656 of 11850
    ttodd1

    ttodd1 Proud Computer Geek

    1,516
    0
    Nov 5, 2003
    SC

    Doesn't mean it isn't bad/going bad.
     
  17. Jan 15, 2006 #2657 of 11850
    zgolfing

    zgolfing New Member

    9
    0
    Jan 15, 2006
    Guys you are amazing, followed your instruction and all is working except this nagging error 51.

    I ran the 51killer.tcl but it did not work?

    tivosd-TiVo# 51killer.tcl by AlphaWolf_HK
    51killer.tcl by AlphaWolf_HK

    This script will clear the error #51 nag from a hard drive that was transfered
    from one tivo to another.

    WARNING: Because the key generated for this nag is also used as part of the
    encryption process for tystreams, any encrypted (scrambled) streams that you
    currently have on the disk will be rendered useless!

    Do you want to continue? (type yes or no):
    y
    Not changing anything.
     
  18. Jan 15, 2006 #2658 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Yes it will work with your laptop. Instead of entering the IP of your router, enter the IP of your laptop. Make sure you're using a cross-over cable.
     
  19. Jan 15, 2006 #2659 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Before you run the Zipper, install the image and marry the drives using instantcake. Then run the Zipper on the master drive only.
     
  20. Jan 15, 2006 #2660 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    A decompression error could indicate a bad CD burn. Are you using a well-worn CD-RW?
     

Share This Page

spam firewall

Advertisements