Hacking your Series 2 DTivo just got a WHOLE lot easier...

Discussion in 'TiVo Underground' started by Gunnyman, Oct 16, 2005.

  1. Jan 11, 2006 #2561 of 11850
    webbuzz

    webbuzz New Member

    16
    0
    Jan 11, 2006
    Atlanta, GA

    Advertisements

    Hi everyone

    I have attempted the zipper on a new WD HDD. But, the following error keeps popping up when trying to load the instacake image from the tools CD

    0x00-1: syntax error in expression (error token is "0x00-1")


    My CD contents match what gunny shows on his page

    Any ideas? I have searched everywhere for the solution. Is it possible that my image is corrupt?

    Thanks in advance

    Bill
     
  2. Jan 11, 2006 #2562 of 11850
    lee espinoza

    lee espinoza some guy

    2,442
    0
    Aug 21, 2002
    San Antonio,TX
    the Zipper instructions say to Burn the tools disk in "Joliet mode", not ISO9660 mode.

    does anyone know a free download item that will do that?
     
  3. Jan 11, 2006 #2563 of 11850
    Gunnyman

    Gunnyman Just a boring dude

    31,914
    956
    Jul 10, 2003
    Upstate...
    lee, nero can do it just fine.
     
  4. Jan 11, 2006 #2564 of 11850
    bka2007

    bka2007 New Member

    1
    0
    Jan 11, 2006
    First of all, Congrats to Gunnyman & rbautch, for such a well engineered script. Great Job! :up: I ran the script last night on a SIR S4080R, after having rewired our home network. 2 routers, 5 computers and now DTivo. The first time I ran the Zipper, I got read errors all the way thru, but script said "success". I remounted in Dtivo and it booted and ran. no errors, but no networking. Router assigned it a ip though. Removed and tried running in an updated computer that has all known good hardware. Still read errors. At this Point I came back to the boards and searched for burning problems with Nero. Saw a few threads indicating there may be a problem in the way Nero was burning the tools disk, so I downloaded a free Burner Program called CDBurner XP Pro 3. I toasted and retryed back on original computer. Worked like a charm. Reinstalled in tivo and booted, rebooted, to lock in the IP I had set, Then telneted in on the first try. Ran the enhancement script and viola, I've got a hacked DTivo. Other than the usual trial and error with the burning of the tools disk this was a breeze. Easier than doing a stage 1 Gentoo install by far. Again kudos to you guys and Keep on Keepin' on. :up: BKA
     
  5. Jan 11, 2006 #2565 of 11850
    webbuzz

    webbuzz New Member

    16
    0
    Jan 11, 2006
    Atlanta, GA

    Advertisements

    I decided to apply the Instacake Image to my HDD first, then I ran the zipper.


    Success!

    Thank you Gunnyman and Rbautch. If you are ever in Atlanta I will buy you dinner.

    Bill
     
  6. Jan 11, 2006 #2566 of 11850
    Tivogre

    Tivogre Well-Known Member

    1,542
    177
    Jul 12, 2002
    Springfield, VA
    I just realized that cron is not set up correctly on my boxes.

    Crond is not running; cronlogs are empty.

    If ffind cron, i get:

    /var/spool/cron
    /enhancements/varhacks/spool/cron

    If I ffind crond i get:

    /busybox/crond

    the rc.sysinit.author DOES show:

    #############################################
    # start crond after waiting 30 seconds
    sleep 30
    /busybox/crond


    What is the easiest way to set up cron without "undoing" other hacks on the box?
     
  7. Jan 11, 2006 #2567 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Cron is set up just the way I intended. Crond is the actual application binary, stored in busybox. Cron is the directory that holds you crontab and logs, and is stored in /enhancements/varhacks/spool/cron. What you see as /var/spool/cron is a symlink to /enhancements/varhacks/spool/cron, done this way to keep the actual files out of /var. Navigate to /var/spool/cron, and enter ls -l, and you'll se what I mean. Also not the different color of the symlink versus the actual directory. If you're having problems, start by entering ps at bash to see if crond is running. If so, check out the troubleshooting posts in the enhancement thread.
     
  8. Jan 11, 2006 #2568 of 11850
    stingerxxx

    stingerxxx New Member

    25
    0
    Jun 24, 2005
    I've been watching and reading the threads here. My question is, is the PTVnet, or instantcake cd a complete diferent option to Zipper. or do I need to use both., I have'nt been able to locate the answer.
     
  9. Jan 11, 2006 #2569 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Instantcake is a product for upgrading your tivo to a larger hard drive(s), and contains a software image. PTVnet is a tool that hacks your drive, and can be used instead of the Zipper. You can use instantcake to apply an image to your drive, and then use the Zipper, or you can extract the image from the instantcake CD, put it on your tools disk, and let the Zipper install it for you.
     
  10. Jan 11, 2006 #2570 of 11850
    webbuzz

    webbuzz New Member

    16
    0
    Jan 11, 2006
    Atlanta, GA
    How long will it take for my local channels to appear? I only have access to the premium, ppv and XM channels.

    Will I need to call DirecTV :confused:
     
  11. Jan 11, 2006 #2571 of 11850
    lee espinoza

    lee espinoza some guy

    2,442
    0
    Aug 21, 2002
    San Antonio,TX
    bash-2.02# cd /hacks
    bash-2.02#
    bash-2.02# sh tweak.sh
    Existing rbautch_files.tgz archive found in /hacks/
    Skipping new script download...

    Running rbautch Hacked Tivo Enhancements...
    tar: inflate error 2
    tar: Unable to read all data
    tar: Unable to read all data
    mv: /enhancements/tweak_uninstall.sh: No such file or directory
    Checking your telnet settings. Do you want to continue? [y/n]: y



    Your telnet client is adding extra line feeds, causing this script to fail.
    No problem. Just re-run the script again using the "Additional
    Directions for Windows XP users", or use a different telnet client with
    the proper CR/LF settings. Exiting now...

    bash-2.02# y
    bash: y: command not found
    bash-2.02#
    bash-2.02#

    were can I find the Additional
    Directions for Windows XP users? I look at http://www.mastersav.com/tivo_tweak.html and I did not see any
     
  12. Jan 11, 2006 #2572 of 11850
    lee espinoza

    lee espinoza some guy

    2,442
    0
    Aug 21, 2002
    San Antonio,TX
    Nevermind I used PuTTY and it start to work
     
  13. Jan 11, 2006 #2573 of 11850
    jp999

    jp999 New Member

    1
    0
    Aug 15, 2004
    Great script and tools. Thank you.

    sh tweak.sh
    When the script got to
    "Adding the alias "speed" to your profile to run netperf..."
    /enhancements/start/sh: /.profile: Read-only file system

    And then from then on, it said "Read-only file system after a lot of commands it was trying to do.

    I then canceled (ctrl-C), did the uninstall, then

    mount -o remount,rw /
    re-ran the script, and now it does not have the errors.
    At the end for saftey, I did:
    mount -o remount,ro /

    Does that sound like things are ok?


    Note: I did not run the main script because I already had the killhdinitrd's kernel installed and had a bash prompt on telnet.
    I have:
    DTivo Samsung DIR 4040 Series 2, 6.2 downloaded from DirecTV some months ago,
     
  14. Jan 11, 2006 #2574 of 11850
    lee espinoza

    lee espinoza some guy

    2,442
    0
    Aug 21, 2002
    San Antonio,TX
    call 1800-531-5000 and when it ask is there a number on your tv put in 722
     
  15. Jan 11, 2006 #2575 of 11850
    gnut

    gnut Tivo and Golf Nut

    7
    0
    Jan 11, 2006
    Raleigh NC
    And another success story! Been reading the thread for sometime just didn't have the nads to piss my wife off! So decided the heck with it. Got everything working the first 2nd time, Screwed up the first and searched and found how to fix it. Isn't 2nd time the charm anyway :) Guys, I don't know how much I need to thank you, my second dvr should be here anyday, and I cant wait. Gunny, Rbautch, If you are ever in Raleigh, drinks and dinner are on me!

    Thanks,
    Randy
     
  16. Jan 11, 2006 #2576 of 11850
    lee espinoza

    lee espinoza some guy

    2,442
    0
    Aug 21, 2002
    San Antonio,TX
    Installation Complete!! and every is fine on my end


    thanks Gunny, Rbautch
     
  17. Jan 11, 2006 #2577 of 11850
    webbuzz

    webbuzz New Member

    16
    0
    Jan 11, 2006
    Atlanta, GA
    Lee - Thanks for the help! I knew I saw that somewhere I just couldn't find it.
     
  18. Jan 11, 2006 #2578 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    There's new instructions in town. The difference is that if you use:
    telnet -t vt100 tivoipaddress
    from a windows command prompt, it will not add line feeds. Terraterm works right out of the box. I could never find the setting to get PuttyTel to stop adding line feeds. Anybody know?
     
  19. Jan 11, 2006 #2579 of 11850
    Tivogre

    Tivogre Well-Known Member

    1,542
    177
    Jul 12, 2002
    Springfield, VA
    No. It's 711.
     
  20. Jan 11, 2006 #2580 of 11850
    lee espinoza

    lee espinoza some guy

    2,442
    0
    Aug 21, 2002
    San Antonio,TX
    722 works too.
     

Share This Page

spam firewall

Advertisements