Green screen boot loop

Discussion in 'TiVo Upgrade Center' started by tommage1, Jan 30, 2021.

  1. tommage1

    tommage1 Well-Known Member

    1,947
    454
    Nov 5, 2008

    Advertisements

    Got an S3 in a green screen boot loop. After running KS57. I seem to remember there is an MFST command that may fix this. Anyone know what it is?
     
  2. jmbach

    jmbach der Neuerer

    3,179
    475
    Jan 1, 2009
    You could try KS 58.

    Other thing you can try is MFSTools. You can use mfsck to change the flag in the MFS header to OK. If nothing it horribly out of wack, it should boot and not boot loop.
     
    tommage1 likes this.
  3. tommage1

    tommage1 Well-Known Member

    1,947
    454
    Nov 5, 2008
    Ok thanks, I already tried the 58, no help, the mfsck command is what I was trying to remember, it has worked for me before. Is that command listed in the extensive list of mfst commands? I checked there first, could not find it but I may have missed it, if it is there could you mention exactly where so next time I can just check the command list, thanks.
     
  4. tommage1

    tommage1 Well-Known Member

    1,947
    454
    Nov 5, 2008
    Checked the MFST command list again. ck is listed under commands. But it just says something like "simple consistency check". Then again the list of commands I looked at was under MFST 3.2 thread from 2015 ;) Maybe there is an updated list of all commands, perhaps for latest version of mfst?

    Post #2.

    MFS Tools 3.2
     
  5. jmbach

    jmbach der Neuerer

    3,179
    475
    Jan 1, 2009

    Advertisements

    Simple. mfsck -m 1 /dev/TARGET

    Sent from my SM-G988U using Tapatalk
     
  6. tommage1

    tommage1 Well-Known Member

    1,947
    454
    Nov 5, 2008
    Right, I just meant when searching ck just said "simple inconsistency check", that was not enough for me to realize that was the command I was looking for. Ie the one to change the flag (maybe a more detailed description of what ck is capable of.) But all good, thanks.
     
  7. tommage1

    tommage1 Well-Known Member

    1,947
    454
    Nov 5, 2008
    Just FYI worked like a champ. Not only got out of the green screen loop, am back to fully functional, as it was before it even needed the KS57.
     

Share This Page

spam firewall

Advertisements