getting tivo web to work outside my network

Discussion in 'TiVo Series 1 - UK' started by jonmon, Oct 10, 2011.

  1. jonmon

    jonmon New Member

    116
    0
    Jan 19, 2010
    Hi there:)
    I have another issue with new upgrade. I can get tivo web to work on my network but I gave my friend my network ip address and says could not connect to server. I have tried it with my 3g phone and it doesn't work either. I dont know much about this stuff but do think its the modem thats the prob not the tivo and its something i got to change on the modem web page? The modem is a Thomson modem from plusnet.
    thanks for any help:)
     
  2. staffie2001uk

    staffie2001uk New Member

    176
    0
    Apr 1, 2004
    Preston,...
    You need to route the incoming web request to the TiVo IP within your network. This will be called different things on different modem/routers. On my netgear it is "Firewall Rules". You select the service (Web/http) and select the destination as the IP of the TiVo within the network.

    If you need more specific guidance, post the make/model of your modem.

    Hope this helps.
     
  3. steveroe

    steveroe Must do some work...

    1,136
    5
    Oct 29, 2002
    Oxford, UK
    I think your question has been answered over on your identical post on the tivoland forums.
     
  4. jonmon

    jonmon New Member

    116
    0
    Jan 19, 2010
    Thanks both for the reply:)
    I tried the procedure in the other tivo forum but I must be doing something wrong as I am having no luck. This is what he told me to do

    1) Select "Create a new game or application"
    2) Give it a name you can remember and set it to "Manual Entry of Port Maps".
    3) Set the "trigger" to TCP, "port range" to 8080-8080 and "translate to" to 80.
    4) Now select "Assign a game or application to a local network device"
    5) Under "Game or Application" in the drop-down box select the name you entered for step 2)
    6) Under "Device" select "<User defined...>".
    7) Enter the IP address of the TiVo in the new box that just appeared.

    I have done protocol "any" port range "8080 to 8080" translate to "80" and trigger protocol drop down menu "TCP" trigger port is blank. I am not sure if I am meant to leave trigger port blank?

    The router is a Thomson TG585 V8

    I haven't much of a clue what I am meant to do so any help would be much appreciated. :up:
     
  5. steveroe

    steveroe Must do some work...

    1,136
    5
    Oct 29, 2002
    Oxford, UK
    I suggest you post your further update over on the Tivoland to try and keep this on one forum and avoid duplication

    <edit>I see you have done this.
     
  6. mikerr

    mikerr TiVoCentral.co.uk

    2,599
    0
    Jun 2, 2005
    Lancashire, UK
  7. jonmon

    jonmon New Member

    116
    0
    Jan 19, 2010
    I dont really understand the port that needs to be forward? This is a bit frustrating, I dont think it can be that difficult but I just dont understand whats what when it comes to this router internet stuff. The site suggests different ports but I am guessing that there is a right port for my tivo:?: I dont know what I am doing really need more help. I have wrote the same thing on other tivo forum but had no reply so I thought I would try here again
    thanks:)
     
  8. bri_tal

    bri_tal New Member

    56
    0
    Sep 21, 2005
    Can I jump in on this one and seek your advice ? I also, want to be able to access TivoWebPlus from remote computers outside my network and in my case, the network router is a Netgear DG834GT. Could you explain please, what settings need to be made to router and tivo, to achieve this with some degree of security ?

    TIA
     
  9. drgeoff

    drgeoff Member

    63
    0
    Nov 10, 2005
    @bri_tal
    The info given above is suitably generic to apply to your Netgear. You need to open a TCP port so that data to that port from outside your home network is directed to port 80 on your TiVo.

    Because port 80 may already be in use or may be needed in the future, port 8080 is often chosen for the external side and the router's firewall configured to translate that to 80.

    In your router's configuration GUI this may be called "port forwarding" or "game and application sharing" etc.

    The minimum security is to apply a username and password prompt. For tivoweb this is accomplished by editing a couple of lines in tivoweb.cfg. (It will be obvious once you see the contents of this file of half a dozen or so lines.) For non-AltEPG Tivos that file is frequently in the /varr/hack/tivoweb-tcl directory. It may be in a different place in TiVos running the AltEPG image. I have no experience with TWP but expect it to be similar.

    Unless your ISP provides you with a static IP address, you will probably want to use a service such as that available at http://dyn.com/dns/dyndns-free/. Most routers support that and/or one of the alternatives - check your router.
     
  10. Trinitron

    Trinitron New Member

    411
    0
    Jan 20, 2003
    North West
    To those that are unsure, bear in mind that if you choose 8080 as the external port, access through a web browser needs you to entering yourwebaddress:8080 - if you omit the numbers it defaults to port 80.
     
  11. bri_tal

    bri_tal New Member

    56
    0
    Sep 21, 2005
    Thanks for the replies. I tried no-ip.com, which appeared to be a simpler solution than dyn.com but couldn't get it to work. It seems that my problem is in making the neccessary changes to the router - particularly the router's firewall. I'm a complete novice as far as routers go.
     
  12. drgeoff

    drgeoff Member

    63
    0
    Nov 10, 2005
    The "no-ip.com" (or alternative) is independent of the port forwarding. Get the latter working first - you can test it with the IP address you get when you go to www.whatismyip.com from your PC's browser. If you put "Netgear DG834GT port forwarding" into Google there are plenty of hits. See http://www.tivoland.com/forum/viewtopic.php?f=8&t=1026&start=30#p9739 for how to test the port forwarding.

    Also, TWP configuration seems to be different from TiVoweb. See the discussion at http://www.tivoland.com/forum/viewtopic.php?f=16&t=1028, posts #4 and onwards.
     
  13. bri_tal

    bri_tal New Member

    56
    0
    Sep 21, 2005
    I have checked with the Gibson Research site and a probe on ports 8075-8080 shows stealth status for all. How do I get port 8080 to be opened in my router settings ?
     
  14. bri_tal

    bri_tal New Member

    56
    0
    Sep 21, 2005
    Further to my previous message, I created a rule under Security>Services, in my router, allowing access through port 8080 and Shields up confirms that it is open.

    In my router's firewall, I have allowed inbound traffic to the service specified above, specifying the Lan server address as that allocated to my tivo and have turned-on remote access to such address, for everyone.

    In TWP2, I have specified a username and password in tivoweb.cfg.

    All that remains is to test it remotely, fingers crossed.

    I'm sure I will be back with further questions, though.

    Thanks for the help, thus far.
     
  15. drgeoff

    drgeoff Member

    63
    0
    Nov 10, 2005
    Re tivoweb.cfg (TWP2 not TW), in the second TiVoland forum thread I mentioned there is a post by millsb which includes:
    "1. Have you set LAN_Auth = 1 ? Without that any connection from your local LAN won't require authentication"

    which I take as meaning the username/password stuff isn't active unless that line is present.
     
  16. bri_tal

    bri_tal New Member

    56
    0
    Sep 21, 2005
    I read that as simply meanig that if one needs to have ones LAN protected from other users of the local network, then the Lan setting needs to be set to 1.

    If I can get my remote connection to work, I'll be able to tell whether or not a password is requested.
     
  17. spitfires

    spitfires wassock

    724
    0
    Dec 19, 2006
    South Coast, UK
    From http://tivo/docs/tivoweb_cfg.html

     

Share This Page